summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-phpunit-php-code-coverage5-fonts.patch20
-rw-r--r--php-phpunit-php-code-coverage5.spec20
3 files changed, 22 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index 7cc4f8c..23b7a12 100644
--- a/composer.json
+++ b/composer.json
@@ -25,7 +25,7 @@
"ext-dom": "*",
"ext-xmlwriter": "*",
"phpunit/php-file-iterator": "^1.4.2",
- "phpunit/php-token-stream": "^2.0",
+ "phpunit/php-token-stream": "^2.0.1",
"phpunit/php-text-template": "^1.2.1",
"sebastian/code-unit-reverse-lookup": "^1.0.1",
"sebastian/environment": "^3.0",
diff --git a/php-phpunit-php-code-coverage5-fonts.patch b/php-phpunit-php-code-coverage5-fonts.patch
index a981850..09d5f18 100644
--- a/php-phpunit-php-code-coverage5-fonts.patch
+++ b/php-phpunit-php-code-coverage5-fonts.patch
@@ -1,16 +1,16 @@
diff -up src/Report/Html/Facade.php.rpm src/Report/Html/Facade.php
---- src/Report/Html/Facade.php.rpm 2017-03-03 07:14:13.503062385 +0100
-+++ src/Report/Html/Facade.php 2017-03-03 07:16:38.118761058 +0100
-@@ -134,7 +134,11 @@ class Facade
+--- src/Report/Html/Facade.php.rpm 2017-11-28 06:14:43.754075896 +0100
++++ src/Report/Html/Facade.php 2017-11-28 06:16:31.423668936 +0100
+@@ -144,7 +144,11 @@ class Facade
$dir = $this->getDirectory($target . '.fonts');
- copy($this->templatePath . 'fonts/glyphicons-halflings-regular.eot', $dir . 'glyphicons-halflings-regular.eot');
- copy($this->templatePath . 'fonts/glyphicons-halflings-regular.svg', $dir . 'glyphicons-halflings-regular.svg');
-- copy($this->templatePath . 'fonts/glyphicons-halflings-regular.ttf', $dir . 'glyphicons-halflings-regular.ttf');
+ \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.eot', $dir . 'glyphicons-halflings-regular.eot');
+ \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.svg', $dir . 'glyphicons-halflings-regular.svg');
+- \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.ttf', $dir . 'glyphicons-halflings-regular.ttf');
+ if (file_exists($font='/usr/share/fonts/glyphicons-halflings/glyphicons-halflings-regular.ttf')) { // System font
-+ copy($font, $dir . 'glyphicons-halflings-regular.ttf');
++ \copy($font, $dir . 'glyphicons-halflings-regular.ttf');
+ } else {
-+ copy($this->templatePath . 'fonts/glyphicons-halflings-regular.ttf', $dir . 'glyphicons-halflings-regular.ttf');
++ \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.ttf', $dir . 'glyphicons-halflings-regular.ttf');
+ }
- copy($this->templatePath . 'fonts/glyphicons-halflings-regular.woff', $dir . 'glyphicons-halflings-regular.woff');
- copy($this->templatePath . 'fonts/glyphicons-halflings-regular.woff2', $dir . 'glyphicons-halflings-regular.woff2');
+ \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.woff', $dir . 'glyphicons-halflings-regular.woff');
+ \copy($this->templatePath . 'fonts/glyphicons-halflings-regular.woff2', $dir . 'glyphicons-halflings-regular.woff2');
diff --git a/php-phpunit-php-code-coverage5.spec b/php-phpunit-php-code-coverage5.spec
index affb586..b873b1a 100644
--- a/php-phpunit-php-code-coverage5.spec
+++ b/php-phpunit-php-code-coverage5.spec
@@ -9,7 +9,7 @@
%global bootstrap 0
# Github
-%global gh_commit 8e1d2397d8adf59a3f12b2878a3aaa66d1ab189d
+%global gh_commit 033ec97498cf530cc1be4199264cad568b19be26
#global gh_date 20150924
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
%global ver_major 5
%global ver_minor 2
-%global ver_patch 3
+%global ver_patch 4
%global specrel 1
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -43,7 +43,7 @@ Group: Development/Libraries
# ASL 2.0: nvd3
License: BSD and MIT and ASL 2.0
URL: https://github.com/%{gh_vendor}/%{gh_project}
-Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
# RPM specific changes: use system .ttf file
Patch0: %{name}-fonts.patch
@@ -55,7 +55,7 @@ BuildRequires: php(language) >= 7.0
BuildRequires: php-composer(phpunit/php-file-iterator) < 2
BuildRequires: php-composer(phpunit/php-file-iterator) >= 1.4.2
BuildRequires: php-composer(phpunit/php-token-stream) < 3
-BuildRequires: php-composer(phpunit/php-token-stream) >= 2.0
+BuildRequires: php-composer(phpunit/php-token-stream) >= 2.0.1
BuildRequires: php-composer(phpunit/php-text-template) < 2
BuildRequires: php-composer(phpunit/php-text-template) >= 1.2.1
BuildRequires: php-composer(sebastian/code-unit-reverse-lookup) < 2
@@ -78,7 +78,7 @@ BuildRequires: php-pecl-xdebug >= 2.5.5
# "ext-dom": "*",
# "ext-xmlwriter": "*",
# "phpunit/php-file-iterator": "^1.4.2",
-# "phpunit/php-token-stream": "^2.0",
+# "phpunit/php-token-stream": "^2.0.1",
# "phpunit/php-text-template": "^1.2.1",
# "sebastian/code-unit-reverse-lookup": "^1.0.1",
# "sebastian/environment": "^3.0",
@@ -90,7 +90,7 @@ Requires: php-xmlwriter
Requires: php-composer(phpunit/php-file-iterator) < 2
Requires: php-composer(phpunit/php-file-iterator) >= 1.4.2
Requires: php-composer(phpunit/php-token-stream) < 3
-Requires: php-composer(phpunit/php-token-stream) >= 2.0
+Requires: php-composer(phpunit/php-token-stream) >= 2.0.1
Requires: php-composer(phpunit/php-text-template) < 2
Requires: php-composer(phpunit/php-text-template) >= 1.2.1
Requires: php-composer(sebastian/code-unit-reverse-lookup) < 2
@@ -185,7 +185,6 @@ fi
cat << 'EOF' | tee tests/bootstrap.php
<?php
-require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php';
require __DIR__ . '/TestCase.php';
define('TEST_FILES_PATH', __DIR__ . '/_files/');
EOF
@@ -194,9 +193,8 @@ ret=0
for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd $EXT \
- -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+ -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{ver_major}/autoload.php \
%{_bindir}/phpunit6 \
- --filter '^((?!(testForClassWithAnonymousFunction|testTextForClassWithAnonymousFunction|testGetLinesToBeIgnored3|testCloverForClassWithAnonymousFunction)).)*$' \
--verbose || ret=1
fi
done
@@ -214,6 +212,10 @@ exit $ret
%changelog
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 5.2.4-1
+- Update to 5.2.4
+- raise dependency on phpunit/php-token-stream 2.0.1
+
* Mon Nov 6 2017 Remi Collet <remi@remirepo.net> - 5.2.3-1
- Update to 5.2.3
- raise dependency on phpunit/php-token-stream 2.0