summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpunit-dbunit3.spec23
1 files changed, 11 insertions, 12 deletions
diff --git a/php-phpunit-dbunit3.spec b/php-phpunit-dbunit3.spec
index 5b5a59c..21fd63f 100644
--- a/php-phpunit-dbunit3.spec
+++ b/php-phpunit-dbunit3.spec
@@ -21,14 +21,13 @@
%global ver_major 3
%global ver_minor 0
%global ver_patch 3
-%global specrel 1
+%global specrel 2
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
Release: %{specrel}%{?dist}
-Summary: PHPUnit extension for database interaction testing
+Summary: Extension for database interaction testing for PHPUnit 6
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -40,8 +39,10 @@ BuildRequires: php(language) >= 7.0
BuildRequires: php-pdo
BuildRequires: php-simplexml
BuildRequires: phpunit6
+# remirepo:1
%if 0%{?fedora} >= 27
BuildRequires: (php-composer(symfony/yaml) >= 3.0 with php-composer(symfony/yaml) < 5)
+# remirepo:3
%else
BuildRequires: php-composer(symfony/yaml) < 4
%endif
@@ -57,8 +58,10 @@ Requires: php(language) >= 7.0
Requires: php-pdo
Requires: php-simplexml
Requires: phpunit6
+# remirepo:1
%if 0%{?fedora} >= 27
Requires: (php-composer(symfony/yaml) >= 3.0 with php-composer(symfony/yaml) < 5)
+# remirepo:3
%else
Requires: php-composer(symfony/yaml) < 4
%endif
@@ -69,16 +72,9 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-%if 0%{?fedora} > 99
-Obsoletes: php-phpunit-Dbunit < %{ver_major}
-Provides: php-phpunit-Dbunit = %{version}
-Provides: %{pk_project} = %{version}
-Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
-%endif
-
%description
-PHPUnit extension for database interaction testing.
+Extension for database interaction testing for PHPUnit 6.
Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
@@ -87,7 +83,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
-
%build
: Generate library autoloader
%{_bindir}/phpab \
@@ -130,6 +125,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc ChangeLog.md
@@ -138,6 +134,9 @@ exit $ret
%changelog
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 3.0.3-2
+- better description
+
* Tue Jan 23 2018 Remi Collet <remi@remirepo.net> - 3.0.3-1
- Update to 3.0.3
- use range dependencies on F27+