summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-10 07:52:37 +0200
committerRemi Collet <remi@remirepo.net>2021-09-10 07:52:37 +0200
commit25bb35025d897f29f35352fef7868a306e84ed77 (patch)
treefc21657dc8e61f690b6a9b7c49fad2168f38f5a9 /php-phpunit-PHPUnit.spec
parentcba9992be7a788dcd37f2c5841cb8975c7afd525 (diff)
add minimal fix for PHP 8.1
Diffstat (limited to 'php-phpunit-PHPUnit.spec')
-rw-r--r--php-phpunit-PHPUnit.spec14
1 files changed, 12 insertions, 2 deletions
diff --git a/php-phpunit-PHPUnit.spec b/php-phpunit-PHPUnit.spec
index 4825ddd..9dd05a6 100644
--- a/php-phpunit-PHPUnit.spec
+++ b/php-phpunit-PHPUnit.spec
@@ -25,7 +25,7 @@
Name: php-phpunit-PHPUnit
Version: %{major}.%{minor}
-Release: 13%{?dist}
+Release: 15%{?dist}
Summary: The PHP Unit Testing framework version 5
License: BSD
@@ -245,8 +245,15 @@ install -D -p -m 755 phpunit %{buildroot}%{_bindir}/phpunit
OPT="--testsuite=small --no-coverage"
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
+ VER=$($cmd -r 'echo PHP_VERSION_ID;');
+ if [ $VER -ge 80000 ]; then
+ FILTER="testStaticAttributesBackupPre"
+ fi
+ if [ -n "$FILTER" ]; then
+ OPT="$OPT --filter '^((?!($FILTER)).)*$'"
+ fi
$cmd ./phpunit $OPT --verbose
fi
done
@@ -270,6 +277,9 @@ fi
%changelog
+* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 5.7.27-15
+- add minimal fix for PHP 8.1
+
* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 5.7.27-13
- switch to Symfony 4