From d05cbf6976a8979bd33cf2e1cfa8fb0c4249b4c4 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Wed, 31 Aug 2016 21:22:19 +0200
Subject: php-phpunit-PHPUnit-MockObject: switch the spec

---
 composer-dev.json                       |  53 -----
 composer.json                           |  13 +-
 php-phpunit-PHPUnit-MockObject-dev.spec | 351 --------------------------------
 php-phpunit-PHPUnit-MockObject.spec     |  96 +++++++--
 phpunit-mock-objects-rpm.patch          |  12 --
 5 files changed, 88 insertions(+), 437 deletions(-)
 delete mode 100644 composer-dev.json
 delete mode 100644 php-phpunit-PHPUnit-MockObject-dev.spec
 delete mode 100644 phpunit-mock-objects-rpm.patch

diff --git a/composer-dev.json b/composer-dev.json
deleted file mode 100644
index 29a06e8..0000000
--- a/composer-dev.json
+++ /dev/null
@@ -1,53 +0,0 @@
-{
-    "name": "phpunit/phpunit-mock-objects",
-    "description": "Mock Object library for PHPUnit",
-    "type": "library",
-    "keywords": [
-        "xunit",
-        "mock"
-    ],
-    "homepage": "https://github.com/sebastianbergmann/phpunit-mock-objects/",
-    "license": "BSD-3-Clause",
-    "authors": [
-        {
-            "name": "Sebastian Bergmann",
-            "email": "sb@sebastian-bergmann.de",
-            "role": "lead"
-        }
-    ],
-    "support": {
-        "issues": "https://github.com/sebastianbergmann/phpunit-mock-objects/issues",
-        "irc": "irc://irc.freenode.net/phpunit"
-    },
-    "require": {
-        "php": "^5.6 || ^7.0",
-        "phpunit/php-text-template": "^1.2",
-        "doctrine/instantiator": "^1.0.2",
-        "sebastian/exporter": "^1.2"
-    },
-    "require-dev": {
-        "phpunit/phpunit": "^5.4"
-    },
-    "conflict": {
-        "phpunit/phpunit": "<5.4.0"
-    },
-    "suggest": {
-        "ext-soap": "*"
-    },
-    "autoload": {
-        "classmap": [
-            "src/"
-        ]
-    },
-    "autoload-dev": {
-        "classmap": [
-            "tests/_fixture/"
-        ]
-    },
-    "extra": {
-        "branch-alias": {
-            "dev-master": "3.2.x-dev"
-        }
-    }
-}
-
diff --git a/composer.json b/composer.json
index 12fb934..29a06e8 100644
--- a/composer.json
+++ b/composer.json
@@ -20,13 +20,16 @@
         "irc": "irc://irc.freenode.net/phpunit"
     },
     "require": {
-        "php": ">=5.3.3",
-        "phpunit/php-text-template": "~1.2",
+        "php": "^5.6 || ^7.0",
+        "phpunit/php-text-template": "^1.2",
         "doctrine/instantiator": "^1.0.2",
-        "sebastian/exporter": "~1.2"
+        "sebastian/exporter": "^1.2"
     },
     "require-dev": {
-        "phpunit/phpunit": "~4.4"
+        "phpunit/phpunit": "^5.4"
+    },
+    "conflict": {
+        "phpunit/phpunit": "<5.4.0"
     },
     "suggest": {
         "ext-soap": "*"
@@ -43,7 +46,7 @@
     },
     "extra": {
         "branch-alias": {
-            "dev-master": "2.3.x-dev"
+            "dev-master": "3.2.x-dev"
         }
     }
 }
diff --git a/php-phpunit-PHPUnit-MockObject-dev.spec b/php-phpunit-PHPUnit-MockObject-dev.spec
deleted file mode 100644
index 71f60e1..0000000
--- a/php-phpunit-PHPUnit-MockObject-dev.spec
+++ /dev/null
@@ -1,351 +0,0 @@
-# remirepo/fedora spec file for php-phpunit-PHPUnit-MockObject
-#
-# Copyright (c) 2013-2016 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%global bootstrap    0
-%global gh_commit    b13d0d9426ced06958bd32104653526a6c998a52
-#global gh_date      20150902
-%global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner     sebastianbergmann
-%global gh_project   phpunit-mock-objects
-%global php_home     %{_datadir}/php
-%global pear_name    PHPUnit_MockObject
-%global pear_channel pear.phpunit.de
-%global major        3.2
-%global minor        3
-%global specrel      1
-%if %{bootstrap}
-%global with_tests   %{?_with_tests:1}%{!?_with_tests:0}
-%else
-%global with_tests   %{?_without_tests:0}%{!?_without_tests:1}
-%endif
-
-Name:           php-phpunit-PHPUnit-MockObject
-Version:        %{major}.%{minor}
-Release:        %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
-Summary:        Mock Object library for PHPUnit
-
-Group:          Development/Libraries
-License:        BSD
-URL:            https://github.com/%{gh_owner}/%{gh_project}
-Source0:        https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-
-# Temporary workaround, under investigation
-Patch0:         %{gh_project}-3.0.0-rpm.patch
-
-# Upstream patches
-
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildArch:      noarch
-BuildRequires:  php-theseer-autoload
-%if %{with_tests}
-BuildRequires:  php(language) >= 5.6
-# From composer.json, "require-dev": {
-#        "phpunit/phpunit": "^5.4"
-BuildRequires:  php-composer(phpunit/phpunit) >= 5.4
-%endif
-
-# From composer.json, "require": {
-#        "php": "^5.6 || ^7.0",
-#        "phpunit/php-text-template": "^1.2",
-#        "doctrine/instantiator": "^1.0.2",
-#        "sebastian/exporter": "^1.2"
-Requires:       php(language) >= 5.6
-Requires:       php-composer(phpunit/php-text-template) >= 1.2
-Requires:       php-composer(phpunit/php-text-template) <  2
-Requires:       php-composer(doctrine/instantiator) >= 1.0.2
-Requires:       php-composer(doctrine/instantiator) <  2
-Requires:       php-composer(sebastian/exporter) >= 1.2
-Requires:       php-composer(sebastian/exporter) <  2
-# From composer.json, "suggest": {
-#        "ext-soap": "*"
-Requires:       php-soap
-# From phpcompatinfo report for version 3.2.0
-Requires:       php-pcre
-Requires:       php-reflection
-Requires:       php-spl
-# From composer.json, "conflict": {
-#        "phpunit/phpunit": "<5.4.0"
-Conflicts:      php-composer(phpunit/phpunit) < 5.4
-
-
-Provides:       php-composer(phpunit/phpunit-mock-objects) = %{version}
-
-
-%description
-Mock Object library for PHPUnit
-
-
-%prep
-%setup -q -n %{gh_project}-%{gh_commit}
-
-%patch0 -p0
-
-find . -name \*.orig -exec rm {} \; -print
-
-
-%build
-phpab \
-  --output src/Framework/MockObject/Autoload.php \
-  src/Framework/MockObject
-
-cat <<EOF | tee -a src/Framework/MockObject/Autoload.php
-/* dependencies */
-require_once 'Text/Template/Autoload.php';
-require_once 'Doctrine/Instantiator/autoload.php';
-require_once 'SebastianBergmann/Exporter/autoload.php';
-EOF
-
-
-%install
-rm -rf     %{buildroot}
-mkdir -p   %{buildroot}%{php_home}
-cp -pr src %{buildroot}%{php_home}/PHPUnit
-
-
-%if %{with_tests}
-%check
-# No phpcov
-grep -v 'log' phpunit.xml.dist > phpunit.xml
-
-: Generate autoloader for tests
-phpab --output tests/_fixture/autoload.php tests/_fixture/
-
-: Fix bootstrap - vendor/autoload used in tests
-mkdir vendor
-ln -s %{buildroot}%{php_home}/PHPUnit/Framework/MockObject/Autoload.php vendor/autoload.php
-
-cat <<EOF >>tests/bootstrap.php
-require __DIR__ . '/_fixture/autoload.php';
-EOF
-
-: Run tests - set include_path to ensure PHPUnit autoloader use it
-run=0
-if which php56; then
-  run=1
-  php56 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-  %{_bindir}/phpunit --no-coverage
-fi
-if which php70; then
-  run=1
-  php70 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-  %{_bindir}/phpunit --no-coverage
-fi
-if [ $run -eq 0 ]; then
-  %{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-  %{_bindir}/phpunit --no-coverage
-fi
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%post
-if [ -x %{_bindir}/pear ]; then
-   %{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
-      %{pear_channel}/%{pear_name} >/dev/null || :
-fi
-
-
-%files
-%defattr(-,root,root,-)
-%{!?_licensedir:%global license %%doc}
-%license LICENSE
-%doc CONTRIBUTING.md README.md composer.json
-%dir %{php_home}/PHPUnit
-%dir %{php_home}/PHPUnit/Framework
-     %{php_home}/PHPUnit/Framework/MockObject
-
-
-%changelog
-* Sun Jun 12 2016 Remi Collet <remi@fedoraproject.org> - 3.2.3-1
-- Update to 3.2.3
-
-* Sat Jun  4 2016 Remi Collet <remi@fedoraproject.org> - 3.2.1-1
-- Update to 3.2.1 (no change)
-- ensure cannot be installed with old PHPUnit
-
-* Fri Jun  3 2016 Remi Collet <remi@fedoraproject.org> - 3.2.0-1
-- Update to 3.2.0
-- raise build dependency on phpunit >= 5.4
-
-* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 3.1.3-1
-- Update to 3.1.3
-
-* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 3.1.2-1
-- Update to 3.1.2
-
-* Wed Mar 23 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
-- Update to 3.1.0
-
-* Tue Dec  8 2015 Remi Collet <remi@fedoraproject.org> - 3.0.6-1
-- Update to 3.0.6
-
-* Tue Dec  8 2015 Remi Collet <remi@fedoraproject.org> - 3.0.5-1
-- Update to 3.0.5
-
-* Wed Nov 18 2015 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
-- Update to 3.0.4
-
-* Sun Oct 18 2015 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
-- Update to 3.0.3
-
-* Fri Oct 16 2015 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
-- Update to 3.0.2
-
-* Wed Oct 14 2015 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
-- Update to 3.0.1
-
-* Fri Oct  2 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
-- Update to 3.0.0
-
-* Mon Sep 14 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-0.1.20150902git4f526b7
-- update to 3.0.0-dev
-- raise dependency on PHP >= 5.6
-
-* Fri Aug 21 2015 Remi Collet <remi@fedoraproject.org> - 2.3.7-1
-- update to 2.3.7
-
-* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> - 2.3.6-1
-- update to 2.3.6 (only cleanup)
-
-* Sat Jul  4 2015 Remi Collet <remi@fedoraproject.org> - 2.3.5-1
-- update to 2.3.5
-
-* Thu Jul  2 2015 Remi Collet <remi@fedoraproject.org> - 2.3.4-2
-- fix autoloader
-
-* Thu Jun 11 2015 Remi Collet <remi@fedoraproject.org> - 2.3.4-1
-- update to 2.3.4
-
-* Fri May 29 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
-- update to 2.3.3
-
-* Thu May 28 2015 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
-- update to 2.3.2
-
-* Thu Apr  2 2015 Remi Collet <remi@fedoraproject.org> - 2.3.1-1
-- update to 2.3.1
-
-* Fri Oct  3 2014 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
-- update to 2.3.0 for PHPUnit 4.3.0
-- drop dependency on ocramius/instantiator
-- add depencency on doctrine/instantiator
-
-* Fri Oct  3 2014 Remi Collet <remi@fedoraproject.org> - 2.3.0-0
-- bootstrap build
-
-* Sun Sep  7 2014 Remi Collet <remi@fedoraproject.org> - 2.2.1-1
-- update to 2.2.1
-- enable test suite
-
-* Mon Aug 11 2014 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
-- update to 2.2.0
-- add dependency on ocramius/instantiator
-- fix license handling
-
-* Mon Jul 07 2014 Remi Collet <remi@fedoraproject.org> - 2.1.5-1
-- update to 2.1.5
-
-* Thu Jun 12 2014 Remi Collet <remi@fedoraproject.org> - 2.1.4-1
-- update to 2.1.4
-- add upstream patch to fix unserialize issue
-  https://github.com/sebastianbergmann/phpunit-mock-objects/pull/176
-
-* Sat Jun  7 2014 Remi Collet <remi@fedoraproject.org> - 2.1.3-1
-- update to 2.1.3
-
-* Sat Jun  7 2014 Remi Collet <remi@fedoraproject.org> - 2.1.2-1
-- update to 2.1.2
-
-* Fri Jun  6 2014 Remi Collet <remi@fedoraproject.org> - 2.1.1-1
-- update to 2.1.1
-
-* Fri May 30 2014 Remi Collet <remi@fedoraproject.org> - 2.1.0-3
-- upstream fix for php 5.4.29 and 5.5.13
-
-* Tue May  6 2014 Remi Collet <remi@fedoraproject.org> - 2.1.0-2
-- workaround to autoload issue during check
-
-* Sat May  3 2014 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
-- update to 2.1.0 for PHPUnit 4.1
-
-* Wed Apr 30 2014 Remi Collet <remi@fedoraproject.org> - 2.0.5-2
-- cleanup pear registry
-
-* Tue Apr 29 2014 Remi Collet <remi@fedoraproject.org> - 2.0.5-1
-- update to 2.0.5
-- sources from gthub
-- run tests when build --with tests option
-
-* Sun Jan 13 2013 Remi Collet <remi@fedoraproject.org> - 1.2.3-1
-- Version 1.2.3 (stable) - API 1.2.0 (stable)
-
-* Mon Nov  5 2012 Remi Collet <remi@fedoraproject.org> - 1.2.2-1
-- Version 1.2.2 (stable) - API 1.2.0 (stable)
-
-* Sat Oct  6 2012 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
-- Version 1.2.1 (stable) - API 1.2.0 (stable)
-
-* Thu Sep 20 2012 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
-- Version 1.2.0 (stable) - API 1.2.0 (stable)
-- raise dependencies: php 5.3.3, PHPUnit 3.7.0
-
-* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
-
-* Thu Jan 19 2012 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
-- Version 1.1.1 (stable) - API 1.1.0 (stable)
-
-* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
-
-* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
-- Version 1.1.0 (stable) - API 1.1.0 (stable)
-
-* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.9-1
-- Version 1.0.9 (stable) - API 1.0.4 (stable)
-- remove PEAR hack (only needed for EPEL)
-- raise PEAR dependency to 1.9.2
-
-* Tue May  3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.8-2
-- rebuild for doc in /usr/share/doc/pear
-
-* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.8-1
-- Version 1.0.8 (stable) - API 1.0.4 (stable)
-
-* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
-- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
-
-* Sat Feb 05 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.7-1
-- Version 1.0.7 (stable) - API 1.0.4 (stable)
-
-* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.6-1
-- Version 1.0.6 (stable) - API 1.0.4 (stable)
-
-* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.5-1
-- Version 1.0.5 (stable) - API 1.0.4 (stable)
-- CHANGELOG and LICENSE are now in the tarball
-
-* Mon Nov 22 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.3-1
-- Version 1.0.3 (stable) - API 1.0.3 (stable)
-
-* Wed Nov 17 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
-- Version 1.0.2 (stable) - API 1.0.0 (stable)
-
-* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.1-2
-- lower PEAR dependency to allow el6 build
-- fix URL
-
-* Mon Oct 25 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.1-1
-- Version 1.0.1 (stable) - API 1.0.0 (stable)
-
-* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
-- initial generated spec + clean
-
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 9e23e0a..71f60e1 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -7,13 +7,17 @@
 # Please, preserve the changelog entries
 #
 %global bootstrap    0
-%global gh_commit    ac8e7a3db35738d56ee9a76e78a4e03d97628983
+%global gh_commit    b13d0d9426ced06958bd32104653526a6c998a52
+#global gh_date      20150902
 %global gh_short     %(c=%{gh_commit}; echo ${c:0:7})
 %global gh_owner     sebastianbergmann
 %global gh_project   phpunit-mock-objects
 %global php_home     %{_datadir}/php
 %global pear_name    PHPUnit_MockObject
 %global pear_channel pear.phpunit.de
+%global major        3.2
+%global minor        3
+%global specrel      1
 %if %{bootstrap}
 %global with_tests   %{?_with_tests:1}%{!?_with_tests:0}
 %else
@@ -21,8 +25,8 @@
 %endif
 
 Name:           php-phpunit-PHPUnit-MockObject
-Version:        2.3.8
-Release:        1%{?dist}
+Version:        %{major}.%{minor}
+Release:        %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
 Summary:        Mock Object library for PHPUnit
 
 Group:          Development/Libraries
@@ -31,7 +35,7 @@ URL:            https://github.com/%{gh_owner}/%{gh_project}
 Source0:        https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
 
 # Temporary workaround, under investigation
-Patch0:         %{gh_project}-rpm.patch
+Patch0:         %{gh_project}-3.0.0-rpm.patch
 
 # Upstream patches
 
@@ -39,17 +43,18 @@ BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
 BuildRequires:  php-theseer-autoload
 %if %{with_tests}
+BuildRequires:  php(language) >= 5.6
 # From composer.json, "require-dev": {
-#        "phpunit/phpunit": "~4.4"
-BuildRequires:  php-composer(phpunit/phpunit) >= 4.4
+#        "phpunit/phpunit": "^5.4"
+BuildRequires:  php-composer(phpunit/phpunit) >= 5.4
 %endif
 
 # From composer.json, "require": {
-#        "php": ">=5.3.3",
-#        "phpunit/php-text-template": "~1.2",
+#        "php": "^5.6 || ^7.0",
+#        "phpunit/php-text-template": "^1.2",
 #        "doctrine/instantiator": "^1.0.2",
-#        "sebastian/exporter": "~1.2"
-Requires:       php(language) >= 5.3.3
+#        "sebastian/exporter": "^1.2"
+Requires:       php(language) >= 5.6
 Requires:       php-composer(phpunit/php-text-template) >= 1.2
 Requires:       php-composer(phpunit/php-text-template) <  2
 Requires:       php-composer(doctrine/instantiator) >= 1.0.2
@@ -59,10 +64,14 @@ Requires:       php-composer(sebastian/exporter) <  2
 # From composer.json, "suggest": {
 #        "ext-soap": "*"
 Requires:       php-soap
-# From phpcompatinfo report for version 2.3.5
+# From phpcompatinfo report for version 3.2.0
 Requires:       php-pcre
 Requires:       php-reflection
 Requires:       php-spl
+# From composer.json, "conflict": {
+#        "phpunit/phpunit": "<5.4.0"
+Conflicts:      php-composer(phpunit/phpunit) < 5.4
+
 
 Provides:       php-composer(phpunit/phpunit-mock-objects) = %{version}
 
@@ -74,7 +83,7 @@ Mock Object library for PHPUnit
 %prep
 %setup -q -n %{gh_project}-%{gh_commit}
 
-%patch0 -p1
+%patch0 -p0
 
 find . -name \*.orig -exec rm {} \; -print
 
@@ -115,8 +124,21 @@ require __DIR__ . '/_fixture/autoload.php';
 EOF
 
 : Run tests - set include_path to ensure PHPUnit autoloader use it
-%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-%{_bindir}/phpunit
+run=0
+if which php56; then
+  run=1
+  php56 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+  %{_bindir}/phpunit --no-coverage
+fi
+if which php70; then
+  run=1
+  php70 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+  %{_bindir}/phpunit --no-coverage
+fi
+if [ $run -eq 0 ]; then
+  %{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+  %{_bindir}/phpunit --no-coverage
+fi
 %endif
 
 
@@ -142,8 +164,50 @@ fi
 
 
 %changelog
-* Fri Oct  2 2015 Remi Collet <remi@fedoraproject.org> - 2.3.8-1
-- update to 2.3.8
+* Sun Jun 12 2016 Remi Collet <remi@fedoraproject.org> - 3.2.3-1
+- Update to 3.2.3
+
+* Sat Jun  4 2016 Remi Collet <remi@fedoraproject.org> - 3.2.1-1
+- Update to 3.2.1 (no change)
+- ensure cannot be installed with old PHPUnit
+
+* Fri Jun  3 2016 Remi Collet <remi@fedoraproject.org> - 3.2.0-1
+- Update to 3.2.0
+- raise build dependency on phpunit >= 5.4
+
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 3.1.3-1
+- Update to 3.1.3
+
+* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 3.1.2-1
+- Update to 3.1.2
+
+* Wed Mar 23 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
+- Update to 3.1.0
+
+* Tue Dec  8 2015 Remi Collet <remi@fedoraproject.org> - 3.0.6-1
+- Update to 3.0.6
+
+* Tue Dec  8 2015 Remi Collet <remi@fedoraproject.org> - 3.0.5-1
+- Update to 3.0.5
+
+* Wed Nov 18 2015 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
+- Update to 3.0.4
+
+* Sun Oct 18 2015 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
+- Update to 3.0.3
+
+* Fri Oct 16 2015 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
+- Update to 3.0.2
+
+* Wed Oct 14 2015 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- Update to 3.0.1
+
+* Fri Oct  2 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
+- Update to 3.0.0
+
+* Mon Sep 14 2015 Remi Collet <remi@fedoraproject.org> - 3.0.0-0.1.20150902git4f526b7
+- update to 3.0.0-dev
+- raise dependency on PHP >= 5.6
 
 * Fri Aug 21 2015 Remi Collet <remi@fedoraproject.org> - 2.3.7-1
 - update to 2.3.7
diff --git a/phpunit-mock-objects-rpm.patch b/phpunit-mock-objects-rpm.patch
deleted file mode 100644
index 97bdde1..0000000
--- a/phpunit-mock-objects-rpm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- phpunit-mock-objects-da0eb04d8ee95ec2898187e407e519c118d3d27c/src/Framework/MockObject/Generator.php.rpm	2014-05-06 13:15:55.000000000 +0200
-+++ phpunit-mock-objects-da0eb04d8ee95ec2898187e407e519c118d3d27c/src/Framework/MockObject/Generator.php	2014-05-06 13:16:12.000000000 +0200
-@@ -49,6 +49,9 @@
-     }
- }
- 
-+# temporary workaround
-+require_once 'Text/Template.php';
-+
- /**
-  * Mock Object Code Generator
-  *
-- 
cgit