summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit-MockObject.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-PHPUnit-MockObject.spec')
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec12
1 files changed, 8 insertions, 4 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 463d2ca..6b654f6 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -17,7 +17,7 @@
%global pear_channel pear.phpunit.de
%global major 3.4
%global minor 4
-%global specrel 4
+%global specrel 5
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%else
@@ -35,8 +35,8 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Temporary workaround, under investigation
Patch0: %{gh_project}-3.0.0-rpm.patch
-
-# Upstream patches
+# For 7.4
+Patch1: %{gh_project}-php74.patch
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -96,6 +96,7 @@ Mock Object library for PHPUnit
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0
+%patch1 -p1
find . -name \*.orig -exec rm {} \; -print
@@ -134,7 +135,7 @@ EOF
: Run tests - set include_path to ensure PHPUnit autoloader use it
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php70 php71 php72 php73 php74; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
%{_bindir}/phpunit --no-coverage || ret=1
@@ -161,6 +162,9 @@ fi
%changelog
+* Wed Aug 21 2019 Remi Collet <remi@remirepo.net> - 3.4.4-5
+- fix deprecated usage of ReflectionType::__toString()
+
* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 3.4.4-4
- cleanup for EL-8