summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit-MockObject.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-04 06:16:14 +0200
committerRemi Collet <remi@remirepo.net>2017-07-04 06:16:14 +0200
commit775b88de916bfed6b52c93d90b81f4256b62e64f (patch)
tree10b175479632fed06eca6cf328ea090d5a52eaa0 /php-phpunit-PHPUnit-MockObject.spec
parent10642ade301125903110ca61aab44afde46e6520 (diff)
v3.4.4
Diffstat (limited to 'php-phpunit-PHPUnit-MockObject.spec')
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec39
1 files changed, 12 insertions, 27 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
index 752bf2a..ecfb2d4 100644
--- a/php-phpunit-PHPUnit-MockObject.spec
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3ab72b65b39b491e0c011e2e09bb2206c2aa8e24
+%global gh_commit a23b761686d50a560cc56233b9ecf49597cc9118
#global gh_date 20150902
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -16,7 +16,7 @@
%global pear_name PHPUnit_MockObject
%global pear_channel pear.phpunit.de
%global major 3.4
-%global minor 3
+%global minor 4
%global specrel 1
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
@@ -26,7 +26,7 @@
Name: php-phpunit-PHPUnit-MockObject
Version: %{major}.%{minor}
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Mock Object library for PHPUnit
Group: Development/Libraries
@@ -39,7 +39,6 @@ Patch0: %{gh_project}-3.0.0-rpm.patch
# Upstream patches
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
@@ -105,7 +104,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/PHPUnit
@@ -124,32 +122,17 @@ require __DIR__ . '/_fixture/autoload.php';
EOF
: Run tests - set include_path to ensure PHPUnit autoloader use it
-# remirepo:13
ret=0
-run=0
-if which php56; then
- run=1
- php56 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
- %{_bindir}/phpunit --no-coverage || ret=1
-fi
-if which php71; then
- run=1
- php71 -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
- %{_bindir}/phpunit --no-coverage || ret=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
-%{_bindir}/phpunit --no-coverage
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+ %{_bindir}/phpunit --no-coverage || ret=1
+ fi
+done
exit $ret
%endif
-%clean
-rm -rf %{buildroot}
-
-
%post
if [ -x %{_bindir}/pear ]; then
%{_bindir}/pear uninstall --nodeps --ignore-errors --register-only \
@@ -158,7 +141,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc CONTRIBUTING.md README.md composer.json
@@ -168,6 +150,9 @@ fi
%changelog
+* Tue Jul 4 2017 Remi Collet <remi@remirepo.net> - 3.4.4-1
+- Update to 3.4.4
+
* Fri Dec 9 2016 Remi Collet <remi@fedoraproject.org> - 3.4.3-1
- Update to 3.4.3