summaryrefslogtreecommitdiffstats
path: root/php-phpunit-PHPUnit-MockObject.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-07 19:19:24 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-07 19:19:24 +0200
commit6ed52767a90c90d27594813018dd72691b24a6cd (patch)
tree3ba17fe9de6a264ca5598e43a1e899560b135e09 /php-phpunit-PHPUnit-MockObject.spec
php-phpunit-PHPUnit-MockObject: import from rawhide
Diffstat (limited to 'php-phpunit-PHPUnit-MockObject.spec')
-rw-r--r--php-phpunit-PHPUnit-MockObject.spec133
1 files changed, 133 insertions, 0 deletions
diff --git a/php-phpunit-PHPUnit-MockObject.spec b/php-phpunit-PHPUnit-MockObject.spec
new file mode 100644
index 0000000..07b284f
--- /dev/null
+++ b/php-phpunit-PHPUnit-MockObject.spec
@@ -0,0 +1,133 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name PHPUnit_MockObject
+%global channel pear.phpunit.de
+
+Name: php-phpunit-PHPUnit-MockObject
+Version: 1.1.1
+Release: 2%{?dist}
+Summary: Mock Object library for PHPUnit
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/sebastianbergmann/phpunit-mock-objects
+Source0: http://pear.phpunit.de/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR) >= 1.9.4
+BuildRequires: php-channel(%{channel})
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR) >= 1.9.4
+Requires: php-soap >= 5.2.7
+Requires: php-pear(%{channel}/Text_Template) >= 1.1.1
+Requires: php-pear(%{channel}/PHPUnit) >= 3.6.0
+
+Provides: php-pear(%{channel}/%{pear_name}) = %{version}
+
+
+%description
+Mock Object library for PHPUnit
+
+
+%prep
+%setup -q -c
+cd %{pear_name}-%{version}
+# package.xml is V2
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/PHPUnit/Framework/MockObject
+
+
+%changelog
+* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Thu Jan 19 2012 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Version 1.1.1 (stable) - API 1.1.0 (stable)
+
+* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Tue Nov 01 2011 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Version 1.1.0 (stable) - API 1.1.0 (stable)
+
+* Fri Jun 10 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.9-1
+- Version 1.0.9 (stable) - API 1.0.4 (stable)
+- remove PEAR hack (only needed for EPEL)
+- raise PEAR dependency to 1.9.2
+
+* Tue May 3 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.8-2
+- rebuild for doc in /usr/share/doc/pear
+
+* Wed Feb 16 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.8-1
+- Version 1.0.8 (stable) - API 1.0.4 (stable)
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sat Feb 05 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.7-1
+- Version 1.0.7 (stable) - API 1.0.4 (stable)
+
+* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.6-1
+- Version 1.0.6 (stable) - API 1.0.4 (stable)
+
+* Tue Jan 18 2011 Remi Collet <Fedora@famillecollet.com> - 1.0.5-1
+- Version 1.0.5 (stable) - API 1.0.4 (stable)
+- CHANGELOG and LICENSE are now in the tarball
+
+* Mon Nov 22 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.3-1
+- Version 1.0.3 (stable) - API 1.0.3 (stable)
+
+* Wed Nov 17 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.2-1
+- Version 1.0.2 (stable) - API 1.0.0 (stable)
+
+* Fri Nov 05 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.1-2
+- lower PEAR dependency to allow el6 build
+- fix URL
+
+* Mon Oct 25 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.1-1
+- Version 1.0.1 (stable) - API 1.0.0 (stable)
+
+* Sun Sep 26 2010 Remi Collet <Fedora@famillecollet.com> - 1.0.0-1
+- initial generated spec + clean
+