summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-07 14:21:44 +0200
committerRemi Collet <remi@remirepo.net>2017-08-07 14:21:44 +0200
commite6d46b2747615242101208c799d7aac954611fc8 (patch)
treeb648ba9c8507a49e751ff51f7600c82093b2051d
parentaafdd610c6c68f2a30924e4ac54e42269825dd65 (diff)
v3.4.2
-rw-r--r--php-phpspec.spec7
-rw-r--r--phpspec-3-rpm.patch10
-rw-r--r--phpspec-autoload.php14
3 files changed, 20 insertions, 11 deletions
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 5b22735..a5ebf9e 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2e969c7d8c6437490b7aa0ab51a3302d15bb7211
+%global gh_commit 4f42719d8d7a26063b9aa79a0f83ed56c79618f4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -25,7 +25,7 @@
%endif
Name: php-phpspec
-Version: 3.4.0
+Version: 3.4.2
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -191,6 +191,9 @@ done
%changelog
+* Mon Aug 7 2017 Remi Collet <remi@remirepo.net> - 3.4.2-1
+- Update to 3.4.2
+
* Fri May 12 2017 Remi Collet <remi@remirepo.net> - 3.4.0-1
- Update to 3.4.0
diff --git a/phpspec-3-rpm.patch b/phpspec-3-rpm.patch
index 921d82e..0db8231 100644
--- a/phpspec-3-rpm.patch
+++ b/phpspec-3-rpm.patch
@@ -1,10 +1,10 @@
-diff -up bin/phpspec.rpm bin/phpspec
---- bin/phpspec.rpm 2016-07-18 10:56:02.330062305 +0200
-+++ bin/phpspec 2016-07-18 10:57:56.042682157 +0200
-@@ -3,24 +3,20 @@
+diff -up ./bin/phpspec.rpm ./bin/phpspec
+--- ./bin/phpspec.rpm 2017-08-07 14:10:13.556500337 +0200
++++ ./bin/phpspec 2017-08-07 14:11:34.996906564 +0200
+@@ -2,24 +2,20 @@
+ <?php
call_user_func(function ($version) {
-
- if (is_file($autoload = getcwd() . '/vendor/autoload.php')) {
- require $autoload;
- } elseif (is_file($autoload = getcwd() . '/../../autoload.php')) {
diff --git a/phpspec-autoload.php b/phpspec-autoload.php
index 1fbcc5d..64f544a 100644
--- a/phpspec-autoload.php
+++ b/phpspec-autoload.php
@@ -12,12 +12,18 @@ if (is_dir(getcwd().'/spec')) {
}
// Dependencies (Rely on include_path as in PHPUnit dependencies + circular dependencies)
+if (version_compare(PHP_VERSION, '7', '>')) {
+ $exp = [
+ 'SebastianBergmann/Exporter3/autoload.php',
+ 'SebastianBergmann/Exporter/autoload.php',
+ ];
+} else {
+ $exp = 'SebastianBergmann/Exporter/autoload.php';
+}
\Fedora\Autoloader\Dependencies::required([
'phpspec/php-diff/autoload.php',
'Prophecy/autoload.php',
'Doctrine/Instantiator/autoload.php',
- [
- 'SebastianBergmann/Exporter3/autoload.php',
- 'SebastianBergmann/Exporter/autoload.php',
- ],
+ $exp,
]);
+