summaryrefslogtreecommitdiffstats
path: root/php-phpseclib-crypt-hash.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-15 07:09:24 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-15 07:09:24 +0100
commit22696a452ed11a3c9556dd9f336045e4e3df6a44 (patch)
treed4401f72b83e9cff5858cb1db1612cd1ebcf7303 /php-phpseclib-crypt-hash.spec
php-phpseclib-crypt-hash: import from rawwhide
Diffstat (limited to 'php-phpseclib-crypt-hash.spec')
-rw-r--r--php-phpseclib-crypt-hash.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/php-phpseclib-crypt-hash.spec b/php-phpseclib-crypt-hash.spec
new file mode 100644
index 0000000..be978f7
--- /dev/null
+++ b/php-phpseclib-crypt-hash.spec
@@ -0,0 +1,76 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Crypt_Hash
+
+Name: php-phpseclib-crypt-hash
+Version: 0.3.5
+Release: 2%{?dist}
+Summary: Pure-PHP implementations of keyed HMACs and hashing functions
+
+Group: Development/Libraries
+License: MIT
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR)
+Provides: php-pear(phpseclib.sourceforge.net/Crypt_Hash) = %{version}
+BuildRequires: php-channel(phpseclib.sourceforge.net)
+Requires: php-channel(phpseclib.sourceforge.net)
+Requires: php-pear(phpseclib.sourceforge.net/Math_BigInteger)
+
+%description
+Uses hash() or mhash() if available and an internal implementation,
+otherwise. Optionally uses suhosin. Currently supports the following:
+md2, md5, md5-96, sha1, sha1-96, sha256, sha384, and sha512.
+
+%prep
+%setup -q -c
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ phpseclib.sourceforge.net/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Crypt
+
+
+%changelog
+* Sat Jan 4 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-2
+- various review style cleanups
+
+* Tue Dec 31 2013 Adam Williamson <awilliam@redhat.com> - 0.3.5-1
+- initial package (generated with pear make-rpm-spec)