summaryrefslogtreecommitdiffstats
path: root/php-phpmyadmin-motranslator5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpmyadmin-motranslator5.spec')
-rw-r--r--php-phpmyadmin-motranslator5.spec23
1 files changed, 16 insertions, 7 deletions
diff --git a/php-phpmyadmin-motranslator5.spec b/php-phpmyadmin-motranslator5.spec
index e6c9a24..d810d45 100644
--- a/php-phpmyadmin-motranslator5.spec
+++ b/php-phpmyadmin-motranslator5.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit d1982c7e468df332b6ff0d73fb599519140d393f
+%global gh_commit a2b3978915a2b5fcfd6f83be300cff024bd0a682
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmyadmin
%global gh_project motranslator
@@ -20,7 +20,7 @@
%global sym_max_ver 6
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 5.0.0
+Version: 5.1.0
Release: 1%{?dist}
Summary: Translation API for PHP using Gettext MO files
@@ -41,16 +41,21 @@ BuildRequires: (php-composer(symfony/expression-language) >= %{sym_min_ver} with
BuildRequires: php-symfony4-expression-language
%endif
# For tests, from composer.json "require-dev": {
-# "phpunit/php-code-coverage": "*",
-# "phpunit/phpunit": "^7.4 || ^8"
+# "phpunit/phpunit": "^7.4 || ^8 || ^9",
+# "phpmyadmin/coding-standard": "^2.0"
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: %{phpunit}
+%else
%global phpunit %{_bindir}/phpunit8
BuildRequires: %{phpunit}
%endif
+%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
-# "php": "^7.1",
+# "php": "^7.1 || ^8.0",
# "symfony/expression-language": ""^4.0 || ^5.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -122,10 +127,10 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
EOF
ret=0
-for cmd in "php %{phpunit}" php72 php73 "php74 %{_bindir}/phpunit9"; do
+for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 "php74" php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit8} --no-coverage --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose || ret=1
fi
done
exit $ret
@@ -145,6 +150,10 @@ exit $ret
%changelog
+* Mon Nov 16 2020 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+- switch to phpunit9
+
* Wed Mar 4 2020 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0
- rename to php-phpmyadmin-motranslator5