summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-docblock5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpdocumentor-reflection-docblock5.spec')
-rw-r--r--php-phpdocumentor-reflection-docblock5.spec71
1 files changed, 41 insertions, 30 deletions
diff --git a/php-phpdocumentor-reflection-docblock5.spec b/php-phpdocumentor-reflection-docblock5.spec
index 9200ff2..5b28384 100644
--- a/php-phpdocumentor-reflection-docblock5.spec
+++ b/php-phpdocumentor-reflection-docblock5.spec
@@ -8,15 +8,15 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit cd72d394ca794d3466a3b2fc09d5a6c1dc86b47e
+%global gh_commit 3170448f5769fe19f456173d833734e0ff1b84df
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
%global major 5
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
Name: php-phpdocumentor-reflection-docblock%{major}
-Version: 5.1.0
+Version: 5.2.0
Release: 1%{?dist}
Summary: DocBlock parser
@@ -30,31 +30,33 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 7.2
BuildRequires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 1.0 with php-composer(phpdocumentor/type-resolver) < 2)
-BuildRequires: (php-composer(webmozart/assert) >= 1.0 with php-composer(webmozart/assert) < 2)
-BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 2.0 with php-composer(phpdocumentor/reflection-common) < 3)
+BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 1.3 with php-composer(phpdocumentor/type-resolver) < 2)
+BuildRequires: (php-composer(webmozart/assert) >= 1.9.1 with php-composer(webmozart/assert) < 2)
+BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 2.2 with php-composer(phpdocumentor/reflection-common) < 3)
# remirepo:5
%else
-BuildRequires: php-phpdocumentor-reflection-common2
-BuildRequires: php-phpdocumentor-type-resolver1
-BuildRequires: php-webmozart-assert
+BuildRequires: php-phpdocumentor-type-resolver1 >= 1.3
+BuildRequires: php-webmozart-assert >= 1.9.1
+BuildRequires: php-phpdocumentor-reflection-common2 >= 2.2
%endif
# From composer.json, require-dev
-# "mockery/mockery": "^1",
-# "doctrine/instantiator": "^1"
+# "mockery/mockery": "~1.3.2"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(mockery/mockery) >= 1.0 with php-composer(mockery/mockery) < 2)
+BuildRequires: (php-composer(mockery/mockery) >= 1.3.2 with php-composer(mockery/mockery) < 2)
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
# remirepo:3
%else
-BuildRequires: php-mockery >= 1.0
-%endif
+BuildRequires: php-mockery >= 1.3.2
BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit8
+%endif
# From phpcompatinfo report for 5.0.0
BuildRequires: php-reflection
BuildRequires: php-pcre
@@ -62,23 +64,23 @@ BuildRequires: php-spl
%endif
# From composer.json, require
-# "php": "^7.2",
-# "phpdocumentor/type-resolver": "^1.0",
-# "webmozart/assert": "^1",
-# "phpdocumentor/reflection-common": "^2.0",
-# "ext-filter": "^7.1"
+# "php": "^7.2 || ^8.0",
+# "phpdocumentor/type-resolver": "^1.3",
+# "webmozart/assert": "^1.9.1",
+# "phpdocumentor/reflection-common": "^2.2",
+# "ext-filter": "*"
Requires: php(language) >= 7.2
Requires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpdocumentor/type-resolver) >= 1.0 with php-composer(phpdocumentor/type-resolver) < 2)
-Requires: (php-composer(webmozart/assert) >= 1.0 with php-composer(webmozart/assert) < 2)
-Requires: (php-composer(phpdocumentor/reflection-common) >= 2.0 with php-composer(phpdocumentor/reflection-common) < 3)
+Requires: (php-composer(phpdocumentor/type-resolver) >= 1.3 with php-composer(phpdocumentor/type-resolver) < 2)
+Requires: (php-composer(webmozart/assert) >= 1.9.1 with php-composer(webmozart/assert) < 2)
+Requires: (php-composer(phpdocumentor/reflection-common) >= 2.2 with php-composer(phpdocumentor/reflection-common) < 3)
# remirepo:5
%else
-Requires: php-phpdocumentor-reflection-common2
-Requires: php-phpdocumentor-type-resolver1
-Requires: php-webmozart-assert
+Requires: php-phpdocumentor-type-resolver1 >= 1.3
+Requires: php-webmozart-assert >= 1.9.1
+Requires: php-phpdocumentor-reflection-common2 >= 2.2
%endif
# From phpcompatinfo report for 4.3.2
Requires: php-reflection
@@ -132,7 +134,7 @@ cp -pr src/DocBlock %{buildroot}%{_datadir}/php/phpDocumentor/Reflection/DocBloc
%check
-%if %{with_tests}
+%if %{with tests}
sed -e '/autoload.php/d' -i examples/*.php examples/*/*.php
phpab \
@@ -149,10 +151,11 @@ cat <<BOOTSTRAP | tee -a bootstrap.php
BOOTSTRAP
RETURN_CODE=0
-for PHP_EXEC in php php72 php73 php74; do
+for PHP_EXEC in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $PHP_EXEC; then
- $PHP_EXEC -d auto_prepend_file=$PWD/bootstrap.php \
- %{_bindir}/phpunit8 \
+ set $PHP_EXEC
+ $1 -d auto_prepend_file=$PWD/bootstrap.php \
+ ${2:-%{_bindir}/phpunit9} \
--bootstrap bootstrap.php \
--verbose || RETURN_CODE=1
fi
@@ -174,6 +177,14 @@ exit $RETURN_CODE
%changelog
+* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 5.2.0-1
+- update to 5.2.0
+- raise dependency on phpdocumentor/type-resolver 1.3
+- raise dependency on webmozart/assert 1.9.1
+- raise dependency on phpdocumentor/reflection-common 2.2
+- raise build dependency on mockery/mockery 1.3.2
+- switch to phpunit9
+
* Wed Feb 26 2020 Remi Collet <remi@remirepo.net> - 5.1.0-1
- update to 5.1.0
- drop unneeded hack as our PR was merged upstream