diff options
author | Remi Collet <remi@remirepo.net> | 2017-08-01 15:51:02 +0200 |
---|---|---|
committer | Remi Collet <remi@remirepo.net> | 2017-08-01 15:51:02 +0200 |
commit | 5371ab253210d203902664c3a2d314c09ce5f097 (patch) | |
tree | 21cad5c2b1220511bdf34ecb42df1a83bfc1b5bf | |
parent | 291a6398edd2f43a8ff38529e582baa9d0cab7d2 (diff) |
minor
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | composer.json | 2 | ||||
-rwxr-xr-x | php-phpdocumentor-reflection-docblock-get-source.sh | 4 |
3 files changed, 5 insertions, 3 deletions
@@ -1,4 +1,4 @@ SRCDIR := $(shell pwd) NAME := $(shell basename $(SRCDIR)) -include ../../common/Makefile +include ../../../common/Makefile diff --git a/composer.json b/composer.json index 85be2fd..05cecc1 100644 --- a/composer.json +++ b/composer.json @@ -12,7 +12,7 @@ "require": { "php": ">=5.5", "phpdocumentor/reflection-common": "^1.0@dev", - "phpdocumentor/type-resolver": "^0.2.0", + "phpdocumentor/type-resolver": "^0.4.0", "webmozart/assert": "^1.0" }, "autoload": { diff --git a/php-phpdocumentor-reflection-docblock-get-source.sh b/php-phpdocumentor-reflection-docblock-get-source.sh index 5f9241e..8cf51f1 100755 --- a/php-phpdocumentor-reflection-docblock-get-source.sh +++ b/php-phpdocumentor-reflection-docblock-get-source.sh @@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO" print "GIT_DIR = $GIT_DIR" TEMP_DIR=$(mktemp --dir) +TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz +CMP_FILE=$PWD/composer.json pushd $TEMP_DIR print "Cloning git repo..." @@ -51,6 +53,7 @@ pushd $TEMP_DIR pushd $GIT_DIR print "Checking out commit..." $GIT checkout $GIT_COMMIT + cp composer.json $CMP_FILE popd TAR_DIR=${GIT_NAME}-${GIT_COMMIT} @@ -58,7 +61,6 @@ pushd $TEMP_DIR mv $GIT_DIR $TAR_DIR - TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz print "TAR_FILE = $TAR_FILE" [ -e $TAR_FILE ] && rm -f $TAR_FILE |