summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-common.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpdocumentor-reflection-common.spec')
-rw-r--r--php-phpdocumentor-reflection-common.spec17
1 files changed, 13 insertions, 4 deletions
diff --git a/php-phpdocumentor-reflection-common.spec b/php-phpdocumentor-reflection-common.spec
index 1ff5ee3..4264e4f 100644
--- a/php-phpdocumentor-reflection-common.spec
+++ b/php-phpdocumentor-reflection-common.spec
@@ -12,8 +12,8 @@
%global github_owner phpDocumentor
%global github_name ReflectionCommon
-%global github_version 1.0
-%global github_commit 144c307535e82c8fdcaacbcfc1d6d8eeb896687c
+%global github_version 1.0.1
+%global github_commit 21bdeb5f65d7ebf9f43b1b25d404f87deab5bfb6
%global composer_vendor phpdocumentor
%global composer_project reflection-common
@@ -34,7 +34,10 @@ Summary: Common reflection classes used by phpdocumentor
Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+# GitHub export does not include tests.
+# Run php-phpdocumentor-type-resolver-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
# Tests
@@ -88,7 +91,8 @@ BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection/autoload-common.php
RETURN_CODE=0
for PHP_EXEC in php php56 php70 php71 php72; do
if which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || RETURN_CODE=1
+ $PHP_EXEC -d auto_prepend_file=$BOOTSTRAP \
+ %{_bindir}/phpunit --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -114,5 +118,10 @@ exit $RETURN_CODE
%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- Update to 1.0.1
+- ensure current version is used during the test
+- use git snapshot as sources for tests
+
* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0-1
- Initial package