summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json29
-rw-r--r--php-phpdocumentor-reflection-common.spec3
4 files changed, 42 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..90eee0f
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,29 @@
+{
+ "name": "phpdocumentor/reflection-common",
+ "keywords": ["phpdoc", "phpDocumentor", "reflection", "static analysis", "FQSEN"],
+ "homepage": "http://www.phpdoc.org",
+ "description": "Common reflection classes used by phpdocumentor to reflect the code structure",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Jaap van Otterdijk",
+ "email": "opensource@ijaap.nl"
+ }
+ ],
+ "require": {
+ "php": ">=5.5"
+ },
+ "autoload" : {
+ "psr-4" : {
+ "phpDocumentor\\Reflection\\": ["src"]
+ }
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.6"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
diff --git a/php-phpdocumentor-reflection-common.spec b/php-phpdocumentor-reflection-common.spec
index 74cf36d..1ff5ee3 100644
--- a/php-phpdocumentor-reflection-common.spec
+++ b/php-phpdocumentor-reflection-common.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-phpdocumentor-reflection-common, from:
#
# Fedora spec file for php-phpdocumentor-reflection-common
#
@@ -85,7 +86,7 @@ BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection/autoload-common.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
+for PHP_EXEC in php php56 php70 php71 php72; do
if which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || RETURN_CODE=1
fi