diff options
author | Remi Collet <remi@remirepo.net> | 2022-12-14 10:21:13 +0100 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2022-12-14 10:21:13 +0100 |
commit | ce406abe1818dbe73e38a364769e00fe88e2090a (patch) | |
tree | ae6c56aee06694e7609806a8d56f9f19396976fc | |
parent | 1d5a3c93d4cbb431bfd1d87716d4ef8d8bb86e1b (diff) |
update to 8.2.1RC1
use oracle client library version 21.8
-rw-r--r-- | failed.txt | 2 | ||||
-rw-r--r-- | php82.spec | 12 | ||||
-rw-r--r-- | upstream.patch | 31 |
3 files changed, 8 insertions, 37 deletions
@@ -1,4 +1,4 @@ -===== 8.2.0 (2022-12-08) +===== 8.2.1RC1 (2022-12-15) $ grep -ar 'Tests failed' /var/lib/mock/*/build.log @@ -24,7 +24,7 @@ %global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock) -%global oraclever 21.7 +%global oraclever 21.8 %global oraclelib 21.1 # Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests @@ -107,8 +107,8 @@ %bcond_without libgd %bcond_with zip -%global upver 8.2.0 -#global rcver RC7 +%global upver 8.2.1 +%global rcver RC1 Summary: PHP scripting language for creating dynamic web sites Name: php @@ -174,7 +174,6 @@ Patch47: php-8.1.0-phpinfo.patch Patch91: php-7.2.0-oci8conf.patch # Upstream fixes (100+) -Patch100: upstream.patch # Security fixes (200+) @@ -1181,7 +1180,6 @@ in pure PHP. %patch91 -p1 -b .remi-oci8 # upstream patches -%patch100 -p1 # security patches @@ -2178,6 +2176,10 @@ fi %changelog +* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-1 +- update to 8.2.1RC1 +- use oracle client library version 21.8 + * Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 8.2.0-1 - update to 8.2.0 GA diff --git a/upstream.patch b/upstream.patch deleted file mode 100644 index be72054..0000000 --- a/upstream.patch +++ /dev/null @@ -1,31 +0,0 @@ -From 3d90a24e9349ea17e5467de7b1d7bfa17ec2c650 Mon Sep 17 00:00:00 2001 -From: Jakub Zelenka <bukka@php.net> -Date: Thu, 24 Nov 2022 18:29:44 +0000 -Subject: [PATCH] Fix GH-9997: OpenSSL engine clean up segfault - ---- - NEWS | 3 +++ - ext/openssl/openssl.c | 5 +++-- - 2 files changed, 6 insertions(+), 2 deletions(-) - -diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c -index cb5e6260b4ab..da555c843c15 100644 ---- a/ext/openssl/openssl.c -+++ b/ext/openssl/openssl.c -@@ -1324,13 +1324,14 @@ PHP_MSHUTDOWN_FUNCTION(openssl) - #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined (LIBRESSL_VERSION_NUMBER) - EVP_cleanup(); - -+ /* prevent accessing locking callback from unloaded extension */ -+ CRYPTO_set_locking_callback(NULL); -+ - #ifndef OPENSSL_NO_ENGINE - /* Free engine list initialized by OPENSSL_config */ - ENGINE_cleanup(); - #endif - -- /* prevent accessing locking callback from unloaded extension */ -- CRYPTO_set_locking_callback(NULL); - /* free allocated error strings */ - ERR_free_strings(); - CONF_modules_free(); |