diff options
author | Remi Collet <remi@remirepo.net> | 2022-12-20 16:51:17 +0100 |
---|---|---|
committer | Remi Collet <remi@php.net> | 2022-12-20 16:51:17 +0100 |
commit | 201564529ff056ce254a532f72d0532e9de41561 (patch) | |
tree | 2e9860b0e3294ba7d093a98086a91f5217703d8b | |
parent | a490fbcf113ac2d188515b5d83a1aec4147a2174 (diff) |
add upstream patch for failing test
-rw-r--r-- | failed.txt | 12 | ||||
-rw-r--r-- | php82.spec | 7 | ||||
-rw-r--r-- | upstream.patch | 22 |
3 files changed, 33 insertions, 8 deletions
@@ -3,15 +3,13 @@ $ grep -ar 'Tests failed' /var/lib/mock/*/build.log /var/lib/mock/el7x82/build.log:Tests failed : 0 -/var/lib/mock/el8x82/build.log:Tests failed : 1 -/var/lib/mock/el9x82/build.log:Tests failed : 1 -/var/lib/mock/fc35x82/build.log:Tests failed : 1 -/var/lib/mock/fc36x82/build.log:Tests failed : 1 -/var/lib/mock/fc37x82/build.log:Tests failed : 1 +/var/lib/mock/el8x82/build.log:Tests failed : 0 +/var/lib/mock/el9x82/build.log:Tests failed : 0 +/var/lib/mock/fc35x82/build.log:Tests failed : 0 +/var/lib/mock/fc36x82/build.log:Tests failed : 0 +/var/lib/mock/fc37x82/build.log:Tests failed : 0 -all: - 3 Compatibility of values of same name trait constants is checked after their constant expressions are evaluated [Zend/tests/traits/constant_016.phpt] 1 proc_open give erratic test results :( @@ -113,7 +113,7 @@ Summary: PHP scripting language for creating dynamic web sites Name: php Version: %{upver}%{?rcver:~%{rcver}} -Release: 2%{?dist} +Release: 3%{?dist} # All files licensed under PHP version 3.01, except # Zend is licensed under Zend # TSRM is licensed under BSD @@ -174,6 +174,7 @@ Patch47: php-8.1.0-phpinfo.patch Patch91: php-7.2.0-oci8conf.patch # Upstream fixes (100+) +Patch100: upstream.patch # Security fixes (200+) @@ -1180,6 +1181,7 @@ in pure PHP. %patch91 -p1 -b .remi-oci8 # upstream patches +%patch100 -p1 # security patches @@ -2176,6 +2178,9 @@ fi %changelog +* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-3 +- add upstream patch for failing test + * Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-2 - php-fpm.conf: move include directive after [global] section https://github.com/remicollet/remirepo/issues/225 diff --git a/upstream.patch b/upstream.patch new file mode 100644 index 0000000..ffd13b6 --- /dev/null +++ b/upstream.patch @@ -0,0 +1,22 @@ +From bfa56cf62bfdb07afa93c63ec263ce24a591261d Mon Sep 17 00:00:00 2001 +From: Remi Collet <remi@remirepo.net> +Date: Tue, 20 Dec 2022 15:24:15 +0100 +Subject: [PATCH] Fix #10133 set variables_order en ensure $ENV is set + +--- + Zend/tests/traits/constant_016.phpt | 2 ++ + 1 file changed, 2 insertions(+) + +diff --git a/Zend/tests/traits/constant_016.phpt b/Zend/tests/traits/constant_016.phpt +index 9cb2b29bcc09..0754c1571637 100644 +--- a/Zend/tests/traits/constant_016.phpt ++++ b/Zend/tests/traits/constant_016.phpt +@@ -2,6 +2,8 @@ + Compatibility of values of same name trait constants is checked after their constant expressions are evaluated + --ENV-- + ENSURE_CONSTANT_IS_DEFINED_AT_RUNTIME=1 ++--INI-- ++variables_order=EGPCS + --FILE-- + <?php + |