summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt2
-rw-r--r--macros.php5
-rw-r--r--php81.spec38
3 files changed, 28 insertions, 17 deletions
diff --git a/failed.txt b/failed.txt
index 912dcf4..80380b1 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.1.19RC1 (2023-04-27)
+===== 8.1.19 (2023-05-10)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/macros.php b/macros.php
index 0c750a7..989e8b3 100644
--- a/macros.php
+++ b/macros.php
@@ -18,4 +18,9 @@
%__php %{_bindir}/php
%__ztsphp %{_bindir}/zts-php
+%__phpize %{_bindir}/phpize
+%__ztsphpize %{_bindir}/zts-phpize
+
+%__phpconfig %{_bindir}/php-config
+%__ztsphpconfig %{_bindir}/zts-php-config
diff --git a/php81.spec b/php81.spec
index 298b114..e64c9b4 100644
--- a/php81.spec
+++ b/php81.spec
@@ -110,7 +110,7 @@
%bcond_with zip
%global upver 8.1.19
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -1168,24 +1168,24 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch10 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%if 0%{?rhel} == 7
+%patch -P10 -p1 -b .curltls
%endif
-%patch41 -p1 -b .syslib
+%patch -P41 -p1 -b .syslib
%if %{with tzdata}
-%patch42 -p1 -b .systzdata
+%patch -P42 -p1 -b .systzdata
%endif
-%patch43 -p1 -b .headers
-%patch45 -p1 -b .ldap_r
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
+%patch -P43 -p1 -b .headers
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
@@ -1193,7 +1193,7 @@ in pure PHP.
# Fixes for tests related to tzdata
%if %{with tzdata}
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
%endif
# WIP patch
@@ -1952,7 +1952,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}-%{__isa_bits}/" \
%endif
< %{SOURCE3} > macros.php
%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
-echo '%%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
+echo '%%pecl_xmldir %%{_localstatedir}/lib/php/peclxml' >>macros.php
%endif
install -m 644 -D macros.php \
$RPM_BUILD_ROOT%{macrosdir}/macros.php
@@ -2194,6 +2194,12 @@ fi
%changelog
+* Wed May 10 2023 Remi Collet <remi@remirepo.net> - 8.1.19-1
+- Update to 8.1.19 - http://www.php.net/releases/8_1_19.php
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.1.19~RC1-2
+- define %%__phpize and %%__phpconfig
+
* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.1.19~RC1-1
- update to 8.1.19RC1
- use oracle client library version 21.10