summaryrefslogtreecommitdiffstats
path: root/php81.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-27 08:47:02 +0200
committerRemi Collet <remi@php.net>2021-10-27 08:47:02 +0200
commitb0fbf21f8a284404b315cd011c7803933c21d45e (patch)
treef8dcf16c57fd9771ab2e3f9b93fae3216b87a13a /php81.spec
parentfcd5bd1b273c7aa7d18866967219351b82874111 (diff)
update to 8.1.0RC5
build using system libxcrypt (Fedora only)
Diffstat (limited to 'php81.spec')
-rw-r--r--php81.spec30
1 files changed, 25 insertions, 5 deletions
diff --git a/php81.spec b/php81.spec
index 93b83d8..45b0723 100644
--- a/php81.spec
+++ b/php81.spec
@@ -14,7 +14,7 @@
# Extension version
%global fileinfover 1.0.5
%global oci8ver 3.1.0
-%global zipver 1.19.4
+%global zipver 1.19.5
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -48,12 +48,22 @@
%bcond_with libpcre
%endif
-%if 0%{?fedora} >= 33
+# Using qdbm from "remi" for now, see https://bugzilla.redhat.com/2017308
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
%bcond_without qdbm
%else
%bcond_with qdbm
%endif
+# TODO change when 8.5 released (libxcrypt 4.1.1-6)
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
+# switch to bundled library using --without libxcrypt
+%bcond_without libxcrypt
+%else
+# switch to system library using --with libxcrypt
+%bcond_with libxcrypt
+%endif
+
# Build firebird extensions, you can disable using --without firebird
%bcond_without firebird
@@ -99,13 +109,13 @@
%bcond_with zip
%global upver 8.1.0
-%global rcver RC4
-%global lower RC4
+%global rcver RC5
+%global lower RC5
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -200,6 +210,9 @@ BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
Provides: bundled(pcre2) = 10.32
%endif
+%if %{with libxcrypt}
+BuildRequires: pkgconfig(libxcrypt)
+%endif
BuildRequires: bzip2
BuildRequires: perl
BuildRequires: autoconf
@@ -1378,6 +1391,9 @@ ln -sf ../configure
%if %{with libpcre}
--with-external-pcre \
%endif
+%if %{with libxcrypt}
+ --with-external-libcrypt \
+%endif
--with-zlib \
--with-layout=GNU \
--with-kerberos \
@@ -2163,6 +2179,10 @@ fi
%changelog
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~RC5-1
+- update to 8.1.0RC5
+- build using system libxcrypt (Fedora only)
+
* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~RC4-2
- dba: enable qdbm backend
- dba: drop gdbm backend