summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-02 07:27:58 +0200
committerRemi Collet <remi@remirepo.net>2021-09-02 07:27:58 +0200
commitf847f63e240f9b94ffae9895b21f6da3804afd82 (patch)
treede4745a47a5263790fe4b2bd6a22c8c686ef0fc5 /Makefile
duplicate 8.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..78ac8ed
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,11 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBE := -lphp7
+LIBS := -lphp7 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBE) -o tembed