summaryrefslogtreecommitdiffstats
path: root/php80.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php80.spec')
-rw-r--r--php80.spec226
1 files changed, 103 insertions, 123 deletions
diff --git a/php80.spec b/php80.spec
index 4ed2d23..e21571e 100644
--- a/php80.spec
+++ b/php80.spec
@@ -8,19 +8,19 @@
# Please preserve changelog entries
#
# API/ABI check
-%global apiver 20190902
-%global zendver 20190902
+%global apiver 20200804
+%global zendver 20200804
%global pdover 20170320
# Extension version
%global fileinfover 1.0.5
-%global oci8ver 2.2.0
-%global zipver 1.13.0
+%global oci8ver 3.0.0
+%global zipver 1.19.0
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 7.4
+%global embed_version 8.0
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
@@ -35,8 +35,7 @@
%global with_lsws 1
# Regression tests take a long time, you can skip 'em with this
-#global runselftest 0
-%{!?runselftest: %global runselftest 1}
+%bcond_without tests
# Use the arch-specific mysql_config binary to avoid mismatch with the
# arch detection heuristic used by bindir/mysql_config.
@@ -99,9 +98,9 @@
%global with_libzip 1
%global with_zip 0
-%global upver 7.4.10
-#global rcver RC1
-#global lower RC1
+%global upver 8.0.0
+%global rcver beta3
+%global lower beta3
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -114,7 +113,6 @@ Release: 1%{?dist}
# ext/date/lib is MIT
# Zend/zend_sort is NCSA
License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA
-Group: Development/Languages
URL: http://www.php.net/
Source0: http://www.php.net/distributions/php-%{upver}%{?rcver}.tar.xz
@@ -144,19 +142,22 @@ Source53: 20-ffi.ini
# Build fixes
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
-Patch6: php-7.4.0-embed.patch
-Patch8: php-7.2.0-libdb.patch
+Patch6: php-8.0.0-embed.patch
+Patch8: php-7.4.0-libdb.patch
Patch9: php-7.0.7-curl.patch
# Functional changes
-Patch42: php-7.3.3-systzdata-v18.patch
+# Use system nikic/php-parser
+Patch41: php-8.0.0-parser.patch
+# use system tzdata
+Patch42: php-8.0.0-systzdata-v19.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# drop "Configure command" from phpinfo output
-# and add build system and provider (from 8.0)
-Patch47: php-7.4.8-phpinfo.patch
+# and only use gcc (instead of full version)
+Patch47: php-8.0.0-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -167,13 +168,13 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
-Patch300: php-7.0.10-datetests.patch
+Patch300: php-7.4.0-datetests.patch
# WIP
BuildRequires: gnupg2
BuildRequires: bzip2-devel
-BuildRequires: pkgconfig(libcurl) >= 7.15.5
+BuildRequires: pkgconfig(libcurl) >= 7.29.0
BuildRequires: httpd-devel >= 2.0.46-1
BuildRequires: pam-devel
%if %{with_httpd2410}
@@ -216,6 +217,7 @@ BuildRequires: /bin/ps
Obsoletes: php53, php53u, php54w, php55u, php55w, php56u, php56w, mod_php70u, php70w, mod_php71u, mod_php71w, mod_php72u, mod_php72w
Obsoletes: mod_php73, mod_php73w
Obsoletes: mod_php74, mod_php74w
+Obsoletes: mod_php80
%endif
# Avoid obsoleting php54 from RHSCL
Obsoletes: php54 > 5.4
@@ -242,7 +244,6 @@ Recommends: php-cli%{?_isa} = %{version}-%{release}
# httpd have threaded MPM by default
Recommends: php-fpm%{?_isa} = %{version}-%{release}
# as "php" is now mostly a meta-package, commonly used extensions
-Recommends: php-json%{?_isa} = %{version}-%{release}
Recommends: php-mbstring%{?_isa} = %{version}-%{release}
Recommends: php-opcache%{?_isa} = %{version}-%{release}
Recommends: php-pdo%{?_isa} = %{version}-%{release}
@@ -268,7 +269,6 @@ The php package contains the module (often referred to as mod_php)
which adds support for the PHP language to Apache HTTP Server.
%package cli
-Group: Development/Languages
Summary: Command-line interface for PHP
# sapi/cli/ps_title.c is PostgreSQL
License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and PostgreSQL
@@ -281,6 +281,7 @@ Obsoletes: php53-cli, php53u-cli, php54-cli, php54w-cli, php55u-cli, php55w-cli,
Obsoletes: php70u-cli, php70w-cli, php71u-cli, php71w-cli, php72u-cli, php72w-cli
Obsoletes: php73-cli, php73w-cli
Obsoletes: php74-cli, php74w-cli
+Obsoletes: php80-cli
%endif
%description cli
@@ -289,20 +290,19 @@ executing PHP scripts, /usr/bin/php, and the CGI interface.
%package dbg
-Group: Development/Languages
Summary: The interactive PHP debugger
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel}
Obsoletes: php56u-dbg, php56w-dbg, php70u-dbg, php70w-phpdbg, php71u-dbg, php71w-phpdbg, php72u-dbg, php72w-phpdbg
Obsoletes: php73-dbg, php73w-phpdbg
Obsoletes: php74-dbg, php74w-phpdbg
+Obsoletes: php80-dbg
%endif
%description dbg
The php-dbg package contains the interactive PHP debugger.
%package fpm
-Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
BuildRequires: pkgconfig(libsystemd) >= 209
@@ -332,6 +332,7 @@ Obsoletes: php53-fpm, php53u-fpm, php54-fpm, php54w-fpm, php55u-fpm, php55w-fpm,
Obsoletes: php70u-fpm, php70w-fpm, php71u-fpm, php71w-fpm, php72u-fpm, php72w-fpm
Obsoletes: php73-fpm, php73w-fpm
Obsoletes: php74-fpm, php74w-fpm
+Obsoletes: php80-fpm
%endif
%description fpm
@@ -342,13 +343,13 @@ any size, especially busier sites.
%if %{with_lsws}
%package litespeed
Summary: LiteSpeed Web Server PHP support
-Group: Development/Languages
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel}
Obsoletes: php53-litespeed, php53u-litespeed, php54-litespeed, php54w-litespeed, php55u-litespeed, php55w-litespeed, php56u-litespeed, php56w-litespeed
Obsoletes: php70u-litespeed, php70w-litespeed, php71u-litespeed, php71w-litespeed, php72u-litespeed, php72w-litespeed
Obsoletes: php73-litespeed, php73w-litespeed
Obsoletes: php74-litespeed, php74w-litespeed
+Obsoletes: php80-litespeed
%endif
%description litespeed
@@ -357,7 +358,6 @@ used by the LiteSpeed Web Server (LSAPI enabled PHP).
%endif
%package common
-Group: Development/Languages
Summary: Common files for PHP
# All files licensed under PHP version 3.01, except
# fileinfo is licensed under PHP version 3.0
@@ -384,6 +384,8 @@ Provides: php-gettext, php-gettext%{?_isa}
Provides: php-hash, php-hash%{?_isa}
Provides: php-mhash = %{version}, php-mhash%{?_isa} = %{version}
Provides: php-iconv, php-iconv%{?_isa}
+Obsoletes: php-json < 8
+Provides: php-json = %{upver}, %{?scl_prefix}php-json%{?_isa} = %{upver}
Provides: php-libxml, php-libxml%{?_isa}
Provides: php-openssl, php-openssl%{?_isa}
Provides: php-phar, php-phar%{?_isa}
@@ -395,9 +397,6 @@ Provides: php-spl, php-spl%{?_isa}
Provides: php-standard = %{version}, php-standard%{?_isa} = %{version}
Provides: php-tokenizer, php-tokenizer%{?_isa}
Provides: php-zlib, php-zlib%{?_isa}
-# For user experience, those extensions were part of php-common
-Requires: php-json%{?_isa} = %{version}-%{release}
-#Requires: php-zip%%{?_isa}
Obsoletes: php-pecl-phar < 1.2.4
Obsoletes: php-pecl-Fileinfo < 1.0.5
@@ -410,6 +409,18 @@ Obsoletes: php53-common, php53u-common, php54-common, php54w-common, php55u-comm
Obsoletes: php70u-common, php70w-common, php71u-common, php71w-common, php72u-common, php72w-common
Obsoletes: php73-common, php73w-common
Obsoletes: php74-common, php74w-common
+Obsoletes: php80-common
+# Json
+Obsoletes: php53-json, php53u-json, php54-json, php54w-json, php55u-json, php55w-json, php56u-json, php56w-json
+Obsoletes: php55u-pecl-jsonc, php56u-pecl-jsonc
+Obsoletes: php70u-json, php70w-json, php71u-json, php71w-json, php72u-json, php72w-json
+Obsoletes: php73-json, php73w-json
+Obsoletes: php74-json, php74w-json
+# Xmlrpc
+Obsoletes: php53-xmlrpc, php53u-xmlrpc, php54-xmlrpc, php54w-xmlrpc, php55u-xmlrpc, php55w-xmlrpc, php56u-xmlrpc, php56w-xmlrpc
+Obsoletes: php70u-xmlrpc, php70w-xmlrpc, php71u-xmlrpc, php71w-xmlrpc, php72u-xmlrpc, php72w-xmlrpc
+Obsoletes: php73-xmlrpc, php73w-xmlrpc
+Obsoletes: php74-xmlrpc, php74w-xmlrpc
%endif
%description common
@@ -417,7 +428,6 @@ The php-common package contains files used by both the php
package and the php-cli package.
%package devel
-Group: Development/Libraries
Summary: Files needed for building PHP extensions
Requires: php-cli%{?_isa} = %{version}-%{release}
# always needed to build extension
@@ -447,6 +457,10 @@ Obsoletes: php55u-pecl-jsonc-devel, php56u-pecl-jsonc-devel
Obsoletes: php70u-devel, php70w-devel, php71u-devel, php71w-devel, php72u-devel, php72w-devel
Obsoletes: php73-devel, php73w-devel
Obsoletes: php74-devel, php74w-devel
+Obsoletes: php80-devel
+%endif
+%if 0%{?fedora} || 0%{?rhel} >= 8
+Recommends: php-nikic-php-parser4 >= 4.3.0
%endif
%description devel
@@ -456,7 +470,6 @@ need to install this package.
%package opcache
Summary: The Zend OPcache
-Group: Development/Languages
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: php-pecl-zendopcache
@@ -469,6 +482,7 @@ Obsoletes: php55u-opcache, php55w-opcache, php56u-opcache, php56w-opcache
Obsoletes: php70u-opcache, php70w-opcache, php71u-opcache, php71w-opcache, php72u-opcache, php72w-opcache
Obsoletes: php73-opcache, php73w-opcache
Obsoletes: php74-opcache, php74w-opcache
+Obsoletes: php80-opcache
%endif
%description opcache
@@ -480,7 +494,6 @@ bytecode optimization patterns that make code execution faster.
%package imap
Summary: A module for PHP applications that use IMAP
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -494,6 +507,7 @@ Obsoletes: php53-imap, php53u-imap, php54-imap, php54w-imap, php55u-imap, php55w
Obsoletes: php70u-imap, php70w-imap, php71u-imap, php71w-imap, php72u-imap, php72w-imap
Obsoletes: php73-imap, php73w-imap
Obsoletes: php74-imap, php74w-imap
+Obsoletes: php80-imap
%endif
%description imap
@@ -503,7 +517,6 @@ messages on mail servers. PHP is an HTML-embedded scripting language.
%package ldap
Summary: A module for PHP applications that use LDAP
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -515,6 +528,7 @@ Obsoletes: php53-ldap, php53u-ldap, php54-ldap, php54w-ldap, php55u-ldap, php55w
Obsoletes: php70u-ldap, php70w-ldap, php71u-ldap, php71w-ldap, php72u-ldap, php72w-ldap
Obsoletes: php73-ldap, php73w-ldap
Obsoletes: php74-ldap, php74w-ldap
+Obsoletes: php80-ldap
%endif
%description ldap
@@ -525,7 +539,6 @@ language.
%package pdo
Summary: A database access abstraction module for PHP applications
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -539,6 +552,7 @@ Obsoletes: php53-pdo, php53u-pdo, php54-pdo, php54w-pdo, php55u-pdo, php55w-pdo,
Obsoletes: php70u-pdo, php70w-pdo, php71u-pdo, php71w-pdo, php72u-pdo, php72w-pdo
Obsoletes: php73-pdo, php73w-pdo
Obsoletes: php74-pdo, php74w-pdo
+Obsoletes: php80-pdo
%endif
%description pdo
@@ -549,7 +563,6 @@ databases.
%package mysqlnd
Summary: A module for PHP applications that use MySQL databases
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-pdo%{?_isa} = %{version}-%{release}
@@ -563,6 +576,7 @@ Obsoletes: php53-mysqlnd, php53u-mysqlnd, php54-mysqlnd, php54w-mysqlnd, php55u-
Obsoletes: php70u-mysqlnd, php70w-mysqlnd, php71u-mysqlnd, php71w-mysqlnd, php72u-mysqlnd, php72w-mysqlnd
Obsoletes: php73-mysqlnd, php73w-mysqlnd
Obsoletes: php74-mysqlnd, php74w-mysqlnd
+Obsoletes: php80-mysqlnd
Obsoletes: php53-mysql, php53u-mysql, php54-mysql, php54w-mysql, php55u-mysql, php55w-mysql, php56u-mysql, php56w-mysql
Obsoletes: php70u-mysql, php70w-mysql, php71u-mysql, php71w-mysql, php72u-mysql, php72w-mysql
%endif
@@ -578,7 +592,6 @@ This package use the MySQL Native Driver
%package pgsql
Summary: A PostgreSQL database module for PHP
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-pdo%{?_isa} = %{version}-%{release}
@@ -592,6 +605,7 @@ Obsoletes: php53-pgsql, php53u-pgsql, php54-pgsql, php54w-pgsql, php55u-pgsql, p
Obsoletes: php70u-pgsql, php70w-pgsql, php71u-pgsql, php71w-pgsql, php72u-pgsql, php72w-pgsql
Obsoletes: php73-pgsql, php73w-pgsql
Obsoletes: php74-pgsql, php74w-pgsql
+Obsoletes: php80-pgsql
%endif
%description pgsql
@@ -604,7 +618,6 @@ php package.
%package process
Summary: Modules for PHP script using system process interfaces
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -618,6 +631,7 @@ Obsoletes: php53-process, php53u-process, php54-process, php54w-process, php55u-
Obsoletes: php70u-process, php70w-process, php71u-process, php71w-process, php72u-process, php72w-process
Obsoletes: php73-process, php73w-process
Obsoletes: php74-process, php74w-process
+Obsoletes: php80-process
%endif
%description process
@@ -627,7 +641,6 @@ communication.
%package odbc
Summary: A module for PHP applications that use ODBC databases
-Group: Development/Languages
# All files licensed under PHP version 3.01, except
# pdo_odbc is licensed under PHP version 3.0
License: PHP
@@ -641,6 +654,7 @@ Obsoletes: php53-odbc, php53u-odbc, php54-odbc, php54w-odbc, php55u-odbc, php55w
Obsoletes: php70u-odbc, php70w-odbc, php71u-odbc, php71w-odbc, php72u-odbc, php72w-odbc
Obsoletes: php73-odbc, php73w-odbc
Obsoletes: php74-odbc, php74w-odbc
+Obsoletes: php80-odbc
%endif
%description odbc
@@ -654,7 +668,6 @@ package.
%package soap
Summary: A module for PHP applications that use the SOAP protocol
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -664,6 +677,7 @@ Obsoletes: php53-soap, php53u-soap, php54-soap, php54w-soap, php55u-soap, php55w
Obsoletes: php70u-soap, php70w-soap, php71u-soap, php71w-soap, php72u-soap, php72w-soap
Obsoletes: php73-soap, php73w-soap
Obsoletes: php74-soap, php74w-soap
+Obsoletes: php80-soap
%endif
%description soap
@@ -673,7 +687,6 @@ support to PHP for using the SOAP web services protocol.
%if %{with_firebird}
%package pdo-firebird
Summary: PDO driver for Interbase/Firebird databases
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
BuildRequires: firebird-devel
@@ -685,6 +698,7 @@ Obsoletes: php53-interbase, php53u-interbase, php54-interbase, php54w-interbase,
Obsoletes: php70u-interbase, php70w-interbase, php71u-interbase, php71w-interbase, php72u-interbase, php72w-interbase
Obsoletes: php73-interbase, php73w-interbase
Obsoletes: php74-pdo-firebird, php74w-pdo-firebird
+Obsoletes: php80-pdo-firebird
%endif
%description pdo-firebird
@@ -695,7 +709,6 @@ Interbase/Firebird databases.
%if %{with_oci8}
%package oci8
Summary: A module for PHP applications that use OCI8 databases
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
BuildRequires: oracle-instantclient-devel >= %{oraclever}
@@ -714,6 +727,7 @@ Obsoletes: php53-oci8, php53u-oci8, php54-oci8, php54w-oci8, php55u-oci8, p
Obsoletes: php70u-oci8, php70w-oci8, php71u-oci8, php71w-oci8, php72u-oci8, php72w-oci8
Obsoletes: php73-oci8, php73w-oci8
Obsoletes: php74-oci8, php74w-oci8
+Obsoletes: php80-oci8
%endif
%description oci8
@@ -737,7 +751,6 @@ Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%package snmp
Summary: A module for PHP applications that query SNMP-managed devices
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}, net-snmp
@@ -747,6 +760,7 @@ Obsoletes: php53-snmp, php53u-snmp, php54-snmp, php54w-snmp, php55u-snmp, php55w
Obsoletes: php70u-snmp, php70w-snmp, php71u-snmp, php71w-snmp, php72u-snmp, php72w-snmp
Obsoletes: php73-snmp, php73w-snmp
Obsoletes: php74-snmp, php74w-snmp
+Obsoletes: php80-snmp
%endif
%description snmp
@@ -757,7 +771,6 @@ will need to install this package and the php package.
%package xml
Summary: A module for PHP applications which use XML
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -775,6 +788,7 @@ Obsoletes: php53-xml, php53u-xml, php54-xml, php54w-xml, php55u-xml, php55w-xml,
Obsoletes: php70u-xml, php70w-xml, php71u-xml, php71w-xml, php72u-xml, php72w-xml
Obsoletes: php73-xml, php73w-xml
Obsoletes: php74-xml, php74w-xml
+Obsoletes: php80-xml
%endif
%description xml
@@ -782,27 +796,8 @@ The php-xml package contains dynamic shared objects which add support
to PHP for manipulating XML documents using the DOM tree,
and performing XSL transformations on XML documents.
-%package xmlrpc
-Summary: A module for PHP applications which use the XML-RPC protocol
-Group: Development/Languages
-# All files licensed under PHP version 3.01, except
-# libXMLRPC is licensed under BSD
-License: PHP and BSD
-Requires: php-xml%{?_isa} = %{version}-%{release}
-%if 0%{?rhel}
-Obsoletes: php53-xmlrpc, php53u-xmlrpc, php54-xmlrpc, php54w-xmlrpc, php55u-xmlrpc, php55w-xmlrpc, php56u-xmlrpc, php56w-xmlrpc
-Obsoletes: php70u-xmlrpc, php70w-xmlrpc, php71u-xmlrpc, php71w-xmlrpc, php72u-xmlrpc, php72w-xmlrpc
-Obsoletes: php73-xmlrpc, php73w-xmlrpc
-Obsoletes: php74-xmlrpc, php74w-xmlrpc
-%endif
-
-%description xmlrpc
-The php-xmlrpc package contains a dynamic shared object that will add
-support for the XML-RPC protocol to PHP.
-
%package mbstring
Summary: A module for PHP applications which need multi-byte string handling
-Group: Development/Languages
# All files licensed under PHP version 3.01, except
# libmbfl is licensed under LGPLv2
# onigurama is licensed under BSD
@@ -820,6 +815,7 @@ Obsoletes: php53-mbstring, php53u-mbstring, php54-mbstring, php54w-mbstring, php
Obsoletes: php70u-mbstring, php70w-mbstring, php71u-mbstring, php71w-mbstring, php72u-mbstring, php72w-mbstring
Obsoletes: php73-mbstring, php73w-mbstring
Obsoletes: php74-mbstring, php74w-mbstring
+Obsoletes: php80-mbstring
%endif
%description mbstring
@@ -828,7 +824,6 @@ support for multi-byte string handling to PHP.
%package gd
Summary: A module for PHP applications for using the gd graphics library
-Group: Development/Languages
# All files licensed under PHP version 3.01
%if %{with_libgd}
License: PHP
@@ -859,6 +854,7 @@ Obsoletes: php53-gd, php53u-gd, php54-gd, php54w-gd, php55u-gd, php55w-gd, php56
Obsoletes: php70u-gd, php70w-gd, php71u-gd, php71w-gd, php72u-gd, php72w-gd
Obsoletes: php73-gd, php73w-gd
Obsoletes: php74-gd, php74w-gd
+Obsoletes: php80-gd
%endif
%description gd
@@ -867,7 +863,6 @@ support for using the gd graphics library to PHP.
%package bcmath
Summary: A module for PHP applications for using the bcmath library
-Group: Development/Languages
# All files licensed under PHP version 3.01, except
# libbcmath is licensed under LGPLv2+
License: PHP and LGPLv2+
@@ -877,6 +872,7 @@ Obsoletes: php53-bcmath, php53u-bcmath, php54-bcmath, php54w-bcmath, php55u-bcma
Obsoletes: php70u-bcmath, php70w-bcmath, php71u-bcmath, php71w-bcmath, php72u-bcmath, php72w-bcmath
Obsoletes: php73-bcmath, php73w-bcmath
Obsoletes: php74-bcmath, php74w-bcmath
+Obsoletes: php80-bcmath
%endif
Provides: bundled(libbcmath)
@@ -886,7 +882,6 @@ support for using the bcmath library to PHP.
%package gmp
Summary: A module for PHP applications for using the GNU MP library
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
BuildRequires: gmp-devel
@@ -896,6 +891,7 @@ Obsoletes: php53-gmp, php53u-gmp, php54-gmp, php54w-gmp, php55u-gmp, php55w-gmp,
Obsoletes: php70u-gmp, php70w-gmp, php71u-gmp, php71w-gmp, php72u-gmp, php72w-gmp
Obsoletes: php73-gmp, php73w-gmp
Obsoletes: php74-gmp, php74w-gmp
+Obsoletes: php80-gmp
%endif
%description gmp
@@ -904,7 +900,6 @@ using the GNU MP library.
%package dba
Summary: A database abstraction layer module for PHP applications
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
BuildRequires: libdb-devel
@@ -917,6 +912,7 @@ Obsoletes: php53-dba, php53u-dba, php54-dba, php54w-dba, php55u-dba, php55w-dba,
Obsoletes: php70u-dba, php70w-dba, php71u-dba, php71w-dba, php72u-dba, php72w-dba
Obsoletes: php73-dba, php73w-dba
Obsoletes: php74-dba, php74w-dba
+Obsoletes: php80-dba
%endif
%description dba
@@ -925,7 +921,6 @@ support for using the DBA database abstraction layer to PHP.
%package tidy
Summary: Standard PHP module provides tidy library support
-Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -935,6 +930,7 @@ Obsoletes: php53-tidy, php53u-tidy, php54-tidy, php54w-tidy, php55u-tidy, php55w
Obsoletes: php70u-tidy, php70w-tidy, php71u-tidy, php71w-tidy, php72u-tidy, php72w-tidy
Obsoletes: php73-tidy, php73w-tidy
Obsoletes: php74-tidy, php74w-tidy
+Obsoletes: php80-tidy
%endif
%description tidy
@@ -954,6 +950,7 @@ Obsoletes: php53-mssql, php53u-mssql, php54-mssql, php54w-mssql, php55u-mssql, p
Obsoletes: php70u-pdo-dblib, php70w-pdo_dblib, php71u-pdo-dblib, php71w-pdo_dblib, php72u-pdo-dblib, php72w-pdo_dblib
Obsoletes: php73-pdo-dblib, php73w-pdo_dblib
Obsoletes: php74-pdo-dblib, php74w-pdo_dblib
+Obsoletes: php80-pdo-dblib
%endif
%description pdo-dblib
@@ -963,7 +960,6 @@ PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.
%package embedded
Summary: PHP library for embedding in applications
-Group: System Environment/Libraries
Requires: php-common%{?_isa} = %{version}-%{release}
# doing a real -devel package for just the .so symlink is a bit overkill
Provides: php-embedded-devel = %{version}-%{release}
@@ -973,6 +969,7 @@ Obsoletes: php53-embedded, php53u-embedded, php54-embedded, php54w-embedded, php
Obsoletes: php70u-embedded, php70w-embedded, php71u-embedded, php71w-embedded, php72u-embedded, php72w-embedded
Obsoletes: php73-embedded, php73w-embedded
Obsoletes: php74-embedded, php74w-embedded
+Obsoletes: php80-embedded
%endif
%description embedded
@@ -981,7 +978,6 @@ into applications to provide PHP scripting language support.
%package pspell
Summary: A module for PHP applications for using pspell interfaces
-Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -991,6 +987,7 @@ Obsoletes: php53-pspell, php53u-pspell, php54-pspell, php54w-pspell, php55u-pspe
Obsoletes: php70u-pspell, php70w-pspell, php71u-pspell, php71w-pspell, php72u-pspell, php72w-pspell
Obsoletes: php73-pspell, php73w-pspell
Obsoletes: php74-pspell, php74w-pspell
+Obsoletes: php80-pspell
%endif
%description pspell
@@ -999,7 +996,6 @@ support for using the pspell library to PHP.
%package intl
Summary: Internationalization extension for PHP applications
-Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
@@ -1011,6 +1007,7 @@ Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
Obsoletes: php73-intl, php73w-intl
Obsoletes: php74-intl, php74w-intl
+Obsoletes: php80-intl
%endif
%description intl
@@ -1019,16 +1016,16 @@ support for using the ICU library to PHP.
%package enchant
Summary: Enchant spelling extension for PHP applications
-Group: System Environment/Libraries
# All files licensed under PHP version 3.0
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(enchant)
+BuildRequires: pkgconfig(enchant-2)
%if 0%{?rhel}
Obsoletes: php53-enchant, php53u-enchant, php54-enchant, php54w-enchant, php55u-enchant, php55w-enchant, php56u-enchant, php56w-enchant
Obsoletes: php70u-enchant, php70w-enchant, php71u-enchant, php71w-enchant, php72u-enchant, php72w-enchant
Obsoletes: php73-enchant, php73w-enchant
Obsoletes: php74-enchant, php74w-enchant
+Obsoletes: php80-enchant
%endif
%description enchant
@@ -1040,7 +1037,6 @@ support for using the enchant library to PHP.
Summary: ZIP archive management extension for PHP
# All files licensed under PHP version 3.0.1
License: PHP
-Group: System Environment/Libraries
Requires: php-common%{?_isa} = %{version}-%{release}
Obsoletes: php-pecl-zip < %{zipver}
Provides: php-pecl(zip) = %{zipver}
@@ -1052,6 +1048,7 @@ Obsoletes: php53-zip, php53u-zip, php54-zip, php54w-zip, php55u-zip, php55w-zip,
Obsoletes: php70u-zip, php70w-zip, php71u-zip, php71w-zip, php72u-zip, php72w-zip
Obsoletes: php73-zip, php73w-zip
Obsoletes: php74-zip, php74w-zip
+Obsoletes: php80-zip
%endif
%if %{with_libzip}
BuildRequires: pkgconfig(libzip) >= 0.11
@@ -1062,36 +1059,10 @@ The php-zip package provides an extension that will add
support for ZIP archive management to PHP.
%endif
-%package json
-Summary: JavaScript Object Notation extension for PHP
-# All files licensed under PHP version 3.0.1
-License: PHP
-Group: System Environment/Libraries
-Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: php-pecl-json < %{version}
-Obsoletes: php-pecl-jsonc < %{version}
-Provides: php-pecl(json) = %{version}
-Provides: php-pecl(json)%{?_isa} = %{version}
-Provides: php-pecl-json = %{version}
-Provides: php-pecl-json%{?_isa} = %{version}
-%if 0%{?rhel}
-Obsoletes: php53-json, php53u-json, php54-json, php54w-json, php55u-json, php55w-json, php56u-json, php56w-json
-Obsoletes: php55u-pecl-jsonc, php56u-pecl-jsonc
-Obsoletes: php70u-json, php70w-json, php71u-json, php71w-json, php72u-json, php72w-json
-Obsoletes: php73-json, php73w-json
-Obsoletes: php74-json, php74w-json
-%endif
-
-%description json
-The php-json package provides an extension that will add
-support for JavaScript Object Notation (JSON) to PHP.
-
-
%package sodium
Summary: Wrapper for the Sodium cryptographic library
# All files licensed under PHP version 3.0.1
License: PHP
-Group: System Environment/Libraries
# Minimal is 1.0.8, 1.0.14 is needed for argon2 password
BuildRequires: pkgconfig(libsodium) >= 1.0.14
@@ -1103,6 +1074,7 @@ Provides: php-pecl(libsodium)%{?_isa} = %{version}
Obsoletes: php72u-sodium, php72w-sodium
Obsoletes: php73-sodium, php73w-sodium
Obsoletes: php74-sodium, php74w-sodium
+Obsoletes: php80-sodium
%endif
%description sodium
@@ -1114,12 +1086,12 @@ low-level PHP extension for the libsodium cryptographic library.
Summary: Foreign Function Interface
# All files licensed under PHP version 3.0.1
License: PHP
-Group: System Environment/Libraries
BuildRequires: pkgconfig(libffi)
Requires: php-common%{?_isa} = %{version}-%{release}
%if 0%{?rhel}
Obsoletes: php74-ffi, php74w-ffi
+Obsoletes: php80-ffi
%endif
%description ffi
@@ -1146,7 +1118,8 @@ in pure PHP.
%patch9 -p1 -b .curltls
%endif
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 6
+%patch41 -p1 -b .syslib
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 6
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -1301,6 +1274,8 @@ export PHP_BUILD_SYSTEM=$(cat /etc/redhat-release | sed -e 's/ Beta//')
%if 0%{?vendor:1}
export PHP_BUILD_PROVIDER="%{vendor}"
%endif
+export PHP_BUILD_COMPILER="$(gcc --version | head -n1)"
+export PHP_BUILD_ARCH="%{_arch}"
# Force use of system libtool:
libtoolize --force --copy
@@ -1422,7 +1397,6 @@ build --libdir=%{_libdir}/php \
--with-iconv=shared \
--enable-sockets=shared \
--enable-tokenizer=shared \
- --with-xmlrpc=shared \
--with-ldap=shared --with-ldap-sasl \
--enable-mysqlnd=shared \
--with-mysqli=shared,mysqlnd \
@@ -1455,7 +1429,6 @@ build --libdir=%{_libdir}/php \
--with-pdo-sqlite=shared \
--with-pdo-dblib=shared,%{_prefix} \
--with-sqlite3=shared \
- --enable-json=shared \
%if %{with_zip}
--with-zip=shared \
%endif
@@ -1479,7 +1452,6 @@ without_shared="--disable-gd \
--disable-dom --disable-dba --without-unixODBC \
--disable-opcache \
--disable-phpdbg \
- --disable-json \
--without-ffi \
--disable-xmlreader --disable-xmlwriter \
--without-sodium \
@@ -1515,7 +1487,7 @@ build --enable-fpm \
popd
# Build for inclusion as embedded script language into applications,
-# /usr/lib[64]/libphp7.so
+# /usr/lib[64]/libphp.so
pushd build-embedded
build --enable-embed \
--without-mysqli --disable-pdo \
@@ -1563,7 +1535,6 @@ build --includedir=%{_includedir}/php-zts \
--enable-tokenizer=shared \
--enable-exif=shared \
--enable-ftp=shared \
- --with-xmlrpc=shared \
--with-ldap=shared --with-ldap-sasl \
--enable-mysqlnd=shared \
--with-mysqli=shared,mysqlnd \
@@ -1597,7 +1568,6 @@ build --includedir=%{_includedir}/php-zts \
--with-pdo-sqlite=shared \
--with-pdo-dblib=shared,%{_prefix} \
--with-sqlite3=shared \
- --enable-json=shared \
%if %{with_zip}
--with-zip=shared \
%endif
@@ -1635,7 +1605,7 @@ popd
%check
-%if %runselftest
+%if %{with tests}
cd build-apache
# Run tests, using the CLI SAPI
@@ -1693,18 +1663,18 @@ install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/php/preload
# install the DSO
install -m 755 -d $RPM_BUILD_ROOT%{_httpd_moddir}
-install -m 755 build-apache/libs/libphp7.so $RPM_BUILD_ROOT%{_httpd_moddir}/libphp7.so
+install -m 755 build-apache/libs/libphp.so $RPM_BUILD_ROOT%{_httpd_moddir}/libphp.so
%if %{with_zts}
# install the ZTS DSO
-install -m 755 build-zts/libs/libphp7.so $RPM_BUILD_ROOT%{_httpd_moddir}/libphp7-zts.so
+install -m 755 build-zts/libs/libphp.so $RPM_BUILD_ROOT%{_httpd_moddir}/libphp-zts.so
%endif
# Apache config fragment
# Dual config file with httpd >= 2.4 (fedora >= 18)
-install -D -m 644 %{SOURCE9} $RPM_BUILD_ROOT%{_httpd_modconfdir}/15-php.conf
+install -D -m 644 %{SOURCE9} $RPM_BUILD_ROOT%{_httpd_modconfdir}/20-php.conf
%if %{with_zts} && 0%{?fedora} < 27 && 0%{?rhel} < 8
-cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_modconfdir}/15-php.conf
+cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_modconfdir}/20-php.conf
%endif
install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/php.conf
@@ -1805,7 +1775,7 @@ done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
-for mod in pgsql odbc ldap snmp imap json \
+for mod in pgsql odbc ldap snmp imap \
mysqlnd mysqli \
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
@@ -1827,14 +1797,14 @@ for mod in pgsql odbc ldap snmp imap json \
%if %{with_firebird}
pdo_firebird \
%endif
- xmlrpc xmlreader xmlwriter
+ xmlreader xmlwriter
do
case $mod in
opcache)
# Zend extensions
TESTCMD="$TESTCMD --define zend_extension=$mod"
ini=10-${mod}.ini;;
- pdo_*|mysqli|xmlreader|xmlrpc)
+ pdo_*|mysqli|xmlreader)
# Extensions with dependencies on 20-*
TESTCMD="$TESTCMD --define extension=$mod"
ini=30-${mod}.ini;;
@@ -1934,8 +1904,8 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/php/modules/*.a \
$RPM_BUILD_ROOT%{_datadir}/pear \
$RPM_BUILD_ROOT%{_bindir}/zts-phar* \
$RPM_BUILD_ROOT%{_mandir}/man1/zts-phar* \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.a \
- $RPM_BUILD_ROOT%{_libdir}/libphp7.la
+ $RPM_BUILD_ROOT%{_libdir}/libphp.a \
+ $RPM_BUILD_ROOT%{_libdir}/libphp.la
# Remove irrelevant docs
rm -f README.{Zeus,QNX,CVS-RULES}
@@ -2003,15 +1973,15 @@ fi
%{!?_licensedir:%global license %%doc}
%files
-%{_httpd_moddir}/libphp7.so
+%{_httpd_moddir}/libphp.so
%if %{with_zts}
-%{_httpd_moddir}/libphp7-zts.so
+%{_httpd_moddir}/libphp-zts.so
%endif
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/opcache
%config(noreplace) %{_httpd_confdir}/php.conf
-%config(noreplace) %{_httpd_modconfdir}/15-php.conf
+%config(noreplace) %{_httpd_modconfdir}/20-php.conf
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
@@ -2062,7 +2032,7 @@ fi
%{_bindir}/zts-phpdbg
%{_mandir}/man1/zts-phpdbg.1*
%endif
-%doc sapi/phpdbg/{README.md,CREDITS}
+%doc sapi/phpdbg/CREDITS
%files fpm
%doc php-fpm.conf.default www.conf.default
@@ -2120,8 +2090,8 @@ fi
%{macrosdir}/macros.php
%files embedded
-%{_libdir}/libphp7.so
-%{_libdir}/libphp7-%{embed_version}.so
+%{_libdir}/libphp.so
+%{_libdir}/libphp-%{embed_version}.so
%files pgsql -f files.pgsql
%files odbc -f files.odbc
@@ -2129,7 +2099,6 @@ fi
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
-%files xmlrpc -f files.xmlrpc
%files mbstring -f files.mbstring
%license libmbfl_LICENSE
%files gd -f files.gd
@@ -2160,13 +2129,24 @@ fi
%if %{with_zip}
%files zip -f files.zip
%endif
-%files json -f files.json
%files sodium -f files.sodium
%files ffi -f files.ffi
%dir %{_datadir}/php/preload
%changelog
+* Fri Sep 11 2020 Remi Collet <remi@remirepo.net> - 8.0.0~beta3-1
+- update to 8.0.0beta3
+- bump ABI/API versions
+- drop xmlrpc extension
+- json is now build statically
+- use system nikic/php-parser if available to generate
+ C headers from PHP stub
+- switch from "runselftest" option to bcond_without tests
+- enchant: use libenchant-2 instead of libenchant
+- rename 15-php.conf to 20-php.conf to ensure load order
+- oci8 version is now 3.0.0
+
* Tue Sep 1 2020 Remi Collet <remi@remirepo.net> - 7.4.10-1
- Update to 7.4.10 - http://www.php.net/releases/7_4_10.php