summaryrefslogtreecommitdiffstats
path: root/php80.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php80.spec')
-rw-r--r--php80.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php80.spec b/php80.spec
index 1bb8dec..03821cb 100644
--- a/php80.spec
+++ b/php80.spec
@@ -85,8 +85,8 @@
%bcond_without libgd
%bcond_with zip
-%global upver 8.0.11
-#global rcver RC1
+%global upver 8.0.12
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -998,9 +998,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 65
-BuildRequires: pkgconfig(icu-io) >= 65
-BuildRequires: pkgconfig(icu-uc) >= 65
+BuildRequires: pkgconfig(icu-i18n) >= 69
+BuildRequires: pkgconfig(icu-io) >= 69
+BuildRequires: pkgconfig(icu-uc) >= 69
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1786,9 +1786,9 @@ install -D -m 644 %{SOURCE14} _fpmdoc/nginx-php.conf
TESTCMD="$RPM_BUILD_ROOT%{_bindir}/php --no-php-ini"
# Ensure all provided extensions are really there
-for mod in core date filter hash libxml openssl pcntl pcre readline reflection session spl standard zlib
+for mod in core date filter hash json libxml openssl pcntl pcre readline reflection session spl standard zlib
do
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
@@ -1833,7 +1833,7 @@ do
ini=20-${mod}.ini;;
esac
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
# some extensions have their own config file
if [ -f ${ini} ]; then
@@ -2151,6 +2151,10 @@ fi
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-1
+- update to 8.0.12RC1
+- use libicu version 69
+
* Wed Sep 22 2021 Remi Collet <remi@remirepo.net> - 8.0.11-1
- Update to 8.0.11 - http://www.php.net/releases/8_0_11.php