summaryrefslogtreecommitdiffstats
path: root/php74.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php74.spec')
-rw-r--r--php74.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php74.spec b/php74.spec
index 01a7c1c..7ab8e11 100644
--- a/php74.spec
+++ b/php74.spec
@@ -90,8 +90,8 @@
%global with_libzip 1
%global with_zip 0
-%global upver 7.4.24
-#global rcver RC1
+%global upver 7.4.25
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -997,9 +997,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 65
-BuildRequires: pkgconfig(icu-io) >= 65
-BuildRequires: pkgconfig(icu-uc) >= 65
+BuildRequires: pkgconfig(icu-i18n) >= 69
+BuildRequires: pkgconfig(icu-io) >= 69
+BuildRequires: pkgconfig(icu-uc) >= 69
%if 0%{?rhel}
Obsoletes: php53-intl, php53u-intl, php54-intl, php54w-intl, php55u-intl, php55w-intl, php56u-intl, php56w-intl
Obsoletes: php70u-intl, php70w-intl, php71u-intl, php71w-intl, php72u-intl, php72w-intl
@@ -1794,7 +1794,7 @@ TESTCMD="$RPM_BUILD_ROOT%{_bindir}/php --no-php-ini"
# Ensure all provided extensions are really there
for mod in core date filter hash libxml openssl pcntl pcre readline reflection session spl standard zlib
do
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
@@ -1839,7 +1839,7 @@ do
ini=20-${mod}.ini;;
esac
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
# some extensions have their own config file
if [ -f ${ini} ]; then
@@ -2162,6 +2162,10 @@ fi
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 7.4.25~RC1-1
+- update to 7.4.24RC1
+- use libicu version 69
+
* Tue Sep 21 2021 Remi Collet <remi@remirepo.net> - 7.4.24-1
- Update to 7.4.24 - http://www.php.net/releases/7_4_24.php