summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php73.spec44
1 files changed, 33 insertions, 11 deletions
diff --git a/php73.spec b/php73.spec
index f1af427..d5bb23a 100644
--- a/php73.spec
+++ b/php73.spec
@@ -58,6 +58,13 @@
%global with_sqlite3 1
+# until firebird available in EPEL
+%if 0%{?rhel} == 8
+%global with_firebird 0
+%else
+%global with_firebird 1
+%endif
+
# Build ZTS extension or only NTS
%global with_zts 1
@@ -88,13 +95,13 @@
%global with_systemd 0
%endif
# httpd 2.4.10 with httpd-filesystem and sethandler support
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_httpd2410 1
%else
%global with_httpd2410 0
%endif
# nginx 1.6 with nginx-filesystem
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_nginx 1
%else
%global with_nginx 0
@@ -118,7 +125,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -246,7 +253,7 @@ Requires(pre): httpd
%endif
# php engine for Apache httpd webserver
Provides: php(httpd)
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# httpd have threaded MPM by default
Recommends: php-fpm%{?_isa} = %{version}-%{release}
%endif
@@ -653,6 +660,7 @@ Obsoletes: php73u-soap, php73w-soap
The php-soap package contains a dynamic shared object that will add
support to PHP for using the SOAP web services protocol.
+%if %{with_firebird}
%package interbase
Summary: A module for PHP applications that use Interbase/Firebird databases
Group: Development/Languages
@@ -681,6 +689,7 @@ technical advisors and supporters developing and enhancing a multi-platform
relational database management system based on the source code released by
Inprise Corp (now known as Borland Software Corp) under the InterBase Public
License.
+%endif
%if %{with_oci8}
%package oci8
@@ -1415,8 +1424,10 @@ build --libdir=%{_libdir}/php \
--with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
%endif
%endif
+%if %{with_firebird}
--with-interbase=shared \
--with-pdo-firebird=shared \
+%endif
--enable-dom=shared \
--with-pgsql=shared \
--enable-simplexml=shared \
@@ -1568,8 +1579,10 @@ build --includedir=%{_includedir}/php-zts \
--with-pdo-oci=shared,instantclient,%{_libdir}/oracle/%{oraclever}/client/lib,%{oraclever} \
%endif
%endif
+%if %{with_firebird}
--with-interbase=shared \
--with-pdo-firebird=shared \
+%endif
--enable-dom=shared \
--with-pgsql=shared \
--enable-simplexml=shared \
@@ -1725,7 +1738,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/opcache
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/peclxml
install -m 755 -d $RPM_BUILD_ROOT%{_docdir}/pecl
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/tests/pecl
@@ -1749,7 +1762,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/php-fpm
# Environment file
-%if 0%{?fedora} < 26
+%if 0%{?fedora} < 26 && 0%{?rhel} < 8
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
%endif
@@ -1760,7 +1773,7 @@ install -m 755 -d $RPM_BUILD_ROOT/run/php-fpm
# this folder requires systemd >= 204
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/php-fpm.service.d
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/php-fpm.conf
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/php-fpm.conf
%endif
@@ -1774,7 +1787,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_initrddir}
install -m 755 %{SOURCE99} $RPM_BUILD_ROOT%{_initrddir}/php-fpm
%endif
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/php-fpm.service
%endif
@@ -1809,7 +1822,9 @@ for mod in pgsql odbc ldap snmp xmlrpc imap json \
%if %{with_oci8}
oci8 pdo_oci \
%endif
+%if %{with_firebird}
interbase pdo_firebird \
+%endif
%if %{with_sqlite3}
sqlite3 \
%endif
@@ -1870,7 +1885,9 @@ cat files.pdo_odbc >> files.odbc
%if %{with_oci8}
cat files.pdo_oci >> files.oci8
%endif
+%if %{with_firebird}
cat files.pdo_firebird >> files.interbase
+%endif
# sysv* and posix in packaged in php-process
cat files.shmop files.sysv* files.posix > files.process
@@ -1903,7 +1920,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "/zts/d" \
%endif
< %{SOURCE3} > macros.php
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
echo '%pecl_xmldir %{_localstatedir}/lib/php/peclxml' >>macros.php
%endif
install -m 644 -D macros.php \
@@ -2078,7 +2095,7 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_sysconfdir}/logrotate.d/php-fpm
-%if 0%{?fedora} < 26
+%if 0%{?fedora} < 26 && 0%{?rhel} < 8
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
%endif
%if %{with_nginx}
@@ -2087,7 +2104,7 @@ fi
%endif
%if %{with_systemd}
%{_unitdir}/php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
@@ -2156,7 +2173,9 @@ fi
%files intl -f files.intl
%files process -f files.process
%files recode -f files.recode
+%if %{with_firebird}
%files interbase -f files.interbase
+%endif
%files enchant -f files.enchant
%files mysqlnd -f files.mysqlnd
%files opcache -f files.opcache
@@ -2173,6 +2192,9 @@ fi
%changelog
+* Fri Nov 30 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc6-2
+- EL-8 build
+
* Tue Nov 20 2018 Remi Collet <remi@remirepo.net> - 7.3.0~rc6-1
- update to 7.3.0RC6