summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-19 20:30:14 +0100
committerRemi Collet <remi@remirepo.net>2019-03-19 20:30:14 +0100
commit8aa6e05d530a4384c28940a5b560b2d65f17f2ac (patch)
tree2fc919a62fd39ba45a8779bb876642750b9bda43
parent9055369c12c9c571db369cc8ffa344043b11fdf2 (diff)
v7.3.4RC1
-rw-r--r--failed.txt17
-rw-r--r--php-openssl111.patch29
-rw-r--r--php.ini22
-rw-r--r--php73.spec11
4 files changed, 33 insertions, 46 deletions
diff --git a/failed.txt b/failed.txt
index 4190b86..185af77 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.3.3 (2019-03-07)
+===== 7.3.4RC1 (2019-03-21)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -6,19 +6,20 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el6x/build.log:Tests failed : 0
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/el8x73/build.log:Tests failed : 13
-/var/lib/mock/fc27i/build.log:Tests failed : 0
+/var/lib/mock/fc27i/build.log:Tests failed : 2
/var/lib/mock/fc27x/build.log:Tests failed : 0
-/var/lib/mock/fc28i/build.log:Tests failed : 0
+/var/lib/mock/fc28i/build.log:Tests failed : 2
/var/lib/mock/fc28x/build.log:Tests failed : 0
-/var/lib/mock/fc29i/build.log:Tests failed : 0
+/var/lib/mock/fc29i/build.log:Tests failed : 2
/var/lib/mock/fc29x/build.log:Tests failed : 0
-/var/lib/mock/fc30i/build.log:Tests failed : 0
+/var/lib/mock/fc30i/build.log:Tests failed : 1
/var/lib/mock/fc30x/build.log:Tests failed : 0
-el6i
- 1 Bug #60120 proc_open hangs with stdin/out with 2048+ bytes [ext/standard/tests/streams/proc_open_bug60120.phpt]
- 1 Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
+el6i, fc27i, fc28i, fc29i
+ 2 Test var_export() function with locale [ext/standard/tests/general_functions/var_export-locale.phpt]
+el6i, fc27i, fc28i, fc29i, fc30i
+ 2 Test var_export() function with integer values [ext/standard/tests/general_functions/var_export_basic1.phpt]
el8x:
5 buildroot issue with openssl under investigation
diff --git a/php-openssl111.patch b/php-openssl111.patch
deleted file mode 100644
index ea43711..0000000
--- a/php-openssl111.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 19a44ffb7be91344550fa700830b8e62a73031ba Mon Sep 17 00:00:00 2001
-From: Anatol Belski <ab@php.net>
-Date: Thu, 28 Feb 2019 12:48:47 +0100
-Subject: [PATCH] Sync with behavior change in OpenSSL 1.1.1b
-
-A behavior change in revealed by some openssl_decrypt() based test,
-where an encrypt API is used with a decrypt context. The EVP_Cipher*
-functions will automatically choose the right operation depending on the
-context passed.
----
- ext/openssl/openssl.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
-index 871a30c..7df5072 100644
---- a/ext/openssl/openssl.c
-+++ b/ext/openssl/openssl.c
-@@ -6494,7 +6494,7 @@ static int php_openssl_cipher_update(const EVP_CIPHER *cipher_type,
- {
- int i = 0;
-
-- if (mode->is_single_run_aead && !EVP_EncryptUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
-+ if (mode->is_single_run_aead && !EVP_CipherUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
- php_openssl_store_errors();
- php_error_docref(NULL, E_WARNING, "Setting of data length failed");
- return FAILURE;
---
-2.1.4
-
diff --git a/php.ini b/php.ini
index 3c6e49b..d52aeaa 100644
--- a/php.ini
+++ b/php.ini
@@ -305,6 +305,7 @@ serialize_precision = -1
; open_basedir, if set, limits all file operations to the defined directory
; and below. This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file.
+; Note: disables the realpath cache
; http://php.net/open-basedir
;open_basedir =
@@ -337,6 +338,7 @@ disable_classes =
; Determines the size of the realpath cache to be used by PHP. This value should
; be increased on systems where PHP opens many files to reflect the quantity of
; the file operations performed.
+; Note: if open_basedir is set, the cache is disabled
; http://php.net/realpath-cache-size
;realpath_cache_size = 4096k
@@ -589,7 +591,7 @@ html_errors = On
; to syslog. Only used when error_log is set to syslog.
;syslog.ident = php
-; The syslog facility is used to specify what type of program is logging
+; The syslog facility is used to specify what type of program is logging
; the message. Only used when error_log is set to syslog.
;syslog.facility = user
@@ -598,9 +600,10 @@ html_errors = On
; control characters. If your logger accepts everything, then no filtering
; is needed at all.
; Allowed values are:
-; ascii (only base ASCII characters)
-; no_ctrl (all characters except control characters)
+; ascii (all printable ASCII characters and NL)
+; no-ctrl (all characters except control characters)
; all (all characters)
+; http://php.net/syslog.filter
;syslog.filter = ascii
;windows.show_crt_warning
@@ -889,7 +892,7 @@ default_socket_timeout = 60
; For example:
;
; extension=mysqli
-;
+;
; When the extension library to load is not located in the default extension
; directory, You may specify an absolute path to the library file:
;
@@ -971,8 +974,19 @@ cli_server.color = On
;intl.use_exceptions = 0
[sqlite3]
+; Directory pointing to SQLite3 extensions
+; http://php.net/sqlite3.extension-dir
;sqlite3.extension_dir =
+; SQLite defensive mode flag (only available from SQLite 3.26+)
+; When the defensive flag is enabled, language features that allow ordinary
+; SQL to deliberately corrupt the database file are disabled. This forbids
+; writing directly to the schema, shadow tables (eg. FTS data tables), or
+; the sqlite_dbpage virtual table.
+; https://www.sqlite.org/c3ref/c_dbconfig_defensive.html
+; (for older SQLite versions, this flag has no use)
+;sqlite3.defensive = 1
+
[Pcre]
; PCRE library backtracking limit.
; http://php.net/pcre.backtrack-limit
diff --git a/php73.spec b/php73.spec
index f7f9abc..61cffc6 100644
--- a/php73.spec
+++ b/php73.spec
@@ -118,9 +118,9 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.3
-#global rcver RC1
-#global lower RC1
+%global upver 7.3.4
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -183,7 +183,6 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-openssl111.patch
# Security fixes (200+)
@@ -1138,7 +1137,6 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -2210,6 +2208,9 @@ fi
%changelog
+* Tue Mar 19 2019 Remi Collet <remi@remirepo.net> - 7.3.4~RC1-1
+- update to 7.3.4RC1
+
* Tue Mar 5 2019 Remi Collet <remi@remirepo.net> - 7.3.3-1
- Update to 7.3.3 - http://www.php.net/releases/7_3_3.php
- add upstream patch for OpenSSL 1.1.1b