summaryrefslogtreecommitdiffstats
path: root/php72.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php72.spec')
-rw-r--r--php72.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/php72.spec b/php72.spec
index 465e607..48605cf 100644
--- a/php72.spec
+++ b/php72.spec
@@ -119,7 +119,7 @@
%endif
%global upver 7.2.14
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
@@ -1818,7 +1818,9 @@ for mod in pgsql odbc ldap snmp xmlrpc imap json \
# some extensions have their own config file
if [ -f ${ini} ]; then
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini}
+ %if %{with_zts}
cp -p ${ini} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/${ini}
+ %endif
else
cat > $RPM_BUILD_ROOT%{_sysconfdir}/php.d/${ini} <<EOF
; Enable ${mod} extension module
@@ -1878,9 +1880,11 @@ cat files.curl files.phar files.fileinfo \
# The default Zend OPcache blacklist file
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php.d/opcache-default.blacklist
+%if %{with_zts}
install -m 644 %{SOURCE51} $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/opcache-default.blacklist
sed -e '/blacklist_filename/s/php.d/php-zts.d/' \
-i $RPM_BUILD_ROOT%{_sysconfdir}/php-zts.d/10-opcache.ini
+%endif
# Install the macros file:
sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
@@ -1909,7 +1913,7 @@ rm -f README.{Zeus,QNX,CVS-RULES}
%pre common
-%if %{?fedora}%{!?fedora:99} < 25
+%if %{?fedora}%{!?fedora:99} < 28
echo -e "WARNING : Fedora %{fedora} is now EOL :"
echo -e "You should consider upgrading to a supported release.\n"
%endif
@@ -2164,6 +2168,9 @@ fi
%changelog
+* Tue Jan 8 2019 Remi Collet <remi@remirepo.net> - 7.2.14-1
+- Update to 7.2.14 - http://www.php.net/releases/7_2_14.php
+
* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 7.2.14~RC1-1
- update to 7.2.14RC1
- oci8 version is now 2.2.0