summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-13 08:55:49 +0200
committerRemi Collet <remi@remirepo.net>2017-09-13 08:55:49 +0200
commit57241c39b08bb51e92b3e32684ce6504ab83fc62 (patch)
tree9c7c872bff821ec19f976074dc878ebc7d654020
parent09ca307dce43d641c12b3335dd3df24b626cf7c0 (diff)
v7.2.0RC2
-rw-r--r--failed.txt29
-rw-r--r--php-timelib.patch30
-rw-r--r--php-upstream.patch30
-rw-r--r--php72.spec12
4 files changed, 24 insertions, 77 deletions
diff --git a/failed.txt b/failed.txt
index 65e084d..cd7f03d 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.0RC1 (2017-08-31)
+===== 7.1.0RC2 (2017-09-14)
$ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
@@ -7,23 +7,32 @@ $ grep -r 'Tests failed' /var/lib/mock/{fc,el}*/build.log
/var/lib/mock/el7x/build.log:Tests failed : 0
/var/lib/mock/fc25i/build.log:Tests failed : 2
/var/lib/mock/fc25x/build.log:Tests failed : 0
-/var/lib/mock/fc26i/build.log:Tests failed : 4
-/var/lib/mock/fc26x/build.log:Tests failed : 2
+/var/lib/mock/fc26i/build.log:Tests failed : 2
+/var/lib/mock/fc26x/build.log:Tests failed : 0
+/var/lib/mock/fc27i/build.log:Tests failed : 2
/var/lib/mock/fc27x/build.log:Tests failed : 0
-fc26i, fc26x
- proc_nice() basic behaviour [ext/standard/tests/general_functions/proc_nice_basic.phpt]
- Check cli_process_title support on Unix [sapi/cli/tests/cli_process_title_unix.phpt]
-el6i, fc25i, fc26i
- Test breaks on HANDLE_EXCEPTION [sapi/phpdbg/tests/exceptions_003.phpt]
- Stepping with exceptions must not be stuck at CATCH [sapi/phpdbg/tests/stepping_001.phpt]
+el6i, fc25i, fc26i, fc27i
+ 2 Test breaks on HANDLE_EXCEPTION [sapi/phpdbg/tests/exceptions_003.phpt]
+ 2 Stepping with exceptions must not be stuck at CATCH [sapi/phpdbg/tests/stepping_001.phpt]
1 proc_open give erratic test results :(
-2 test issue (fixed upstream)
+2 test issue
3 known issue
4 bugs related to tzdata
5 need investigation
+32-bit known failure, this is ok (need to be fixed upstream)
+
+TEST FAILURE: ../sapi/phpdbg/tests/stepping_001.diff --
+012+ [L9 0xf6a7a070 CATCH<-112> "Exception" $e 1 /builddir/build/BUILD/php-7.2.0RC2/sapi/phpdbg/tests/stepping_001.php]
+012- [L9 %s CATCH<-128> "Exception" $e 1 %s]
+-- ../sapi/phpdbg/tests/stepping_001.diff result ends.
+TEST FAILURE: ../sapi/phpdbg/tests/exceptions_003.diff --
+017+ [L9 0xf6a7b0c4 CATCH<-196> "Error" $e 1 /builddir/build/BUILD/php-7.2.0RC2/sapi/phpdbg/tests/exceptions_003.php]
+017- [L9 %s CATCH<-224> "Error" $e 1 %s]
+-- ../sapi/phpdbg/tests/exceptions_003.diff result ends.
+
diff --git a/php-timelib.patch b/php-timelib.patch
deleted file mode 100644
index dd8d8cf..0000000
--- a/php-timelib.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/timelib_private.h b/timelib_private.h
-index cd402e0..efc7c80 100644
---- a/ext/date/lib/timelib_private.h
-+++ b/ext/date/lib/timelib_private.h
-@@ -115,7 +115,7 @@
- m = NULL; \
- }
-
--typedef struct ttinfo
-+struct ttinfo
- {
- int32_t offset;
- int isdst;
-@@ -123,13 +123,13 @@ typedef struct ttinfo
-
- unsigned int isstdcnt;
- unsigned int isgmtcnt;
--} ttinfo;
-+};
-
--typedef struct tlinfo
-+struct tlinfo
- {
- int32_t trans;
- int32_t offset;
--} tlinfo;
-+};
-
-
- #ifndef LONG_MAX
diff --git a/php-upstream.patch b/php-upstream.patch
deleted file mode 100644
index 448fd7c..0000000
--- a/php-upstream.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Thu, 31 Aug 2017 07:55:45 +0200
-Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
- conditon)
-
----
- ext/sqlite3/config0.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
-index 0e5fbc5..78fd622 100644
---- a/ext/sqlite3/config0.m4
-+++ b/ext/sqlite3/config0.m4
-@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
- other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
- fi
-
-+ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
- PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
- PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
- fi
-
-- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
- AC_DEFINE(HAVE_SQLITE3,1,[ ])
-
- sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
---
-2.1.4
-
diff --git a/php72.spec b/php72.spec
index c53988c..4268cf9 100644
--- a/php72.spec
+++ b/php72.spec
@@ -113,12 +113,12 @@
%endif
%global upver 7.2.0
-%global rcver RC1
+%global rcver RC2
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -155,8 +155,6 @@ Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.1.0-libdb.patch
Patch9: php-7.0.7-curl.patch
-# From https://github.com/derickr/timelib/pull/21
-Patch10: php-timelib.patch
# Functional changes
Patch40: php-7.1.3-dlopen.patch
@@ -174,7 +172,6 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1057,7 +1054,6 @@ low-level PHP extension for the libsodium cryptographic library.
%if 0%{?rhel}
%patch9 -p1 -b .curltls
%endif
-%patch10 -p1 -b .timelib
%patch40 -p1 -b .dlopen
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
@@ -1073,7 +1069,6 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -2116,6 +2111,9 @@ fi
%changelog
+* Wed Sep 13 2017 Remi Collet <remi@remirepo.net> - 7.2.0~RC2-1
+- update to 7.2.0RC2
+
* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.2.0~RC1-2
- add patch for EL-6, fix undefined symbol: sqlite3_errstr