summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-13 10:26:25 +0100
committerRemi Collet <remi@remirepo.net>2017-11-13 10:26:25 +0100
commit0c93631728698c1a9f7af4a2c8eccc82548237b5 (patch)
tree266a668d5af97007b44196b23bc2a29431219d4c
parent4c3ff42a1a3ef85b07dc23d0d4e804668dac3694 (diff)
add patch for https://bugs.php.net/75514
-rw-r--r--0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch55
-rw-r--r--php72.spec2
2 files changed, 57 insertions, 0 deletions
diff --git a/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
new file mode 100644
index 0000000..23743fe
--- /dev/null
+++ b/0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
@@ -0,0 +1,55 @@
+From 00500c425ba895f1b3591ace3ccd5ee125307559 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 13 Nov 2017 09:55:10 +0100
+Subject: [PATCH] Fixed bug #75514 mt_rand returns value outside [$min,$max]+
+ on 32-bit
+
+---
+ ext/standard/mt_rand.c | 4 ++--
+ ext/standard/tests/math/bug75514.phpt | 12 ++++++++++++
+ 2 files changed, 14 insertions(+), 2 deletions(-)
+ create mode 100644 ext/standard/tests/math/bug75514.phpt
+
+diff --git a/ext/standard/mt_rand.c b/ext/standard/mt_rand.c
+index 2335a92..6669cbc 100644
+--- a/ext/standard/mt_rand.c
++++ b/ext/standard/mt_rand.c
+@@ -294,7 +294,7 @@ PHPAPI zend_long php_mt_rand_range(zend_long min, zend_long max)
+ * rand() allows min > max, mt_rand does not */
+ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+ {
+- zend_long n;
++ uint32_t n;
+
+ if (BG(mt_rand_mode) == MT_RAND_MT19937) {
+ return php_mt_rand_range(min, max);
+@@ -302,7 +302,7 @@ PHPAPI zend_long php_mt_rand_common(zend_long min, zend_long max)
+
+ /* Legacy mode deliberately not inside php_mt_rand_range()
+ * to prevent other functions being affected */
+- n = (zend_long)php_mt_rand() >> 1;
++ n = php_mt_rand() >> 1;
+ RAND_RANGE_BADSCALING(n, min, max, PHP_MT_RAND_MAX);
+
+ return n;
+diff --git a/ext/standard/tests/math/bug75514.phpt b/ext/standard/tests/math/bug75514.phpt
+new file mode 100644
+index 0000000..af97b6d
+--- /dev/null
++++ b/ext/standard/tests/math/bug75514.phpt
+@@ -0,0 +1,12 @@
++--TEST--
++Bug #75514 mt_rand returns value outside [$min,$max]
++--FILE--
++<?php
++mt_srand(0, MT_RAND_PHP);
++var_dump(mt_rand(0,999999999), mt_rand(0,999));
++?>
++===Done===
++--EXPECT--
++int(448865905)
++int(592)
++===Done===
+--
+2.9.5
+
diff --git a/php72.spec b/php72.spec
index 7323eaa..66e2cb7 100644
--- a/php72.spec
+++ b/php72.spec
@@ -182,6 +182,7 @@ Patch300: php-7.0.10-datetests.patch
Patch301: php-7.0.0-oldpcre.patch
# WIP
+Patch400: 0001-Fixed-bug-75514-mt_rand-returns-value-outside-min-ma.patch
BuildRequires: bzip2-devel, curl-devel >= 7.9
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
@@ -1088,6 +1089,7 @@ fi
%endif
# WIP patch
+%patch400 -p1 -bug75514
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE