summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-31 08:40:23 +0200
committerRemi Collet <remi@remirepo.net>2017-08-31 08:40:23 +0200
commit09ca307dce43d641c12b3335dd3df24b626cf7c0 (patch)
treeea754706bd120f27d48fdcdc6adf662f2d000340
parent5b09c0083df77ba98cf9ec80bf96ae6d92906db0 (diff)
add patch for EL-6, fix undefined symbol: sqlite3_errstr
-rw-r--r--php-upstream.patch30
-rw-r--r--php72.spec7
2 files changed, 36 insertions, 1 deletions
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..448fd7c
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,30 @@
+From 3239f6d6798d86fdbf8e03aa741d9990bcfffe79 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 31 Aug 2017 07:55:45 +0200
+Subject: [PATCH] move AC_DEFINE in the right position (in bundled lib
+ conditon)
+
+---
+ ext/sqlite3/config0.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
+index 0e5fbc5..78fd622 100644
+--- a/ext/sqlite3/config0.m4
++++ b/ext/sqlite3/config0.m4
+@@ -85,11 +85,11 @@ if test $PHP_SQLITE3 != "no"; then
+ other_flags="$other_flags -DSQLITE_ENABLE_ICU=1"
+ fi
+
++ AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ PHP_SQLITE3_CFLAGS="-I@ext_srcdir@/libsqlite $other_flags $threadsafe_flags $debug_flags"
+ PHP_INSTALL_HEADERS([ext/sqlite3/libsqlite/sqlite3.h])
+ fi
+
+- AC_DEFINE(HAVE_SQLITE3_ERRSTR, 1, [have sqlite3_errstr function])
+ AC_DEFINE(HAVE_SQLITE3,1,[ ])
+
+ sqlite3_sources="sqlite3.c $sqlite3_extra_sources"
+--
+2.1.4
+
diff --git a/php72.spec b/php72.spec
index 50926bb..c53988c 100644
--- a/php72.spec
+++ b/php72.spec
@@ -118,7 +118,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -174,6 +174,7 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -1072,6 +1073,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1 -b .up
# security patches
@@ -2114,6 +2116,9 @@ fi
%changelog
+* Thu Aug 31 2017 Remi Collet <remi@fedoraproject.org> - 7.2.0~RC1-2
+- add patch for EL-6, fix undefined symbol: sqlite3_errstr
+
* Wed Aug 30 2017 Remi Collet <remi@fedoraproject.org> - 7.2.0~RC1-1
- update to 7.2.0RC1