summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-23 13:31:02 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-23 13:31:02 +0200
commitd4f9012f851983a4f0caff03f0365951f86acf71 (patch)
tree236fd54ad78a73b63a0b97358e250f9cb92e2d42 /Makefile
php 7.0.0beta2 (as bas package, new)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..7aca750
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
+
+debug:
+ time rpmbuild $(RPMDEFINES) --with debug -bb $(NAME).spec
+