summaryrefslogtreecommitdiffstats
path: root/php56.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-03-15 15:32:33 +0100
committerRemi Collet <remi@remirepo.net>2019-03-15 15:32:33 +0100
commitd07b0a64c3ea35ee0043e148520c25786371967f (patch)
treeae8a57de79a6858307c2f397026de740b76c017b /php56.spec
parentfc946c95ef924e4ca53009ca51c869d1f08ff1cf (diff)
Fix #76846 Segfault in shutdown function after memory limit error
Diffstat (limited to 'php56.spec')
-rw-r--r--php56.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/php56.spec b/php56.spec
index b1f329c..ab08e0e 100644
--- a/php56.spec
+++ b/php56.spec
@@ -142,7 +142,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.6.40
-Release: 5%{?dist}
+Release: 6%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -201,6 +201,7 @@ Patch91: php-5.6.3-oci8conf.patch
# Upstream fixes (100+)
Patch100: php-5.6.31-oci.patch
+Patch103: php-bug76846.patch
# Security fixes (200+)
# See https://github.com/Microsoft/php-src/commits/PHP-5.6-security-backports
@@ -955,7 +956,7 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzi
%patch40 -p1 -b .dlopen
%patch41 -p1 -b .dtrace
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -969,6 +970,7 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} libzip=%{with_libzi
# upstream patches
%patch100 -p1 -b .pdo_oci
+%patch103 -p1 -b .bug76846
# security patches
%patch208 -p1 -b .bug77396
@@ -1019,6 +1021,12 @@ mkdir build-cgi build-apache build-embedded \
rm ext/date/tests/timezone_location_get.phpt
rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
+rm ext/date/tests/bug33414-1.phpt
+rm ext/date/tests/bug33414-2.phpt
+rm ext/date/tests/bug33415-2.phpt
+rm ext/date/tests/date_modify-1.phpt
+rm ext/date/tests/bug51819.phpt
+rm ext/date/tests/date_sunset_variation9.phpt
# Should be skipped but fails sometime
rm ext/standard/tests/file/file_get_contents_error001.phpt
# fails sometime
@@ -1182,7 +1190,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml-dir=%{_prefix} \
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 5
--with-system-tzdata \
%endif
--with-mhash \
@@ -2008,6 +2016,9 @@ EOF
%changelog
+* Fri Mar 15 2019 Remi Collet <remi@remirepo.net> - 5.6.40-6
+- Fix #76846 Segfault in shutdown function after memory limit error
+
* Tue Mar 12 2019 Remi Collet <remi@remirepo.net> - 5.6.40-5
- phar:
Fix #77396 Null Pointer Dereference in phar_create_or_parse_filename