summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-wip.patch28
-rw-r--r--php55.spec29
2 files changed, 39 insertions, 18 deletions
diff --git a/php-wip.patch b/php-wip.patch
index 8c0d2f7..bf2b723 100644
--- a/php-wip.patch
+++ b/php-wip.patch
@@ -1,11 +1,17 @@
---- ext/date/php_date.c.orig 2012-12-01 09:54:45.834231459 +0100
-+++ ext/date/php_date.c 2012-12-01 09:54:51.594252063 +0100
-@@ -1027,7 +1027,7 @@
- case 'H': length = slprintf(buffer, 32, "%02d", (int) t->h); break;
- case 'i': length = slprintf(buffer, 32, "%02d", (int) t->i); break;
- case 's': length = slprintf(buffer, 32, "%02d", (int) t->s); break;
-- case 'u': length = slprintf(buffer, 32, "%06d", (int) floor(t->f * 1000000)); break;
-+ case 'u': length = slprintf(buffer, 32, "%06d", (int) floor(t->f * 1000000 + 0.5)); break;
-
- /* timezone */
- case 'I': length = slprintf(buffer, 32, "%d", localtime ? offset->is_dst : 0); break;
+--- acinclude.m4.old 2012-12-10 12:30:11.684122918 +0100
++++ acinclude.m4 2012-12-10 12:31:49.933474452 +0100
+@@ -2963,12 +2963,12 @@
+ cat>>Makefile.objects<<EOF
+
+ $ac_bdir[$]ac_hdrobj: $abs_srcdir/$ac_provsrc
+- dtrace -h -C -s $ac_srcdir[$]ac_provsrc -o \$[]@ && \$(SED) -ibak 's,PHP_,DTRACE_,g' \$[]@
++ CFLAGS="$(CFLAGS_CLEAN)" dtrace -h -C -s $ac_srcdir[$]ac_provsrc -o \$[]@ && \$(SED) -ibak 's,PHP_,DTRACE_,g' \$[]@
+
+ \$(PHP_DTRACE_OBJS): $ac_bdir[$]ac_hdrobj
+
+ $ac_bdir[$]ac_provsrc.o: \$(PHP_DTRACE_OBJS)
+- dtrace -G -o \$[]@ -s $abs_srcdir/$ac_provsrc $dtrace_objs
++ CFLAGS="$(CFLAGS_CLEAN)" dtrace -G -o \$[]@ -s $abs_srcdir/$ac_provsrc $dtrace_objs
+
+ EOF
+ ])
diff --git a/php55.spec b/php55.spec
index f57f451..6a0bf1a 100644
--- a/php55.spec
+++ b/php55.spec
@@ -1,6 +1,6 @@
# API/ABI check
%global apiver 20121113
-%global zendver 20121128
+%global zendver 20121204
%global pdover 20080721
# Extension version
%global oci8ver 1.4.9
@@ -42,6 +42,11 @@
%{!?_httpd_moddir: %{expand: %%global _httpd_moddir %%{_libdir}/httpd/modules}}
%{!?_httpd_contentdir: %{expand: %%global _httpd_contentdir /var/www}}
+%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
+%global with_dtrace 1
+%else
+%global with_dtrace 0
+%endif
%if 0%{?fedora} < 17 && 0%{?rhel} < 7
%global with_libzip 0
%else
@@ -56,14 +61,14 @@
%global db_devel libdb-devel
%endif
-%global snapdate 201211301534
+%global snapdate 201212100830
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.5.0
%if 0%{?snapdate:1}%{?rcver:1}
-Release: 0.4.%{?snapdate}%{?rcver}%{?dist}
+Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
Release: 2%{?dist}
%endif
@@ -116,7 +121,8 @@ Patch45: php-5.4.8-ldap_r.patch
# RC Patch
Patch91: php-5.3.7-oci8conf.patch
-# WIP https://bugs.php.net/63435
+# WIP dtrace patch
+# https://bugs.php.net/bug.php?id=63706
Patch99: php-wip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -139,6 +145,9 @@ BuildRequires: libtool-ltdl-devel
%if %{with_libzip}
BuildRequires: libzip-devel >= 0.10
%endif
+%if %{with_dtrace}
+BuildRequires: systemtap-sdt-devel
+%endif
%if 0%{?snapdate}
BuildRequires: bison
%endif
@@ -735,8 +744,7 @@ echo CIBLE = %{name}-%{version}-%{release} oci8=%{with_oci8} fpm=%{with_fpm} lib
httpd -V | grep -q 'threaded:.*yes' && exit 1
%if 0%{?snapdate}
-#setup -q -n php5.4-%{snapdate}
-%setup -q -n php-src
+%setup -q -n php5.5-%{snapdate}
%else
%setup -q -n php-%{version}%{?rcver}
%endif
@@ -919,7 +927,10 @@ ln -sf ../configure
--with-system-tzdata \
%endif
--with-mhash \
- $*
+%if %{with_dtrace}
+ --enable-dtrace \
+%endif
+ $*
if test $? != 0; then
tail -500 config.log
: configure failed
@@ -1605,6 +1616,10 @@ fi
%changelog
+* Mon Dec 10 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.5.201212100830
+- new snapshot
+- enable dtrace
+
* Tue Dec 4 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.4.201211301534
- build simplexml and xml extensions shared (in php-xml)
- build bz2, calendar, ctype, exif, ftp, gettext and iconv