summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php55.spec13
1 files changed, 7 insertions, 6 deletions
diff --git a/php55.spec b/php55.spec
index 929bb97..31d5ff1 100644
--- a/php55.spec
+++ b/php55.spec
@@ -896,7 +896,6 @@ ln -sf ../configure
--with-pic \
--disable-rpath \
--without-pear \
- --with-bz2 \
--with-exec-dir=%{_bindir} \
--with-freetype-dir=%{_prefix} \
--with-png-dir=%{_prefix} \
@@ -944,6 +943,7 @@ build --enable-force-cgi-redirect \
--with-gmp=shared \
--enable-calendar=shared \
--enable-bcmath=shared \
+ --with-bz2=shared \
--enable-dba=shared --with-db4=%{_prefix} \
--enable-exif=shared \
--enable-ftp=shared \
@@ -1016,7 +1016,7 @@ without_shared="--without-gd \
--disable-json --without-pspell --disable-wddx \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
- --without-iconv --disable-ftp \
+ --without-iconv --disable-ftp --without-bz2 \
--disable-sysvmsg --disable-sysvshm --disable-sysvsem"
# Build Apache module, and the CLI SAPI, /usr/bin/php
@@ -1066,6 +1066,7 @@ build --enable-force-cgi-redirect \
--with-gmp=shared \
--enable-calendar=shared \
--enable-bcmath=shared \
+ --with-bz2=shared \
--enable-dba=shared --with-db4=%{_prefix} \
--with-gettext=shared \
--with-iconv=shared \
@@ -1295,7 +1296,7 @@ install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
for mod in pgsql mysql mysqli odbc ldap snmp xmlrpc imap \
mysqlnd mysqlnd_mysql mysqlnd_mysqli pdo_mysqlnd \
mbstring gd dom xsl soap bcmath dba xmlreader xmlwriter \
- simplexml calendar exif ftp gettext gmp iconv \
+ simplexml bz2 calendar exif ftp gettext gmp iconv \
pdo pdo_mysql pdo_pgsql pdo_odbc pdo_sqlite json %{zipmod} \
%{?_with_oci8:oci8} %{?_with_oci8:pdo_oci} interbase pdo_firebird \
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
@@ -1363,7 +1364,7 @@ cat files.sqlite3 >> files.pdo
# Package json, zip, curl, phar and fileinfo in -common.
cat files.json files.curl files.phar files.fileinfo \
files.exif files.gettext files.iconv files.calendar \
- files.ftp > files.common
+ files.ftp files.bz2 > files.common
%if %{with_zip}
cat files.zip >> files.common
%endif
@@ -1602,8 +1603,8 @@ fi
%changelog
* Tue Dec 4 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.4.201211301534
- build simplexml and xml extensions shared (in php-xml)
-- build calendar, exif, ftp, gettext and iconv extensions shared
- (in php-common)
+- build bz2, calendar, exif, ftp, gettext and iconv
+ extensions shared (in php-common)
- build gmp extension shared (in php-bcmath)
* Mon Dec 3 2012 Remi Collet <remi@fedoraproject.org> 5.5.0-0.3.201211301534