summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-5.4.7-imap.patch11
-rw-r--r--php-5.4.7-sqlite.patch27
-rw-r--r--php-5.4.8-libxml.patch50
-rw-r--r--php-5.4.8-mysqli.patch11
-rw-r--r--php-5.4.9-json.patch76
-rw-r--r--php54.spec23
6 files changed, 6 insertions, 192 deletions
diff --git a/php-5.4.7-imap.patch b/php-5.4.7-imap.patch
deleted file mode 100644
index d37d05c..0000000
--- a/php-5.4.7-imap.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.4.7/ext/imap/php_imap.c.orig 2012-09-22 09:00:39.661043173 +0200
-+++ php-5.4.7/ext/imap/php_imap.c 2012-09-22 09:01:13.606053829 +0200
-@@ -1191,7 +1191,7 @@
- if (zend_hash_index_find(Z_ARRVAL_PP(disabled_auth_method), i, (void **) &z_auth_method) == SUCCESS) {
- if (Z_TYPE_PP(z_auth_method) == IS_STRING) {
- if (Z_STRLEN_PP(z_auth_method) > 1) {
-- mail_parameters (NIL, DISABLE_AUTHENTICATOR, (void *)Z_STRVAL_PP(disabled_auth_method));
-+ mail_parameters (NIL, DISABLE_AUTHENTICATOR, (void *)Z_STRVAL_PP(z_auth_method));
- }
- } else {
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "Invalid argument, expect string or array of strings");
diff --git a/php-5.4.7-sqlite.patch b/php-5.4.7-sqlite.patch
deleted file mode 100644
index 2c26b86..0000000
--- a/php-5.4.7-sqlite.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 05b9b50f09e10038230e1edab43b86afb67c14a8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 24 Sep 2012 13:53:59 +0200
-Subject: [PATCH] Fix Bug #63149, check sqlite3_column_table_name availability
- with system SQLite
-
----
- ext/sqlite3/config0.m4 | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/ext/sqlite3/config0.m4 b/ext/sqlite3/config0.m4
-index ac58b35..1365def 100644
---- a/ext/sqlite3/config0.m4
-+++ b/ext/sqlite3/config0.m4
-@@ -50,6 +50,9 @@ if test $PHP_SQLITE3 != "no"; then
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_key,[
- AC_DEFINE(HAVE_SQLITE3_KEY, 1, [have commercial sqlite3 with crypto support])
- ])
-+ PHP_CHECK_LIBRARY(sqlite3,sqlite3_column_table_name,[
-+ AC_DEFINE(SQLITE_ENABLE_COLUMN_METADATA, 1, [have sqlite3 with column metadata enabled])
-+ ])
-
- PHP_CHECK_LIBRARY(sqlite3,sqlite3_load_extension,
- [],
---
-1.7.10
-
diff --git a/php-5.4.8-libxml.patch b/php-5.4.8-libxml.patch
deleted file mode 100644
index d9e92e9..0000000
--- a/php-5.4.8-libxml.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 100bb87f5517484d75191ff4cdbbc1fdf579791d Mon Sep 17 00:00:00 2001
-From: jjacky <i.am.jack.mail@gmail.com>
-Date: Fri, 11 May 2012 22:38:05 +0200
-Subject: [PATCH] CGI/FPM process could crash when using libxml, fixes #61557
-
-Since d8bddb9665637d96f20dc4a2ae5668ba376f3b17 some SAPI would only setup/reset
-callbacks to libxml once, instead of for each request processed. However, this
-also included a callback for structured errors, which should remain per request
-(as it can be defined through PHP's libxml_use_internal_errors).
-
-As a result, after the internal handler was set in a request, processing another
-request would result in the handler being triggered while the memory associated
-with it (LIBXML(error_list)) had been free-d/reset, leading to the process
-segfaulting.
-
-This reset the handler for structured errors after each request.
-
-(see #61325 also possibly the same bug)
----
- ext/libxml/libxml.c | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/ext/libxml/libxml.c b/ext/libxml/libxml.c
-index e42d845..92c1099 100644
---- a/ext/libxml/libxml.c
-+++ b/ext/libxml/libxml.c
-@@ -851,7 +851,6 @@ static PHP_MSHUTDOWN_FUNCTION(libxml)
- {
- if (!_php_libxml_per_request_initialization) {
- xmlSetGenericErrorFunc(NULL, NULL);
-- xmlSetStructuredErrorFunc(NULL, NULL);
-
- xmlParserInputBufferCreateFilenameDefault(NULL);
- xmlOutputBufferCreateFilenameDefault(NULL);
-@@ -867,11 +866,11 @@ static int php_libxml_post_deactivate()
- /* reset libxml generic error handling */
- if (_php_libxml_per_request_initialization) {
- xmlSetGenericErrorFunc(NULL, NULL);
-- xmlSetStructuredErrorFunc(NULL, NULL);
-
- xmlParserInputBufferCreateFilenameDefault(NULL);
- xmlOutputBufferCreateFilenameDefault(NULL);
- }
-+ xmlSetStructuredErrorFunc(NULL, NULL);
-
- if (LIBXML(stream_context)) {
- /* the steam_context resource will be released by resource list destructor */
---
-1.7.10.1
-
diff --git a/php-5.4.8-mysqli.patch b/php-5.4.8-mysqli.patch
deleted file mode 100644
index b65189a..0000000
--- a/php-5.4.8-mysqli.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.4.8/ext/mysqli/config.m4.orig 2012-10-25 14:36:21.560016333 +0200
-+++ php-5.4.8/ext/mysqli/config.m4 2012-10-25 14:37:04.706164258 +0200
-@@ -81,5 +81,8 @@
- if test "$PHP_MYSQLI" = "yes" || test "$PHP_MYSQLI" = "mysqlnd"; then
- PHP_ADD_EXTENSION_DEP(mysqli, mysqlnd)
- AC_DEFINE([MYSQLI_USE_MYSQLND], 1, [Whether mysqlnd is enabled])
-+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_mysqlnd.h])
-+ else
-+ PHP_INSTALL_HEADERS([ext/mysqli/mysqli_libmysql.h])
- fi
- fi
diff --git a/php-5.4.9-json.patch b/php-5.4.9-json.patch
deleted file mode 100644
index 73db3a9..0000000
--- a/php-5.4.9-json.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-diff -up php-5.4.9/ext/json/config.m4.63588 php-5.4.9/ext/json/config.m4
---- php-5.4.9/ext/json/config.m4.63588 2012-11-23 14:48:42.934043358 +0100
-+++ php-5.4.9/ext/json/config.m4 2012-11-23 14:48:58.237102616 +0100
-@@ -9,7 +9,7 @@ if test "$PHP_JSON" != "no"; then
- AC_DEFINE([HAVE_JSON],1 ,[whether to enable JavaScript Object Serialization support])
- AC_HEADER_STDC
-
-- PHP_NEW_EXTENSION(json, json.c utf8_to_utf16.c utf8_decode.c JSON_parser.c, $ext_shared)
-+ PHP_NEW_EXTENSION(json, json.c utf8_decode.c JSON_parser.c, $ext_shared)
- PHP_INSTALL_HEADERS([ext/json], [php_json.h])
- PHP_SUBST(JSON_SHARED_LIBADD)
- fi
-diff -up php-5.4.9/ext/json/json.c.63588 php-5.4.9/ext/json/json.c
---- php-5.4.9/ext/json/json.c.63588 2012-11-23 14:48:28.038987099 +0100
-+++ php-5.4.9/ext/json/json.c 2012-11-23 14:51:37.780705594 +0100
-@@ -25,8 +25,8 @@
- #include "php.h"
- #include "php_ini.h"
- #include "ext/standard/info.h"
-+#include "ext/standard/html.h"
- #include "ext/standard/php_smart_str.h"
--#include "utf8_to_utf16.h"
- #include "JSON_parser.h"
- #include "php_json.h"
- #include <zend_exceptions.h>
-@@ -344,6 +344,32 @@ static void json_encode_array(smart_str
- }
- /* }}} */
-
-+static int json_utf8_to_utf16(unsigned short *utf16, char utf8[], int len) /* {{{ */
-+{
-+ size_t pos = 0, us;
-+ int j, status;
-+
-+ for (j=0 ; pos < len ; j++) {
-+ us = php_next_utf8_char((const unsigned char *)utf8, len, &pos, &status);
-+ if (status != SUCCESS) {
-+ return -1;
-+ }
-+ if (utf16) {
-+ /* From http://en.wikipedia.org/wiki/UTF16 */
-+ if (us >= 0x10000) {
-+ us -= 0x10000;
-+ utf16[j++] = (unsigned short)((us >> 10) | 0xd800);
-+ utf16[j] = (unsigned short)((us & 0x3ff) | 0xdc00);
-+ } else {
-+ utf16[j] = (unsigned short)us;
-+ }
-+ }
-+ }
-+ return j;
-+}
-+/* }}} */
-+
-+
- #define REVERSE16(us) (((us & 0xf) << 12) | (((us >> 4) & 0xf) << 8) | (((us >> 8) & 0xf) << 4) | ((us >> 12) & 0xf))
-
- static void json_escape_string(smart_str *buf, char *s, int len, int options TSRMLS_DC) /* {{{ */
-@@ -383,7 +409,7 @@ static void json_escape_string(smart_str
- }
-
- utf16 = (options & PHP_JSON_UNESCAPED_UNICODE) ? NULL : (unsigned short *) safe_emalloc(len, sizeof(unsigned short), 0);
-- ulen = utf8_to_utf16(utf16, s, len);
-+ ulen = json_utf8_to_utf16(utf16, s, len);
- if (ulen <= 0) {
- if (utf16) {
- efree(utf16);
-@@ -628,7 +654,7 @@ PHP_JSON_API void php_json_decode_ex(zva
-
- utf16 = (unsigned short *) safe_emalloc((str_len+1), sizeof(unsigned short), 1);
-
-- utf16_len = utf8_to_utf16(utf16, str, str_len);
-+ utf16_len = json_utf8_to_utf16(utf16, str, str_len);
- if (utf16_len <= 0) {
- if (utf16) {
- efree(utf16);
diff --git a/php54.spec b/php54.spec
index 9b7bd66..8e542f9 100644
--- a/php54.spec
+++ b/php54.spec
@@ -65,11 +65,11 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.4.9
+Version: 5.4.10
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 3%{?dist}
+Release: 1%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -99,20 +99,10 @@ Patch5: php-5.2.0-includedir.patch
Patch6: php-5.2.4-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-5.4.7-libdb.patch
-# https://bugs.php.net/63361 - Header not installed
-Patch9: php-5.4.8-mysqli.patch
-# See http://bugs.php.net/63588
-Patch10: php-5.4.9-json.patch
# Fixes for extension modules
-# https://bugs.php.net/63126 - DISABLE_AUTHENTICATOR ignores array
-Patch20: php-5.4.7-imap.patch
# https://bugs.php.net/63171 no odbc call during timeout
Patch21: php-5.4.7-odbctimer.patch
-# https://bugs.php.net/63149 check sqlite3_column_table_name
-Patch22: php-5.4.7-sqlite.patch
-# https://bugs.php.net/61557 crash in libxml
-Patch23: php-5.4.8-libxml.patch
# Functional changes
Patch40: php-5.4.0-dlopen.patch
@@ -764,14 +754,9 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch6 -p1 -b .embed
%patch7 -p1 -b .recode
%patch8 -p1 -b .libdb
-%patch9 -p1 -b .mysqliheaders
-%patch10 -p1 -b .63588
rm -f ext/json/utf8_to_utf16.*
-%patch20 -p1 -b .imap
%patch21 -p1 -b .odbctimer
-%patch22 -p1 -b .tablename
-%patch23 -p1 -b .libxmlcrash
%patch40 -p1 -b .dlopen
%patch41 -p1 -b .easter
@@ -1625,6 +1610,10 @@ fi
%changelog
+* Wed Dec 19 2012 Remi Collet <rcollet@redhat.com> 5.4.10-1
+- update to 5.4.10
+- remove patches merged upstream
+
* Tue Dec 11 2012 Remi Collet <rcollet@redhat.com> 5.4.9-3
- drop "Configure Command" from phpinfo output