summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION6
-rw-r--r--php-zstd.spec40
3 files changed, 18 insertions, 32 deletions
diff --git a/PHPINFO b/PHPINFO
index d38d953..af9bd71 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
zstd
Zstd support => enabled
-Extension Version => 0.11.0
-Interface Version => 1.5.0
+Extension Version => 0.12.0
+Interface Version => 1.5.2
APCu serializer ABI => 0
diff --git a/REFLECTION b/REFLECTION
index e130801..5b3c89c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #109 zstd version 0.11.0 ] {
+Extension [ <persistent> extension #109 zstd version 0.12.0 ] {
- Dependencies {
Dependency [ apcu (Optional) ]
@@ -8,8 +8,8 @@ Extension [ <persistent> extension #109 zstd version 0.11.0 ] {
Constant [ int ZSTD_COMPRESS_LEVEL_MIN ] { 1 }
Constant [ int ZSTD_COMPRESS_LEVEL_MAX ] { 22 }
Constant [ int ZSTD_COMPRESS_LEVEL_DEFAULT ] { 3 }
- Constant [ int LIBZSTD_VERSION_NUMBER ] { 10500 }
- Constant [ string LIBZSTD_VERSION_STRING ] { 1.5.0 }
+ Constant [ int LIBZSTD_VERSION_NUMBER ] { 10502 }
+ Constant [ string LIBZSTD_VERSION_STRING ] { 1.5.2 }
}
- Functions {
diff --git a/php-zstd.spec b/php-zstd.spec
index 2813fd1..2288ca3 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-zstd
#
-# Copyright (c) 2018-2021 Remi Collet
+# Copyright (c) 2018-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,15 +17,11 @@
%global pkg_name %{name}
%endif
-# To build with PHP 5.x use --without apcu
+%bcond_without tests
%bcond_without apcu
-
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 7
%bcond_without libzstd
-%else
-%bcond_with libzstd
-%endif
-%global zstdver 1.5.0
+
+%global zstdver 1.5.1
%global pecl_name zstd
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -34,7 +30,7 @@
Summary: Zstandard extension
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.11.0
+Version: 0.12.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with libzstd}
License: MIT
@@ -46,11 +42,9 @@ URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
%if %{with apcu}
-BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
-%else
-BuildRequires: %{?scl_prefix}php-devel
%endif
BuildRequires: %{?scl_prefix}php-pear
%if %{with libzstd}
@@ -69,21 +63,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
PHP extension for compression and decompression with Zstandard library.
@@ -217,10 +196,12 @@ cd NTS
--ri apcu | grep '%{pecl_name}'
%endif
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%{__php} -n run-tests.php -q --offline --show-diff
+%endif
%if %{with_zts}
cd ../ZTS
@@ -229,11 +210,13 @@ cd ../ZTS
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%{__ztsphp} -n run-tests.php -q --offline --show-diff
%endif
+%endif
%files
@@ -263,6 +246,9 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Tue Nov 22 2022 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+
* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 0.11.0-1
- update to 0.11.0