summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-simplepie.spec43
2 files changed, 23 insertions, 48 deletions
diff --git a/makesrc.sh b/makesrc.sh
deleted file mode 100755
index 87d223d..0000000
--- a/makesrc.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/bash
-
-NAME=$(basename $PWD)
-OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
-PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
-VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
-COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
-SHORT=${COMMIT:0:7}
-
-echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
-
-echo "Cloning..."
-rm -rf $PROJECT-$COMMIT
-git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
-
-echo "Getting commit..."
-pushd $PROJECT-$COMMIT
-git checkout $COMMIT
-cp composer.json ../composer.json
-popd
-
-echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
-
-echo "Cleaning..."
-rm -rf $PROJECT-$COMMIT
-
-echo "Done."
diff --git a/php-simplepie.spec b/php-simplepie.spec
index 98b3d7c..0aba45b 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -11,42 +11,45 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
+%global gh_version 1.5.1
%global with_tests 0%{!?_without_tests:1}
-Name: php-simplepie
-Version: 1.5.1
+Name: php-%{gh_project}
+Version: %{gh_version}
Release: 1%{?dist}
Summary: A simple Atom/RSS parsing library for PHP
-Group: Development/Libraries
+Group: Development/Libraries
License: BSD
-URL: http://simplepie.org/
-# Git snapshot to retrieve test suite excluded in .gitattributes
-Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
-Source1: makesrc.sh
+URL: http://simplepie.org/
+
+# Use a git snapshot as upstream remove tests from distribution
+Source0: %{name}-%{gh_version}-%{gh_short}.tgz
+# Script to pull the git snapshot
+Source1: %{name}-makesrc.sh
# Adapt autoloader for installation tree
Patch0: %{name}-rpm.patch
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php-phpunit-PHPUnit
+BuildRequires: php-phpunit-PHPUnit
%endif
-Requires: php-IDNA_Convert
-Requires: php-curl
-Requires: php-date
-Requires: php-dom
-Requires: php-iconv
-Requires: php-libxml
-Requires: php-mbstring
-Requires: php-pcre
-Requires: php-pdo
-Requires: php-reflection
-Requires: php-xml
+Requires: php-IDNA_Convert
+Requires: php-curl
+Requires: php-date
+Requires: php-dom
+Requires: php-iconv
+Requires: php-libxml
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-pdo
+Requires: php-reflection
+Requires: php-xml
# Optional: memcache, memcached, redis, xmlreader, zlib
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
%description