summaryrefslogtreecommitdiffstats
path: root/php-simplepie.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-09 12:09:34 +0200
committerRemi Collet <remi@remirepo.net>2019-10-09 12:09:34 +0200
commit76bbe78ce30ddaca27644c641b114d6ae3e4bde1 (patch)
treef853faebe7b472c35112dc1942c6bcc125568db7 /php-simplepie.spec
parentd7d2e8af41d6ba7c5c7574f6692fcd83a9a09221 (diff)
- update to 1.5.3
- add patch for PHP 7.4 from https://github.com/simplepie/simplepie/pull/628
Diffstat (limited to 'php-simplepie.spec')
-rw-r--r--php-simplepie.spec14
1 files changed, 11 insertions, 3 deletions
diff --git a/php-simplepie.spec b/php-simplepie.spec
index e60947d..b1c34f6 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -7,11 +7,11 @@
#
# Please preserve changelog entries
#
-%global gh_commit 0e8fe72132dad765d25db4cabc69a91139af1263
+%global gh_commit 173663382a9346acd53df60c7ffb20689c9cf1f6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
-%global gh_version 1.5.2
+%global gh_version 1.5.3
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
@@ -30,6 +30,8 @@ Source1: %{name}-makesrc.sh
# Adapt autoloader for installation tree
Patch0: %{name}-rpm.patch
+# PHP 7.4
+Patch1: https://patch-diff.githubusercontent.com/raw/simplepie/simplepie/pull/628.patch
BuildArch: noarch
%if %{with_tests}
@@ -89,6 +91,7 @@ Autoloader: %{_datadir}/php/%{name}/autoloader.php
%setup -qn %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1
# fix rpmlint warnings
find . -type f -exec chmod -x {} \;
@@ -114,7 +117,7 @@ sed -e 's:@PATH@:%{buildroot}/%{_datadir}/php/%{name}:' \
-i tests/bootstrap.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -134,6 +137,11 @@ exit $ret
%changelog
+* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 1.5.3-1
+- update to 1.5.3
+- add patch for PHP 7.4 from
+ https://github.com/simplepie/simplepie/pull/628
+
* Tue Oct 2 2018 Remi Collet <remi@remirepo.net> - 1.5.2-1
- update to 1.5.2
- raise dependency on PHP 5.6