summaryrefslogtreecommitdiffstats
path: root/php-scssphp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-scssphp.spec')
-rw-r--r--php-scssphp.spec26
1 files changed, 16 insertions, 10 deletions
diff --git a/php-scssphp.spec b/php-scssphp.spec
index ba2b01b..815755f 100644
--- a/php-scssphp.spec
+++ b/php-scssphp.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-scssphp
#
-# Copyright (c) 2012-2015 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2016 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,8 +13,8 @@
%global github_owner leafo
%global github_name scssphp
-%global github_version 0.3.2
-%global github_commit 033dd027dfc8e1905ce782a687160d66d3bd65ee
+%global github_version 0.4.0
+%global github_commit 78a6f27aa4eaf70bb3ff4d13b639bab71fdaf47a
%global composer_vendor leafo
%global composer_project scssphp
@@ -53,10 +53,9 @@ BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.3.2)
+## phpcompatinfo (computed from version 0.4.0)
BuildRequires: php-ctype
BuildRequires: php-date
-BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
## Autoloader
@@ -66,17 +65,16 @@ BuildRequires: php-composer(symfony/class-loader)
Requires: php-cli
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.3.2)
+# phpcompatinfo (computed from version 0.4.0)
Requires: php-ctype
Requires: php-date
-Requires: php-json
Requires: php-mbstring
Requires: php-pcre
# Autoloader
Requires: php-composer(symfony/class-loader)
# Standard "php-{COMPOSER_VENDOR}-{COMPOSER_PROJECT}" naming
-Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
+Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -109,8 +107,7 @@ cat <<'AUTOLOAD' | tee src/autoload.php
<?php
/**
* Autoloader for %{name} and its' dependencies
- *
- * Created by %{name}-%{version}-%{release}
+ * (created by %{name}-%{version}-%{release}).
*
* @return \Symfony\Component\ClassLoader\ClassLoader
*/
@@ -158,6 +155,11 @@ install -pm 0755 bin/pscss %{buildroot}%{_bindir}/
%if %{with_tests}
%{_bindir}/phpunit --verbose \
--bootstrap %{buildroot}%{phpdir}/Leafo/ScssPhp/autoload.php
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose \
+ --bootstrap %{buildroot}%{phpdir}/Leafo/ScssPhp/autoload.php
+fi
%else
: Tests skipped
%endif
@@ -179,6 +181,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Jan 20 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.4.0-1
+- Updated to 0.4.0 (RHBZ #1274939)
+- Removed php-json dependency
+
* Sun Oct 11 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.3.2-1
- Updated to 0.3.2 (RHBZ #1268709)