summaryrefslogtreecommitdiffstats
path: root/php-scssphp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-scssphp.spec')
-rw-r--r--php-scssphp.spec21
1 files changed, 11 insertions, 10 deletions
diff --git a/php-scssphp.spec b/php-scssphp.spec
index 36d6748..a92b03d 100644
--- a/php-scssphp.spec
+++ b/php-scssphp.spec
@@ -14,14 +14,14 @@
%global github_owner leafo
%global github_name scssphp
-%global github_version 0.8.2
-%global github_commit 1b168bfee60889547e1fe55b9afdf055f6d3c58d
+%global github_version 0.8.3
+%global github_commit 2f88bb86b67883b2cb4598a9793679326dc1d3f2
%global composer_vendor leafo
%global composer_project scssphp
-# "php": ">=5.4.0"
-%global php_min_ver 5.4.0
+# "php": "^5.6.0 || ^7"
+%global php_min_ver 5.6.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -48,7 +48,7 @@ BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.8.2)
+## phpcompatinfo (computed from version 0.8.3)
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-json
@@ -62,8 +62,9 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php-cli
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.8.2)
+# phpcompatinfo (computed from version 0.8.3)
Requires: php-ctype
+Requires: php-date
Requires: php-json
Requires: php-mbstring
Requires: php-pcre
@@ -99,9 +100,6 @@ Autoloader: %{phpdir}/Leafo/ScssPhp/autoload.php
sed "/scss.inc.php/s#.*#require_once '%{phpdir}/Leafo/ScssPhp/autoload.php';#" \
-i bin/pscss
-: Fix version
-sed -e '/VERSION/s/0.7.6/0.7.7/' -i src/Version.php
-
%build
: Create autoloader
@@ -145,7 +143,7 @@ sed '/2147483647/d' -i tests/Base64VLQTest.php
%if %{with_tests}
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55 php56 php70} php71 php72 php73
+for PHP_EXEC in "" %{?rhel:php55 php56 php70} php71 php72 php73 php74
do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC
then
@@ -170,6 +168,9 @@ exit $RETURN_CODE
%changelog
+* Mon Jun 03 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.8.3-1
+- Update to 0.8.3 (RHBZ #1716011)
+
* Fri May 10 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.8.2-1
- Update to 0.8.2 (RHBZ #1703256)