summaryrefslogtreecommitdiffstats
path: root/php-scssphp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-scssphp.spec')
-rw-r--r--php-scssphp.spec61
1 files changed, 31 insertions, 30 deletions
diff --git a/php-scssphp.spec b/php-scssphp.spec
index 3a4a13c..8ced94f 100644
--- a/php-scssphp.spec
+++ b/php-scssphp.spec
@@ -2,8 +2,9 @@
#
# Fedora spec file for php-scssphp
#
-# Copyright (c) 2012-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
+# Christian Glombek <christian.glombek@rwth-aachen.de>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -13,8 +14,8 @@
%global github_owner leafo
%global github_name scssphp
-%global github_version 0.6.7
-%global github_commit 562213cd803e42ea53b0735554794c4022d8db89
+%global github_version 0.7.5
+%global github_commit 8b538d828bbb75276974605c4a1a435e939da74e
%global composer_vendor leafo
%global composer_project scssphp
@@ -29,10 +30,8 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A compiler for SCSS written in PHP
-
-Group: Development/Libraries
License: MIT
URL: http://leafo.github.io/scssphp
@@ -41,7 +40,6 @@ URL: http://leafo.github.io/scssphp
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Library version check
BuildRequires: php-cli
@@ -50,9 +48,10 @@ BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 0.6.7)
+
+## phpcompatinfo (computed from version 0.7.5)
BuildRequires: php-ctype
-BuildRequires: php-date
+BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
## Autoloader
@@ -62,16 +61,16 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php-cli
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.6.7)
+# phpcompatinfo (computed from version 0.7.5)
Requires: php-ctype
-Requires: php-date
+Requires: php-json
Requires: php-mbstring
Requires: php-pcre
# Autoloader
Requires: php-composer(fedora/autoloader)
# Standard "php-{COMPOSER_VENDOR}-{COMPOSER_PROJECT}" naming
-Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
+Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -114,8 +113,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
: Lib
mkdir -p %{buildroot}%{phpdir}/Leafo/ScssPhp
cp -pr src/* %{buildroot}%{phpdir}/Leafo/ScssPhp/
@@ -135,30 +132,24 @@ install -pm 0755 bin/pscss %{buildroot}%{_bindir}/
'
%if %{with_tests}
-BOOTSTRAP=%{buildroot}%{phpdir}/Leafo/ScssPhp/autoload.php
-
-: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP
-
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || SCL_RETURN_CODE=1
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" %{?rhel:php55 php56} php70 php71 php72
+do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC
+ then
+ $PHP_EXEC $PHPUNIT --verbose \
+ --bootstrap %{buildroot}%{phpdir}/Leafo/ScssPhp/autoload.php \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.md
%doc composer.json
@@ -168,6 +159,16 @@ rm -rf %{buildroot}
%changelog
+* Sun Mar 25 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.7.5-2
+- Update get source script to save in spec directory
+- Update phpcompatinfo computed dependencies
+- Remove code sniffer dependency and test
+- Modify upstream test run
+
+* Tue Feb 13 2018 Christian Glombek <christian.glombek@rwth-aachen.de> - 0.7.5-1
+- Updated to 0.7.5 (RHBZ #1504394)
+- Use php_condesniffer for testing
+
* Sat Mar 04 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.6.7-1
- Updated to 0.6.7 (RHBZ #1426927)
- Switch autoloader to php-composer(fedora/autoloader)