summaryrefslogtreecommitdiffstats
path: root/php-scssphp.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 10:40:42 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 10:40:42 +0200
commit14ff889d735daa2c6c4228affa42684a53791830 (patch)
tree96fb4d8756ce602b501f86d4899d61e2af67637c /php-scssphp.spec
parentfb5de775bff3a728f829d6cc80907f93c5c201a7 (diff)
v0.8.2 from Fedora
Diffstat (limited to 'php-scssphp.spec')
-rw-r--r--php-scssphp.spec25
1 files changed, 18 insertions, 7 deletions
diff --git a/php-scssphp.spec b/php-scssphp.spec
index b74d2f8..36d6748 100644
--- a/php-scssphp.spec
+++ b/php-scssphp.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-scssphp
#
-# Copyright (c) 2012-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2012-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
# Christian Glombek <christian.glombek@rwth-aachen.de>
#
@@ -14,8 +14,8 @@
%global github_owner leafo
%global github_name scssphp
-%global github_version 0.7.7
-%global github_commit 1d656f8c02a3a69404bba6b28ec4e06edddf0f49
+%global github_version 0.8.2
+%global github_commit 1b168bfee60889547e1fe55b9afdf055f6d3c58d
%global composer_vendor leafo
%global composer_project scssphp
@@ -48,12 +48,13 @@ BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-
-## phpcompatinfo (computed from version 0.7.5)
+## phpcompatinfo (computed from version 0.8.2)
BuildRequires: php-ctype
+BuildRequires: php-date
BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
+BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -61,11 +62,12 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php-cli
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.7.5)
+# phpcompatinfo (computed from version 0.8.2)
Requires: php-ctype
Requires: php-json
Requires: php-mbstring
Requires: php-pcre
+Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -134,10 +136,16 @@ install -pm 0755 bin/pscss %{buildroot}%{_bindir}/
exit(version_compare("%{version}", "$version", "=") ? 0 : 1);
'
+: Skip tests requiring non-resolved dependencies
+rm -f tests/FrameworkTest.php
+
+: Skip flapping/flakey test
+sed '/2147483647/d' -i tests/Base64VLQTest.php
+
%if %{with_tests}
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php55 php56} php70 php71 php72 php73
+for PHP_EXEC in "" %{?rhel:php55 php56 php70} php71 php72 php73
do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC
then
@@ -162,6 +170,9 @@ exit $RETURN_CODE
%changelog
+* Fri May 10 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.8.2-1
+- Update to 0.8.2 (RHBZ #1703256)
+
* Fri Dec 21 2018 Remi Collet <remi@remirepo.net> - 0.7.7-1
- update to 0.7.7