summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION77
-rw-r--r--php-phalcon5.spec11
3 files changed, 57 insertions, 35 deletions
diff --git a/PHPINFO b/PHPINFO
index 086b731..d88c013 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.0.0alpha5
-Build Date => Sep 9 2021 00:00:00
+Version => 5.0.0alpha6
+Build Date => Sep 18 2021 00:00:00
Powered by Zephir => Version 0.14.0-beta.3-0be9ad5
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 650d578..233f467 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
+Extension [ <persistent> extension #121 phalcon version 5.0.0alpha6 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -1528,7 +1528,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon> abstract public method commit ] {
@@ -1542,9 +1542,9 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon> abstract public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon> abstract public method createSavepoint ] {
@@ -1882,7 +1882,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon> abstract public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -13612,7 +13612,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AdapterInterface> abstract public method commit ] {
@@ -13626,9 +13626,9 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AdapterInterface> abstract public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AdapterInterface> abstract public method describeColumns ] {
@@ -13675,7 +13675,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AdapterInterface> abstract public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -14426,15 +14426,15 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AdapterInterface, prototype Phalcon\Db\Adapter\AdapterInterface> public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon> public method convertBoundParams ] {
@@ -14475,6 +14475,10 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
}
Method [ <internal:phalcon> public method getErrorInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AdapterInterface, prototype Phalcon\Db\Adapter\AdapterInterface> public method getInternalHandler ] {
@@ -14501,7 +14505,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AdapterInterface, prototype Phalcon\Db\Adapter\AdapterInterface> public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -31422,15 +31426,15 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method convertBoundParams ] {
@@ -31471,6 +31475,10 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method getErrorInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method getInternalHandler ] {
@@ -31497,7 +31505,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -32041,9 +32049,9 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AbstractAdapter, prototype Phalcon\Db\Adapter\AdapterInterface> public method createTable ] {
@@ -32140,7 +32148,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method convertBoundParams ] {
@@ -32181,6 +32189,10 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method getErrorInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method getInternalHandler ] {
@@ -32207,7 +32219,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -32728,9 +32740,9 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method connect ] {
- Parameters [1] {
- Parameter #0 [ <optional> array or NULL $descriptor ]
+ Parameter #0 [ <optional> array $descriptor ]
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AdapterInterface, prototype Phalcon\Db\Adapter\AdapterInterface> public method describeColumns ] {
@@ -32815,7 +32827,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method convertBoundParams ] {
@@ -32856,6 +32868,10 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo> public method getErrorInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method getInternalHandler ] {
@@ -32882,7 +32898,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method lastInsertId ] {
- Parameters [1] {
- Parameter #0 [ <optional> $sequenceName ]
+ Parameter #0 [ <optional> string or NULL $name ]
}
}
@@ -65193,7 +65209,7 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
Property [ <default> private $signer ]
}
- - Methods [24] {
+ - Methods [25] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -65208,6 +65224,15 @@ Extension [ <persistent> extension #121 phalcon version 5.0.0alpha5 ] {
- Return [ Phalcon\Security\JWT\Builder ]
}
+ Method [ <internal:phalcon> public method addClaim ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> $value ]
+ }
+ - Return [ Phalcon\Security\JWT\Builder ]
+ }
+
Method [ <internal:phalcon> public method getAudience ] {
}
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index b1fc229..d30d384 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -23,7 +23,7 @@
# after 40-json.ini, 20-pdo.ini, 40-psr.ini
%global ini_name 50-%{pecl_name}.ini
%global upstream_ver 5.0.0
-%global upstream_pre alpha5
+%global upstream_pre alpha6
Name: %{?scl_prefix}php-phalcon5
Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
@@ -74,12 +74,6 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
# Don't provides php-composer(phalcon/cphalcon), not registered on packagist
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%endif
-%{?filter_setup}
-
%description
Phalcon is a web framework implemented as a C extension offering
@@ -255,6 +249,9 @@ fi
%changelog
+* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 5.0.0~alpha6-1
+- update to 5.0.0alpha6
+
* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 5.0.0~alpha5-1
- update to 5.0.0alpha5