summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-24 09:57:49 +0200
committerRemi Collet <remi@php.net>2022-09-24 09:57:49 +0200
commitc92bd05478e57fc5f9a6d90b82e413a987413da7 (patch)
tree7195e1bcdfab6ff95e82398525c87d50cd4fdff9
parentdac53af7307ea3dba18d7430375fea74ed6aa4c1 (diff)
update to 5.0.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION24
-rw-r--r--php-phalcon5.spec5
3 files changed, 27 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index bd3c933..cb7306c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.0.0
-Build Date => Sep 23 2022 00:00:00
+Version => 5.0.1
+Build Date => Sep 24 2022 00:00:00
Powered by Zephir => Version 0.16.3-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index be7024a..f5f8787 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 phalcon version 5.0.0 ] {
+Extension [ <persistent> extension #115 phalcon version 5.0.1 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -41592,13 +41592,14 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [4] {
+ Property [ private $claims = NULL ]
Property [ private $errors = NULL ]
Property [ private $timeShift = 0 ]
Property [ private $token = NULL ]
}
- - Methods [11] {
+ - Methods [13] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [2] {
@@ -41614,6 +41615,23 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0 ] {
- Return [ array ]
}
+ Method [ <internal:phalcon> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $claim ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:phalcon> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $claim ]
+ Parameter #1 [ <required> $value ]
+ }
+ - Return [ Phalcon\Encryption\Security\JWT\Validator ]
+ }
+
Method [ <internal:phalcon> public method setToken ] {
- Parameters [1] {
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index bc3846e..42e9295 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -22,7 +22,7 @@
%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.0.0
+%global upstream_ver 5.0.1
#global upstream_pre RC4
#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
@@ -250,6 +250,9 @@ fi
%changelog
+* Sat Sep 24 2022 Remi Collet <remi@remirepo.net> - 5.0.1-1
+- update to 5.0.1
+
* Fri Sep 23 2022 Remi Collet <remi@remirepo.net> - 5.0.0-1
- update to 5.0.0