summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-10 08:51:04 +0200
committerRemi Collet <remi@php.net>2022-06-10 08:51:04 +0200
commit9883836869176be4ec90e34bd2e8b6db58a3d684 (patch)
tree471058e3b83debf809a3e6fbc22b35d95407e20a
parent6a11ad0583f99f6da3e51d70efddecec4e84e2f4 (diff)
update to 5.0.0RC2
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION40
-rw-r--r--php-phalcon5.spec7
3 files changed, 41 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 726ece6..291ca46 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,9 +5,9 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.0.0RC1
-Build Date => Jun 1 2022 00:00:00
-Powered by Zephir => Version 0.16.0-4fac47b
+Version => 5.0.0RC2
+Build Date => Jun 10 2022 00:00:00
+Powered by Zephir => Version 0.16.0-$Id$
Directive => Local Value => Master Value
phalcon.db.escape_identifiers => On => On
diff --git a/REFLECTION b/REFLECTION
index 2d9fc2e..28b94cb 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
+Extension [ <persistent> extension #116 phalcon version 5.0.0RC2 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -68,7 +68,7 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
}
}
- - Classes [615] {
+ - Classes [616] {
Interface [ <internal:phalcon> interface Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -6459,7 +6459,7 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
- Return [ Phalcon\Html\Escaper\EscaperInterface ]
}
- Method [ <internal:phalcon> abstract public method setHtmlQuoteType ] {
+ Method [ <internal:phalcon> abstract public method setFlags ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
@@ -42205,7 +42205,7 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
Class [ <internal:phalcon> class Phalcon\Filter\Filter implements Phalcon\Filter\FilterInterface ] {
- - Constants [21] {
+ - Constants [22] {
Constant [ public string FILTER_ABSINT ] { absint }
Constant [ public string FILTER_ALNUM ] { alnum }
Constant [ public string FILTER_ALPHA ] { alpha }
@@ -42221,6 +42221,7 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
Constant [ public string FILTER_SPECIAL ] { special }
Constant [ public string FILTER_SPECIALFULL ] { specialfull }
Constant [ public string FILTER_STRING ] { string }
+ Constant [ public string FILTER_STRING_LEGACY ] { stringlegacy }
Constant [ public string FILTER_STRIPTAGS ] { striptags }
Constant [ public string FILTER_TRIM ] { trim }
Constant [ public string FILTER_UPPER ] { upper }
@@ -42752,6 +42753,31 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
Method [ <internal:phalcon> public method __invoke ] {
- Parameters [1] {
+ Parameter #0 [ <required> string $input ]
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:phalcon> class Phalcon\Filter\Sanitize\StringValLegacy ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:phalcon> public method __invoke ] {
+
+ - Parameters [1] {
Parameter #0 [ <required> $input ]
}
}
@@ -52969,15 +52995,15 @@ Extension [ <persistent> extension #116 phalcon version 5.0.0RC1 ] {
- Return [ Phalcon\Html\Escaper\EscaperInterface ]
}
- Method [ <internal:phalcon> public method setFlags ] {
+ Method [ <internal:phalcon, prototype Phalcon\Html\Escaper\EscaperInterface> public method setFlags ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
}
- - Return [ Phalcon\Html\Escaper ]
+ - Return [ Phalcon\Html\Escaper\EscaperInterface ]
}
- Method [ <internal:phalcon, prototype Phalcon\Html\Escaper\EscaperInterface> public method setHtmlQuoteType ] {
+ Method [ <internal:phalcon> public method setHtmlQuoteType ] {
- Parameters [1] {
Parameter #0 [ <required> int $flags ]
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 763380b..1974fb4 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -23,8 +23,8 @@
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
%global upstream_ver 5.0.0
-%global upstream_pre RC1
-%global upstream_low rc1
+%global upstream_pre RC2
+%global upstream_low rc2
Name: %{?scl_prefix}php-phalcon5
Version: %{upstream_ver}%{?upstream_pre:~%{upstream_low}}
@@ -250,6 +250,9 @@ fi
%changelog
+* Fri Jun 10 2022 Remi Collet <remi@remirepo.net> - 5.0.0~rc2-1
+- update to 5.0.0RC2
+
* Wed Jun 1 2022 Remi Collet <remi@remirepo.net> - 5.0.0~rc1-1
- update to 5.0.0RC1
- drop dependency on psr extension