summaryrefslogtreecommitdiffstats
path: root/php-pggi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pggi.spec')
-rw-r--r--php-pggi.spec34
1 files changed, 20 insertions, 14 deletions
diff --git a/php-pggi.spec b/php-pggi.spec
index 8f3a26c..374cc6c 100644
--- a/php-pggi.spec
+++ b/php-pggi.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pggi
#
-# Copyright (c) 2018 Remi Collet
+# Copyright (c) 2018-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%{?scl: %scl_package php-pggi}
-%global gh_commit daac9120e3eb3f0f07a469aee9a89923b79f8643
+%global gh_commit e7ccc179b142ded3746ca75f912f4c5f3eba0a89
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Letargie
%global gh_project pggi
@@ -17,19 +17,15 @@
Summary: GTK bindings
Name: %{?scl_prefix}php-pggi
-Version: 0.3.0
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.4.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# https://github.com/Letargie/pggi/pull/8
-Patch0: https://patch-diff.githubusercontent.com/raw/Letargie/pggi/pull/8.patch
-# https://github.com/Letargie/pggi/pull/9
-Patch1: https://patch-diff.githubusercontent.com/raw/Letargie/pggi/pull/9.patch
-# https://github.com/Letargie/pggi/pull/11
-Patch2: https://patch-diff.githubusercontent.com/raw/Letargie/pggi/pull/11.patch
+# https://github.com/Letargie/pggi/pull/14
+Patch0: https://patch-diff.githubusercontent.com/raw/Letargie/pggi/pull/14.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: gtk3-devel
@@ -58,9 +54,13 @@ Obsoletes: php72u-%{pecl_name} <= %{version}
Obsoletes: php72w-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-%{pecl_name} <= %{version}
+Obsoletes: php73u-%{pecl_name} <= %{version}
Obsoletes: php73w-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-%{pecl_name} <= %{version}
+Obsoletes: php74w-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -84,9 +84,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{gh_project}-%{gh_commit} NTS
cd NTS
-%patch0 -p1 -b .pr8
-%patch1 -p1 -b .pr9
-%patch2 -p1 -b .pr11
+%patch0 -p1 -b .pr14
+find src/ -name \*.c -exec chmod -x {} \;
+find src/ -name \*.h -exec chmod -x {} \;
# Sanity check, really often broken
extver=$(sed -n '/#define PGGI_VERSION/{s/.* "//;s/".*$//;p}' src/pggi.h)
@@ -176,6 +176,12 @@ cd ../ZTS
%changelog
+* Tue Oct 8 2019 Remi Collet <remi@remirepo.net> - 0.4.0-1
+- update to 0.4.0
+- drop patches merged upstream
+- open https://github.com/Letargie/pggi/pull/14
+ fix various build warnings
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.3.0-4
- rebuild for 7.3.0beta2 new ABI