summaryrefslogtreecommitdiffstats
path: root/php-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-09 17:58:19 +0200
committerRemi Collet <remi@remirepo.net>2019-09-09 17:58:19 +0200
commit0b386592e415959287f3160cea02d287b822a99c (patch)
tree3c3136445100bd36eddec08949097d953bbb6c33 /php-mongodb.spec
parent3e8ef083c408ef2fb8a2599721a0b6847c89e77a (diff)
- update to 1.5.0
- raise dependency on PHP 5.6 - raise dependency on mongodb extension 1.6
Diffstat (limited to 'php-mongodb.spec')
-rw-r--r--php-mongodb.spec36
1 files changed, 23 insertions, 13 deletions
diff --git a/php-mongodb.spec b/php-mongodb.spec
index b61fe2b..d62f12b 100644
--- a/php-mongodb.spec
+++ b/php-mongodb.spec
@@ -6,18 +6,18 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 18fca8cc8d0c2cc07f76605760d20632bb3dab96
+%global gh_commit 6405e91ba63955bcd187d3bab9ec7327d17cc4ce
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner mongodb
#global gh_date 20151102
%global gh_project mongo-php-library
# disabled for https://fedoraproject.org/wiki/Changes/MongoDB_Removal
-%global with_tests 0
+%global with_tests 0%{?_with_tests:1}
%global psr0 MongoDB
#global prever beta2
Name: php-%{gh_owner}
-Version: 1.4.3
+Version: 1.5.0
%if 0%{?gh_date}
Release: 1%{gh_date}git%{gh_short}%{?dist}
%else
@@ -34,16 +34,20 @@ Source1: %{name}-autoload.php
BuildArch: noarch
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-json
BuildRequires: php-spl
-BuildRequires: php-pecl(mongodb) >= 1.4.0
+BuildRequires: php-pecl(mongodb) >= 1.6
BuildRequires: mongodb-server >= 2.4
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.36 || ^6.4"
+# "phpunit/phpunit": "^5.7.27 || ^6.4 || ^8.3",
+# "sebastian/comparator": "^1.0 || ^2.0 || ^3.0",
+# "squizlabs/php_codesniffer": "^3.4",
+# "symfony/phpunit-bridge": "^4.4@dev"
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit8
%else
%global phpunit %{_bindir}/phpunit
%endif
@@ -53,15 +57,16 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=5.5"
+# "php": "^5.6 || ^7.0"
# "ext-hash": "*",
# "ext-json": "*",
-# "ext-mongodb": "^1.5.0"
-Requires: php(language) >= 5.4
+# "ext-mongodb": "^1.6"
+Requires: php(language) >= 5.6
Requires: php-hash
Requires: php-json
-Requires: php-pecl(mongodb) >= 1.5.0
-# From phpcompatinfo report for 1.4.0
+Requires: php-pecl(mongodb) >= 1.6
+# From phpcompatinfo report for 1.5.0
+Requires: php-date
Requires: php-spl
# For autoloader
Requires: php-composer(fedora/autoloader)
@@ -129,7 +134,7 @@ ret=0
for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
fi
done
@@ -152,6 +157,11 @@ exit $ret
%changelog
+* Mon Sep 9 2019 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- raise dependency on PHP 5.6
+- raise dependency on mongodb extension 1.6
+
* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 1.4.3-1
- update to 1.4.3