summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION4
-rw-r--r--composer.json4
-rw-r--r--php-maxminddb.spec31
4 files changed, 17 insertions, 26 deletions
diff --git a/PHPINFO b/PHPINFO
index 2e9fb00..c2dd9b6 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
maxminddb
MaxMind DB Reader => enabled
-maxminddb extension version => 1.8.0
-libmaxminddb library version => 1.2.0
+maxminddb extension version => 1.9.0
+libmaxminddb library version => 1.4.3
diff --git a/REFLECTION b/REFLECTION
index 515092f..2a358b2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 maxminddb version 1.8.0 ] {
+Extension [ <persistent> extension #119 maxminddb version 1.9.0 ] {
- Classes [3] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader\InvalidDatabaseException extends Exception implements Throwable ] {
@@ -61,7 +61,7 @@ Extension [ <persistent> extension #117 maxminddb version 1.8.0 ] {
Class [ <internal:maxminddb> class MaxMind\Db\Reader ] {
- Constants [1] {
- Constant [ public string MMDB_LIB_VERSION ] { 1.2.0 }
+ Constant [ public string MMDB_LIB_VERSION ] { 1.4.3 }
}
- Static properties [0] {
diff --git a/composer.json b/composer.json
index bbb43b8..f4e7391 100644
--- a/composer.json
+++ b/composer.json
@@ -21,10 +21,10 @@
"ext-maxminddb": "A C-based database decoder that provides significantly faster lookups"
},
"conflict": {
- "ext-maxminddb": "<1.7.0,>=2.0.0"
+ "ext-maxminddb": "<1.9.0,>=2.0.0"
},
"require-dev": {
- "friendsofphp/php-cs-fixer": "2.*",
+ "friendsofphp/php-cs-fixer": "*",
"phpunit/phpunit": ">=8.0.0,<10.0.0",
"php-coveralls/php-coveralls": "^2.1",
"phpunit/phpcov": ">=6.0.0",
diff --git a/php-maxminddb.spec b/php-maxminddb.spec
index 3671bb4..d73e0ad 100644
--- a/php-maxminddb.spec
+++ b/php-maxminddb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-maxminddb
#
-# Copyright (c) 2018-2020 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
-%global gh_commit b566d429ac9aec10594b0935be8ff38302f8d5c8
+%global gh_commit 9ee9ba9ee287b119e9f5a8e8dbfea0b49647cec4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner maxmind
%global gh_project MaxMind-DB-Reader-php
@@ -31,8 +31,8 @@
Summary: MaxMind DB Reader extension
Name: %{?sub_prefix}php-maxminddb
-Version: 1.8.0
-%global rpmrel 2
+Version: 1.9.0
+%global rpmrel 1
Release: %{rpmrel}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -61,29 +61,17 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-%{pecl_name} <= %{version}
-Obsoletes: php72w-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-%{pecl_name} <= %{version}
-Obsoletes: php73w-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-%{pecl_name} <= %{version}
-Obsoletes: php74w-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
MaxMind DB is a binary file format that stores data indexed by
@@ -108,7 +96,7 @@ BuildRequires: php-fedora-autoloader-devel
BuildRequires: php-bcmath
BuildRequires: php-gmp
# from composer.json "require-dev": {
-# "friendsofphp/php-cs-fixer": "2.*",
+# "friendsofphp/php-cs-fixer": "*",
# "phpunit/phpunit": ">=8.0.0,<10.0.0",
# "php-coveralls/php-coveralls": "^2.1",
# "phpunit/phpcov": ">=6.0.0",
@@ -117,8 +105,8 @@ BuildRequires: phpunit8
%endif
# from composer.json "require": {
-# "php": ">=5.6"
-Requires: php(language) >= 5.6
+# "php": ">=7.2"
+Requires: php(language) >= 7.2
# from composer.json "suggest": {
# "ext-bcmath": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
# "ext-gmp": "bcmath or gmp is required for decoding larger integers with the pure PHP decoder",
@@ -132,7 +120,7 @@ Recommends: geolite2-country
Suggests: geolite2-city
%endif
# from composer.json "conflict": {
-# "ext-maxminddb": "<1.6.0,>=2.0.0"
+# "ext-maxminddb": "<1.9.0,>=2.0.0"
Conflicts: php-maxminddb < %{version}
# From phpcompatifo report for 1.3.0
Requires: php-filter
@@ -332,6 +320,9 @@ fi
# noarch in "remi" not in modular
%changelog
+* Fri Jan 8 2021 Remi Collet <remi@remirepo.net> - 1.9.0-1
+- update to 1.9.0
+
* Fri Oct 2 2020 Remi Collet <remi@remirepo.net> - 1.8.0-2
- update to 1.8.0
- drop patches merged upstream