summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-16 08:38:48 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-16 08:38:48 +0100
commit63797ecb6ce0801a50181eff2c7d5fc91b0e60fa (patch)
tree7e27a4015ba21e08a36be147d201f0970c28c828
parente9e3f36fad243669daaea5ac2ac1a3b07cb37df0 (diff)
php-ioncube-loader: 5.0.20
-rw-r--r--LICENSE.txt2
-rw-r--r--REFLECTION20
-rw-r--r--php-ioncube-loader.spec28
3 files changed, 38 insertions, 12 deletions
diff --git a/LICENSE.txt b/LICENSE.txt
index 412b636..8c63a6b 100644
--- a/LICENSE.txt
+++ b/LICENSE.txt
@@ -240,4 +240,4 @@ This License Agreement and any issues relating thereto shall be construed and
interpreted in accordance with the laws of England and subject to the
exclusive jurisdiction of the English courts.
-Copyright (c) 2002-2015 ionCube Ltd. Last revised 23-April-2015
+Copyright (c) 2002-2016 ionCube Ltd. Last revised 23-April-2015
diff --git a/REFLECTION b/REFLECTION
index 735011d..ca75129 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #204 ionCube Loader version <no_version> ] {
+Extension [ <persistent> extension #219 ionCube Loader version <no_version> ] {
- INI {
Entry [ ic24.enable <SYSTEM> ]
@@ -22,12 +22,12 @@ Extension [ <persistent> extension #204 ionCube Loader version <no_version> ] {
Entry [ ic24.api_check_ip <SYSTEM> ]
Current = '1'
}
+ Entry [ ic24.slt <SYSTEM> ]
+ Current = '7'
+ }
Entry [ ic24.sec.enable <SYSTEM> ]
Current = '1'
}
- Entry [ ic24.sec.alert_action <SYSTEM> ]
- Current = '–<Hñœò'
- }
Entry [ ic24.sec.exclusion_key <SYSTEM> ]
Current = ''
}
@@ -37,6 +37,12 @@ Extension [ <persistent> extension #204 ionCube Loader version <no_version> ] {
Entry [ ic24.home_dir <SYSTEM> ]
Current = ''
}
+ Entry [ ic24.sec.block_stdin <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ ic24.update_domains_retry_interval <SYSTEM> ]
+ Current = '30'
+ }
Entry [ ic24.dump_cache <SYSTEM> ]
Current = '0'
}
@@ -83,6 +89,8 @@ Extension [ <persistent> extension #204 ionCube Loader version <no_version> ] {
}
Function [ <internal:ionCube Loader> function ioncube_server_data ] {
}
+ Function [ <internal:ionCube Loader> function ic24_get_cache_id ] {
+ }
Function [ <internal:ionCube Loader> function ic24_is_authenticated ] {
}
Function [ <internal:ionCube Loader> function ic24_authentication_status ] {
@@ -131,6 +139,10 @@ Extension [ <persistent> extension #204 ionCube Loader version <no_version> ] {
}
Function [ <internal:ionCube Loader> function ic24_get_pkv ] {
}
+ Function [ <internal:ionCube Loader> function ic24_update_domains ] {
+ }
+ Function [ <internal:ionCube Loader> function ic24_cache_status ] {
+ }
Function [ <internal:ionCube Loader> function _dyuweyrj4 ] {
}
Function [ <internal:ionCube Loader> function _dyuweyrj4r ] {
diff --git a/php-ioncube-loader.spec b/php-ioncube-loader.spec
index 783aa23..da9f0e0 100644
--- a/php-ioncube-loader.spec
+++ b/php-ioncube-loader.spec
@@ -10,7 +10,12 @@
%global extname ioncube_loader
%global debug_package %{nil}
%global __debug_install_post /bin/true
+%if 0%{?rhel} == 5
+# http://forum.ioncube.com/viewtopic.php?p=10779 - ZTS module broken on EL-5
+%global with_zts 0
+%else
%global with_zts 0%{?__ztsphp:1}
+%endif
%if "%{php_version}" < "5.6"
%global ininame %{extname}.ini
%else
@@ -19,20 +24,20 @@
%endif
# Open issues
-# http://forum.ioncube.com/viewtopic.php?t=4245 - Missing LICENSE file in tarball
# http://forum.ioncube.com/viewtopic.php?t=4244 - No versio in Reflection
+# http://forum.ioncube.com/viewtopic.php?p=10779 - ZTS module broken on EL-5
+#
Name: %{?scl_prefix}php-ioncube-loader
Summary: Loader for ionCube Encoded Files with ionCube 24 support
-Version: 5.0.19
+Version: 5.0.20
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: Distribuable
Group: Development/Languages
URL: http://www.ioncube.com
-Source0: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86.tar.bz2
-Source1: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86-64.tar.bz2
-Source2: LICENSE.txt
+Source0: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86.tar.gz
+Source1: http://downloads2.ioncube.com/loader_downloads/%{extname}s_lin_x86-64.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
@@ -83,7 +88,7 @@ tar xvf %{SOURCE0}
# Drop in the bit of configuration
# Sometime file is missing
# http://forum.ioncube.com/viewtopic.php?t=4245
-[ -f ioncube/LICENSE.txt ] || cp %{SOURCE2} ioncube
+[ -f ioncube/LICENSE.txt ] || exit 1
sed -e 's/\r//' -i ioncube/*.txt
cat << 'EOF' | tee %{extname}.nts
@@ -98,12 +103,14 @@ zend_extension = %{extname}.so
;ic24.sec.block_uploaded_files = 1
;ic24.api_access_key = ''
;ic24.api_check_ip = 1
-;ic24.sec.alert_action = '^E<96><H<F1><9C><F2>'
+;ic24.slt = '7'
;ic24.sec.enable=1
;ic24.sec.exclusion_key = ''
;ic24.cache_path = ''
;ic24.dump_cache=0
;ic24.home_dir = ''
+;ic24.sec.block_stdin = '1'
+;ic24.update_domains_retry_interval = '30'
;ioncube.loader.encoded_paths = ''
;phpd = 1
;phpd.t = 1
@@ -175,6 +182,13 @@ rm -rf %{buildroot}
%changelog
+* Sat Jan 16 2016 Remi Collet <remi@remirepo.net> - 5.0.20-1
+- update to 5.0.20 (Jan 20, 2016)
+- update configuration comments, remove sec.alert_action
+ add slt, sec.block_stdin, update_domains_retry_interval
+- drop broken ZTS module on EL-5
+ http://forum.ioncube.com/viewtopic.php?p=10779
+
* Tue Oct 20 2015 Remi Collet <remi@remirepo.net> - 5.0.19-1
- update to 5.0.19 (Oct 19, 2015)