summaryrefslogtreecommitdiffstats
path: root/php-getid3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-08 09:52:05 +0100
committerRemi Collet <remi@remirepo.net>2019-02-08 09:52:05 +0100
commit80a050c456dd4c659fb9e5fa1f609944e1382e13 (patch)
tree50830269865fdf4f5e79c1ab43aff09e0ae99bc8 /php-getid3.spec
parent53ce65f8959eebaf5db5055d9c68ef77cd997b45 (diff)
update to 1.9.17HEADmaster
add weak dependencies on suggested extension
Diffstat (limited to 'php-getid3.spec')
-rw-r--r--php-getid3.spec19
1 files changed, 14 insertions, 5 deletions
diff --git a/php-getid3.spec b/php-getid3.spec
index 4c5d173..58a13cf 100644
--- a/php-getid3.spec
+++ b/php-getid3.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 7aec0d4f5fc156612f71e415d07996aee6ab8d82
+%global gh_commit d2e45f2c4f75cc7443e158757ad2d678e318685d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner JamesHeinrich
%global gh_project getID3
@@ -15,13 +15,12 @@
%global pk_project getid3
Name: php-%{pk_project}
-Version: 1.9.16
+Version: 1.9.17
Release: 1%{?dist}
Epoch: 1
License: LGPLv3+
Summary: The PHP media file parser
-Group: Development/Libraries
-URL: http://www.getid3.org/
+URL: https://www.getid3.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
@@ -38,11 +37,17 @@ Requires: php-exif
Requires: php-filter
Requires: php-gd
Requires: php-iconv
+Requires: php-json
Requires: php-libxml
Requires: php-mbstring
Requires: php-pcre
Requires: php-xml
-# Optional: dba, mysql, mysqli, sqlite3, rar
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Suggests: php-dba
+Suggests: php-mysqli
+Suggests: php-rar
+Suggests: php-sqlite3
+%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -94,6 +99,10 @@ exit ($ok ? 0 : 1);
%changelog
+* Fri Feb 8 2019 Remi Collet <remi@remirepo.net> - 1.9.17-1
+- update to 1.9.17
+- add weak dependencies on suggested extension
+
* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 1.9.16-1
- update to 1.9.16