summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore3
-rw-r--r--php-fedora-autoloader.spec41
2 files changed, 33 insertions, 11 deletions
diff --git a/.gitignore b/.gitignore
index 95b26a9..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
+clog
+package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/php-fedora-autoloader.spec b/php-fedora-autoloader.spec
index 472bb78..1eedf8e 100644
--- a/php-fedora-autoloader.spec
+++ b/php-fedora-autoloader.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-fedora-autoloader
#
-# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2021 Shawn Iwinski <shawn@iwin.ski>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -25,15 +25,18 @@
%global phpab_min_ver 1.22
%global phpab_max_ver 2.0
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+%if 0%{?fedora}
+%bcond_without tests
+%else
+%bcond_with tests
+%endif
%{!?phpdir: %global phpdir %{_datadir}/php}
%global phpab_template_dir %{phpdir}/TheSeer/Autoload/templates/ci
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?dist}
+Release: 7%{?dist}
Summary: Fedora Autoloader
License: MIT
@@ -42,17 +45,22 @@ Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{githu
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php-cli
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit6
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit8
%else
%global phpunit %{_bindir}/phpunit
%endif
BuildRequires: %{phpunit}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires:(php-composer(theseer/autoload) >= %{phpab_min_ver} with php-composer(theseer/autoload) < %{phpab_max_ver})
+%else
+BuildRequires: php-composer(theseer/autoload) < %{phpab_max_ver}
BuildRequires: php-composer(theseer/autoload) >= %{phpab_min_ver}
+%endif
BuildRequires: php-pear
## phpcompatinfo (computed from version 1.0.1)
BuildRequires: php-ctype
@@ -83,8 +91,12 @@ required and optional dependencies.
Summary: %{name} devel
Requires: %{name} = %{version}-%{release}
-Requires: php-composer(theseer/autoload) >= %{phpab_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires:(php-composer(theseer/autoload) >= %{phpab_min_ver} with php-composer(theseer/autoload) < %{phpab_max_ver})
+%else
Requires: php-composer(theseer/autoload) < %{phpab_max_ver}
+Requires: php-composer(theseer/autoload) >= %{phpab_min_ver}
+%endif
%description devel
Provides needed tools to build other packages:
@@ -119,7 +131,7 @@ cp -p res/phpab/fedora*.php.tpl %{buildroot}%{phpab_template_dir}/
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -132,11 +144,11 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "php %{phpunit}" %{?rhel:php54 php55 php56} php70 "php71 %{_bindir}/phpunit6" "php72 %{_bindir}/phpunit6" "php73 %{_bindir}/phpunit6" "php74 %{_bindir}/phpunit6"; do
+for PHP_EXEC in "php %{phpunit}" php74 php80 php81; do
set $PHP_EXEC
if [ "php" == "$1" ] || which $PHP_EXEC; then
$1 -d include_path=.:%{buildroot}%{phpdir}:%{phpdir}:%{_datadir}/pear \
- ${2:-%{_bindir}/phpunit} \
+ ${2:-%{_bindir}/phpunit8} \
--bootstrap bootstrap.php \
--verbose
fi
@@ -160,6 +172,13 @@ exit $RETURN_CODE
%changelog
+* Mon Dec 6 2021 Remi Collet <remi@remirepo.net> - 1.0.1-7
+- disable test suite on EL
+
+* Mon Mar 8 2021 Remi Collet <remi@remirepo.net> - 1.0.1-5
+- use range dependencies
+- switch to phpunit8
+
* Wed Feb 12 2020 Shawn Iwinski <shawn@iwin.ski> - 1.0.1-2
- Add tests bootstrap to fix EPEL6 build