summaryrefslogtreecommitdiffstats
path: root/php-cs-fixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-cs-fixer.spec')
-rw-r--r--php-cs-fixer.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index b10cd11..3d87926 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d40f9436e1c448d309fa995ab9c14c5c7a96f2dc
+%global gh_commit 3f0ed862f22386c55a767461ef5083bddceeed79
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.16.0
+Version: 3.17.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: PHP Coding Standards Fixer
@@ -51,7 +51,7 @@ Provides: php-cs-fixer3 = %{version}
# Bundled PHP libraries
# License BSD-3-Clause
-Provides: bundled(php-sebastian-diff) = 4.0.4
+Provides: bundled(php-sebastian-diff) = 4.0.5
# License MIT
Provides: bundled(php-composer-pcre) = 3.1.0
Provides: bundled(php-composer-semver) = 3.3.2
@@ -63,11 +63,11 @@ Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.1.2
Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-console) = v5.4.22
+Provides: bundled(php-symfony-console) = v5.4.23
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-event-dispatcher) = v5.4.22
Provides: bundled(php-symfony-event-dispatcher-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.21
+Provides: bundled(php-symfony-filesystem) = v5.4.23
Provides: bundled(php-symfony-finder) = v5.4.21
Provides: bundled(php-symfony-options-resolver) = v5.4.21
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
@@ -77,7 +77,7 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.22
+Provides: bundled(php-symfony-process) = v5.4.23
Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-stopwatch) = v5.4.21
Provides: bundled(php-symfony-string) = v5.4.22
@@ -101,7 +101,7 @@ projects. This tool does not only detect them, but also fixes them for you.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .rpm
+%patch -P0 -p1 -b .rpm
: List bundled libraries and Licenses
php -r '
@@ -155,6 +155,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 3.17.0-1
+- update to 3.17.0
+
* Mon Apr 3 2023 Remi Collet <remi@remirepo.net> - 3.16.0-1
- update to 3.16.0